none
COMM+ apps, MDAC 2.6, Oracle 10g client works fine on Server 2003. does not work on server 2008 RRS feed

  • Question

  • Hello,

    I am attempting to get an old COMM+ application that uses Oracle network utilities to communicate to and Oracle server remotely.  it works great in server 2003.  I am trying to get it to run on a server 2008 server.

    I have been working on this for some time now.  I am stuck...

    so what I have tried...

    MDAC 2.? does not work on server 2008+ as it has been renamed to WDAC and comes with the server OS.  Oracle 10g is not supported on server 2008+ you need a special version of 11g Release 2 (11.2) for Microsoft Windows (32-Bit) but the client installs are drastically different and I am not sure I have the proper elements installed (so I installed everything). 

    from what I gathered so far, reading from the Oracle database works, but when the transaction portion is invoked, I get an error like object method or something similar.  after days of searching, the only thing i found was an MDAC mismatch can cause this error.

    at one point, I did get it working, of course after trying everything and now, what fixed it.  after installing another COMM+ application, it broke again and I was never successful with getting that to work again.

    I know the COMM+ apps are a 32 bit application, so I set the following:

    • Under the (General) section, Enable the following:
      • .NET Framework Version | v2.0
      •  32-Bit Application | TRUE
      • Managed Pipeline Mode | Classic

    I used the proper component manager C:\WINDOWS\SysWOW64\mmc comexp.msc /32 and c:\windows\syswow64\regsvr32 "e:\dll folder\xyz.dll" to register the DLL's 

    I checked the following registry keys, to ensure they matched the oracle client version.

    • Navagate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC\MTxOCI:
      • if OracleXaLib is set to xa11.dll
      • if OracleSqlLib is set to SqlLib11.dll
      • "OracleOciLib"="oci.dll"
    • Navagate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MSDTC\MTxOCI
      • if OracleXaLib is set to xa11.dll
      • if OracleSqlLib is set to SqlLib11.dll
      • "OracleOciLib"="oci.dll"I

    I checked the Local DTC and set the security to use the NT AUTHORITY\NETWORK SERVICE

    Enabled XA Transactions,

    I reapplied the security setting on the entire Oracle folder to allow the Network Service access

    What am I missing?  I am NOT a developer, I have access to one who maintains the application and rewriting the app in .NET is not going to happen.  no resources.. I need to get this running on 2008 to get off of 2003.

    Thank you in advance for taking the time to read this and help if you can!

    M

    Thursday, January 7, 2016 3:41 PM