locked
Active Directory Security RRS feed

  • Question

  • User1097472472 posted

    Hi every one,

     I am using ActiveDirectoryMembershipProvider    as shown below..

    <membership defaultProvider="AspNetActiveDirectoryMembershipProvider">

    <providers>

    <remove name="AspNetActiveDirectoryMembershipProvider" />

    <add connectionStringName="ActiveDirecotryProvider"

    enablePasswordReset="true"

    requiresQuestionAndAnswer="true"

    applicationName="/"

    attributeMapUsername="userPrincipalName"

    attributeMapPasswordQuestion="nntHintQuestion"

    attributeMapPasswordAnswer="HintAnswer"

    attributeMapFailedPasswordAnswerCount="FailedPwdAnswerCount"

    attributeMapFailedPasswordAnswerTime="FailedPwdAnswerTime"

    attributeMapFailedPasswordAnswerLockoutTime="FailedPwdAnswerLockoutTime"

    connectionUsername="ADAMDOM\Administrator" connectionPassword="nunet123"

    connectionProtection="None"

    enableSearchMethods="True"

    requiresUniqueEmail="false"

    minRequiredPasswordLength="1"

    minRequiredNonalphanumericCharacters="0"

    maxInvalidPasswordAttempts="5"

    passwordAttemptWindow="10"

    passwordStrengthRegularExpression=""

    name="AspNetActiveDirectoryMembershipProvider"

    type="System.Web.Security.ActiveDirectoryMembershipProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a">

    </add>

    </providers>

    </membership>

    <authorization>

    <deny users="?"/>

    <allow users="*"/>

    </authorization>

    <machineKey validationKey='07F9EA691720BEFB69D7D726256C20FC3AFE647DCEF42E46F559C69FAC883D8A9DED4646EBD82EEA1E6370ABC1A27E861993797D94145902DAFDC932F0AA2250' decryptionKey='6FA641EC83A731EC0E968648345C515AB4083B6EDD2AE015' validation="SHA1" decryption="Auto" />

    I am experiencing problems with password format (displaying in encrypted format) in "Forgot Password" Email body.


    I  have no problem with login,create user,forgot password,changepassword  but I am getting Email body as shown below..

    Please return to the site and log in using the following information.
    User Name: geoff
    Password: 7TPm2H:f;C8K($

    is there any way to display password properly??????

    Saturday, March 4, 2006 9:04 AM

All replies

  • User1354132231 posted
    Welcome to the forums.  Unfortunately, I have not used this provider myself, so I can't really answer this one definitively for you.  However, I can suggest a way for you to figure out what is going on.  I would use Reflector to read what is happening in the provider model to see what it is expecting and really doing.

    My initial hunch is that it would not return to you the password of the user.  There is no supported way to do this with either AD or ADAM now anyway.  The only thing it could be doing is resetting the password to some random value and sending that to you.  There is no attribute that can be read to get the password directly unless you have added this yourself.

    Wednesday, March 8, 2006 5:13 PM