locked
IIS-W3SVC-WP event ID 2307 RRS feed

  • Question

  • User467127122 posted

    Hello all 

     

    Has anyone encountered event ID 2307 in application logs.  I cannot find any mention of it on MSN's TechNet.  I am getting a 'HTTP Error 503. The service is unavailable' !! with this application event log ID...

    2307 - The worker process for application pool 'Classic .NET AppPool' encountered an error 'Cannot read configuration file due to insufficient permissions' trying to read configuration data from file '\\?\C:\inetpub\temp\apppools\Classic .NET AppPool.config', line number '0'.  The data field contains the error code.   

    Also, I cannot get service ‘Microsoft .NET Framework NGEN v2.0.50727_X86’ to start and stay started.  After starting it, it drops within seconds and I cannot find any logs to explain why.

     

    Any suggestions very welcome...

     

    I have tried mvolo's 'Troubleshoot IIS errors like a pro' but it skips over the essential point of how to fix problems once located.

     

    Thanks in advance 

     

    Friday, May 21, 2010 6:56 AM

Answers

  • User467127122 posted
    Thanks for the suggestion.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>I was using anonymous but did try explicit user permissions too.  Neither worked.  I managed to get it working again just now only after unregistering IIS7 and .net framework then registering and reconfiguring them.  <o:p></o:p>It is odd that the event ID that I was getting, i.e. 2307 was not listed on the official MSN IIS7 site. No mention of it anywhere on the net.  It’s like the issue I was having didn’t really happen!  Spooky!  Maybe it was all a nightmare.  A nightmare sponsored by MS!<o:p></o:p>

    Thanks again.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, May 21, 2010 12:17 PM

All replies

  • User-1174711417 posted

     It may be a bit of a longshot but are you by chance using a domain user account for the application pool identity? I know that if the account isn't a member of IIS_WPG group, the WP will bail out which will cause the site to be unavailable.

    Friday, May 21, 2010 8:22 AM
  • User467127122 posted
    Thanks for the suggestion.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>I was using anonymous but did try explicit user permissions too.  Neither worked.  I managed to get it working again just now only after unregistering IIS7 and .net framework then registering and reconfiguring them.  <o:p></o:p>It is odd that the event ID that I was getting, i.e. 2307 was not listed on the official MSN IIS7 site. No mention of it anywhere on the net.  It’s like the issue I was having didn’t really happen!  Spooky!  Maybe it was all a nightmare.  A nightmare sponsored by MS!<o:p></o:p>

    Thanks again.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, May 21, 2010 12:17 PM
  • User-1831259175 posted

    Hi,

      I have looked everywhere for information on this Event ID 2307 and this is the only reference I can find.

     My error is as follows...

    The worker process for application pool 'DefaultAppPool' encountered an error 'Cannot read configuration file due to insufficient permissions

    ' trying to read configuration data from file '\\?\C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config', line number '0'. The data field contains the error code.

     

    Now, I have installed/re-installed both IIS and .Net  I have also changed the connect as settings to the default website that this application pool is using and the Test was successful.

    All I receive when I try to browse the default website is the 503 error and then the app pool stops and a number of these messages appear in the event viewer.

    I noticed that the previous writer mentioned that they configured the IIS but didn't elaborate as to what they configured.

    Any comments??

     

    Thanks

    Wednesday, June 30, 2010 10:30 AM
  • User-1174711417 posted

    Does ASP.NET and IIS_WPG have permissions to access the file?

    Wednesday, June 30, 2010 11:05 AM
  • User-1831259175 posted

    Hi,

     I cannot locate either of those groups when authorising them the folder.  I looked in the IIS Manager and can see that the .NET authorisation rules are set to allow all users.

     I should have mentioned that I am using Windows 7 and I have just seen that the IIS_WPG group was removed for this release.

    I have authorised IUSR and IIS_IUSRS full control just so that I can eliminate the 503 error whissh is still occurring.

     

    Thanks,

     

    Wednesday, June 30, 2010 1:56 PM
  • User969693524 posted

     I had this issue today, I had the VWD installed and the .net on a machine that has all kind of Java applications but today i wanted to test some code with iis so i installed the IIS and i had the error you was having.

     after reading some posts i went to the Application pool in the IIS and changed the .net version from 2.0 to 4.0 restarted the application pools and the websites and all working as charm...

     I think this can resolve such issue without reinstalling the .net and the iis...

     Regards,

    Gabriel

    Monday, October 3, 2011 5:53 AM