locked
VS crashing as soon as I edit master page RRS feed

  • Question

  • User-1573083504 posted

    Hi all,

    I recently got VS community 2015 update 1 (got it bundled with Unity3d) and it is absolutely unusable for me as it keeps crashing 100% of the time as soon as I get anywhere near a master page. Here is a use case that makes it crash:

    1. Open VS
    2. Click new project
    3. Choose ASP.Net web application with framework 4.5.2
    4. Choose web forms as a template
    5. When the project is created, open the master page (Site.Master)
    6. Make any insignificant change on it and save --> CRASH ("Microsoft Visual Studio 2015 has stopped working")

    Needless to say, it is extremely frustrating... 

    If it is relevant I run Windows 10 on a Mac Book Pro with Bootcamp. And I repaired VS at least 5 times already so that doesn't do it.

    Anyone has any idea what is happening here and most importantly how to solve it?

    Many thanks!

    EDIT:

    I isolated the issue. It has to do with the script manager control on the page. As soon as I remove the below VS stops crashing:

    <asp:ScriptManager runat="server">
                <Scripts>
                    <%--To learn more about bundling scripts in ScriptManager see http://go.microsoft.com/fwlink/?LinkID=301884 --%>
                    <%--Framework Scripts--%>
                    <asp:ScriptReference Name="MsAjaxBundle" />
                    <asp:ScriptReference Name="jquery" />
                    <asp:ScriptReference Name="bootstrap" />
                    <asp:ScriptReference Name="respond" />
                    <asp:ScriptReference Name="WebForms.js" Assembly="System.Web" Path="~/Scripts/WebForms/WebForms.js" />
                    <asp:ScriptReference Name="WebUIValidation.js" Assembly="System.Web" Path="~/Scripts/WebForms/WebUIValidation.js" />
                    <asp:ScriptReference Name="MenuStandards.js" Assembly="System.Web" Path="~/Scripts/WebForms/MenuStandards.js" />
                    <asp:ScriptReference Name="GridView.js" Assembly="System.Web" Path="~/Scripts/WebForms/GridView.js" />
                    <asp:ScriptReference Name="DetailsView.js" Assembly="System.Web" Path="~/Scripts/WebForms/DetailsView.js" />
                    <asp:ScriptReference Name="TreeView.js" Assembly="System.Web" Path="~/Scripts/WebForms/TreeView.js" />
                    <asp:ScriptReference Name="WebParts.js" Assembly="System.Web" Path="~/Scripts/WebForms/WebParts.js" />
                    <asp:ScriptReference Name="Focus.js" Assembly="System.Web" Path="~/Scripts/WebForms/Focus.js" />
                    <asp:ScriptReference Name="WebFormsBundle" />
                    <%--Site Scripts--%>
               </Scripts>
    </asp:ScriptManager>

    Even if I replace the above with only 

    <asp:ScriptManager runat="server">
    </asp:ScriptManager>

    the problem is there, VS starts crashing again.

    Why is that? I don't know...

    Tuesday, March 1, 2016 5:17 AM

All replies

  • User-166373564 posted

    Hi abertrand,

    If the VS crashes, you could try the following steps.

    1.In Visual Studio, click Tools, and then click Options.

    2.In the Options dialog box, clear the Automatically adjust visual experience based on client performance check box.

    3.Clear the Use hardware graphics acceleration if available check box to prevent the use of hardware graphics acceleration.

    4.Select or clear the Enable rich client visual experience check box to make sure that rich visuals are always on or off, respectively.

    When this check box is selected, rich visuals are used independent of the computer environment.

    For example, rich visuals are used when you run Visual Studio locally on a rich client and over remote desktop.

    reference:

    https://support.microsoft.com/en-us/kb/2894215

    Regards,

    Angie

    Thursday, March 3, 2016 2:49 AM
  • User-1573083504 posted

    Thank you for your reply Angie. However I had tried this already and it didn't make any difference. I ended up simply giving up trying to use Web Forms, simply unusable for me because of this. Resorted to use MVC and so far no bug!

    Friday, March 4, 2016 8:50 AM