locked
Adding root certificate from CACert RRS feed

  • Question

  • I've developed applications that I'm now looking to port over and start testing on Vista, but I am now facing a problem in not being able to add the roo certificate for CACert (www.cacert.org) to Vista.

    I get a crash in rundll32.exe

    details:

    Log Name:      Application
    Source:        Application Error
    Date:          14/12/2006 2:47:23 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Jason-PC
    Description:
    Faulting application rundll32.exe, version 6.0.6000.16386, time stamp 0x4549b0e1, faulting module CertEnroll.dll_unloaded, version 0.0.0.0, time stamp 0x4549bccf, exception code 0xc0000005, fault offset 0x6e4eba84, process id 0x10d0, application start time 0x01c71fc964ed7056.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2006-12-14T21:47:23.000Z" />
        <EventRecordID>785</EventRecordID>
        <Channel>Application</Channel>
        <Computer>Jason-PC</Computer>
        <Security />
      </System>
      <EventData>
        <Data>rundll32.exe</Data>
        <Data>6.0.6000.16386</Data>
        <Data>4549b0e1</Data>
        <Data>CertEnroll.dll_unloaded</Data>
        <Data>0.0.0.0</Data>
        <Data>4549bccf</Data>
        <Data>c0000005</Data>
        <Data>6e4eba84</Data>
        <Data>10d0</Data>
        <Data>01c71fc964ed7056</Data>
      </EventData>
    </Event>

    Any ideas?

    Thursday, December 14, 2006 10:01 PM

All replies

  • I have the same problem but no solution at the moment... can anyone help us ?
    Wednesday, May 16, 2007 6:46 AM
  • I do have the same problem with norwegian vista, so i gues it not related to language pack in any way. I would very much like a solution to this problem because i'm atm unable to use bank services with my new vista pc...
    Wednesday, May 16, 2007 9:52 PM
  • I found an alternativ method to manage the certificates without the anoying tundll32 problem.
    Run Internet Explorer as Administrator (right-click - > run as administrator) then under Tools (I think that's the english traduction) - > Internet Options - > Content - > Certificates

    So you run the Cert tool as administrator.

    When adding a certificate, don't forget to place the certificate in the right folder namely CACert : "LOCAL COMPUTER" so the certificate is installed for all users and not only for the administrator because you run the tool as admin.

    Tell me if it works on norwegian version.
    Wednesday, May 16, 2007 10:17 PM
  • Hi, sorry for late answer,  but it work like a charm for me to with norwegian vista! :-)  Thanx!

    Sunday, July 8, 2007 7:55 PM
  •  

    Works on the Danish Vista as well - I guess this is THE workaround untill Microsoft publishes a fix.

    I've also tried disabling data execution prevention (DEP) with bcdedit, which Vista reported was causing the crash, but this did not solve the problem. So the above workaround using Internet Explorer is the way to go at the moment!

    Friday, September 14, 2007 8:53 AM
  • Works fine for the same problem on the french version too, thanks a lot !
    Tuesday, October 9, 2007 8:50 PM
  • The same principle worked for me (Vista Business, US English edition) to get access to a Swedish banking system. Thanks!

     

    But why does this problem occur? Is it reasonable of Microsoft to demand this procedure to install root certificates? Does MS have a fix planned for this?

     

    Best regards,

    Hans

    Monday, November 26, 2007 12:57 PM
  • The WA work for me, with a Spanish Vista.
    Thanks.
    Thursday, December 13, 2007 2:07 PM