none
VS2015 breakpoints dont stop in VC++

    Question

  • Hi,

    I want to debug a VC++ component (a 64 bit DirectShow filter) but unfortunately, VS does not stop on the breakpoints.

    To debug, i ask to VS to launch an application (a C#, .net 4.6) that uses  my component. I'm sure that the component (the Directshow filter) is loaded and started. But VS ignores all the breakpoints that i set. It's "difficult" to debug in these conditions.

    Someone can help?

    regards

    Pascal

    Wednesday, March 29, 2017 5:00 PM

Answers

  • Hi again,

    i found the solution, here is it:

    Even if i registered the component located in my developpement folder, a copy of the component have to be put in the Windows\System32folder.

    regards

    Pascal

    • Marked as answer by pasc059 Wednesday, March 29, 2017 5:53 PM
    Wednesday, March 29, 2017 5:52 PM

All replies

  • Hi again,

    i found the solution, here is it:

    Even if i registered the component located in my developpement folder, a copy of the component have to be put in the Windows\System32folder.

    regards

    Pascal

    • Marked as answer by pasc059 Wednesday, March 29, 2017 5:53 PM
    Wednesday, March 29, 2017 5:52 PM
  • Hi Pascal,

    Thank you for sharing the answer with us.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 30, 2017 1:52 AM