locked
Windows 7 (dual boot) doesn't start (error in W8 boot)

    Question

  • Hi, I need really help: Windows 8 is, sometimes, giving an error of MEMORY.DMP, and the computer restarts and executes the scan of system files, and everythings ok, but now... the action center is telling that is a problem in system file, i restart and restart and always appear the scan. Even if i click on Windows 7, it doesn't boot. That thing of scan alway appear, only can boot in w8.

    Here is the bcedit log:

     

    Windows Boot Manager
    --------------------
    identifier              {bootmgr}
    device                  boot
    description             Windows Boot Manager
    locale                  en-US
    inherit                 {globalsettings}
    integrityservices       Enable
    default                 {current}
    resumeobject            {3657c841-f52c-11e0-8c1e-b43fc5c296ab}
    displayorder            {current}
                            {971b54c0-eb51-11e0-a1af-00251185ea38}
    toolsdisplayorder       {memdiag}
    timeout                 30
    custom:26000025         Yes

    Windows Boot Loader
    -------------------
    identifier              {current}
    device                  partition=K:
    path                    \Windows\system32\winload.exe
    description             Windows Developer Preview
    locale                  en-US
    loadoptions             DDISABLE_INTEGRITY_CHECKS
    inherit                 {bootloadersettings}
    recoverysequence        {3657c843-f52c-11e0-8c1e-b43fc5c296ab}
    integrityservices       Enable
    recoveryenabled         Yes
    osdevice                partition=K:
    systemroot              \Windows
    resumeobject            {3657c841-f52c-11e0-8c1e-b43fc5c296ab}
    nx                      OptIn
    custom:250000c2         1

    Windows Boot Loader
    -------------------
    identifier              {971b54c0-eb51-11e0-a1af-00251185ea38}
    device                  partition=C:
    path                    \Windows\system32\winload.exe
    description             Microsoft Windows 7
    locale                  en-US
    osdevice                partition=C:
    systemroot              \Windows
    resumeobject            {ad769bc9-eb52-11e0-a7d1-806e6f6e6963}

     

    Thanks for the help!



    • Edited by Deskt Friday, October 28, 2011 7:23 PM
    Friday, October 28, 2011 7:22 PM

Answers

All replies

  • lollxd,

    Can you please give information as to how you setup dual boot on your machine?

    Thanks,


    Chris
    Saturday, October 29, 2011 4:06 PM
  • Hey Chris, I launched the setup.exe in the sources of the ISO. But everything worked fine before, after that disk check i have no way to go to w7.
    Tuesday, November 1, 2011 1:17 PM
  • zip the memory.dmp and upload it.
    "A programmer is just a tool which converts caffeine into code"

    Tuesday, November 1, 2011 4:05 PM
  • Hey Andre, is there an upload specific for the forums, or i can just use a normal like mediafire?

     

     


    • Edited by Deskt Tuesday, November 1, 2011 6:02 PM
    Tuesday, November 1, 2011 6:01 PM
  • Every LiveID (the email you use to sign in here to the forums) has a SkyDrive: http://skydrive.live.com/

    Sign in with your LiveID and you can upload the zip to the public folder and post a link here in this topic.

    "A programmer is just a tool which converts caffeine into code"

    Tuesday, November 1, 2011 11:20 PM
  • https://skydrive.live.com/redir.aspx?cid=fd4dc743dcc6630a&resid=FD4DC743DCC6630A!103

     

    Thanks!

    Wednesday, November 2, 2011 6:54 PM
  • You have issues with the PCI driver. Which PCI devices do you use?

    DRIVER_POWER_STATE_FAILURE (9f)<o:p></o:p>

    A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
    Arguments:
    Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
    Arg2: fffffa8001585060, Physical Device Object of the stack
    Arg3: fffff80000d30988, nt!TRIAGE_9F_POWER on Win7, otherwise the Functional Device Object of the stack
    Arg4: fffffa8003d37350, The blocked IRP<o:p></o:p>

    Debugging Details:<o:p></o:p>

    ------------------<o:p></o:p>

    DRVPOWERSTATE_SUBCODE:  3<o:p></o:p>

    DRIVER_OBJECT: fffffa80019f9740<o:p></o:p>

    IMAGE_NAME:  pci.sys<o:p></o:p>

    DEBUG_FLR_IMAGE_TIMESTAMP:  4e546554<o:p></o:p>

    MODULE_NAME: pci<o:p></o:p>

    FAULTING_MODULE: fffff88000e78000 pci<o:p></o:p>

    DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT<o:p></o:p>

    BUGCHECK_STR:  0x9F<o:p></o:p>

    PROCESS_NAME:  System<o:p></o:p>

    CURRENT_IRQL:  2<o:p></o:p>

    STACK_TEXT:  <o:p></o:p>

    nt!KeBugCheckEx
    nt! ?? ::FNODOBFM::`string'+0x35e97
    nt!KiProcessExpiredTimerList+0x22c
    nt!KiExpireTimerTable+0x1a9
    nt!KiTimerExpiration+0xbe
    nt!KiRetireDpcList+0x2db
    nt!KiIdleLoop+0x5a<o:p></o:p>

    BUCKET_ID:  X64_0x9F_3_IMAGE_pci.sys<o:p></o:p>

    kd> !drvobj fffffa80019f9740 f<o:p></o:p>

    Driver object (fffffa80019f9740) is for:<o:p></o:p>

     \Driver\pci<o:p></o:p>

    Driver Extension List: (id , addr)<o:p></o:p>

    <o:p> </o:p>

    Device Object list:<o:p></o:p>

    fffffa80019e5be0  fffffa80019e6040  fffffa80019e7be0  fffffa8001583890<o:p></o:p>

    fffffa8001583060  fffffa8001584890  fffffa8001585890  fffffa8001585060<o:p></o:p>

    fffffa8001586890  fffffa8001586060  fffffa8001580890  fffffa8001580060<o:p></o:p>

    fffffa8001578890  fffffa8001578060  fffffa8001579890  fffffa8001579060<o:p></o:p>

    fffffa800157a890  fffffa800157a060  fffffa800157b890  fffffa800157b060<o:p></o:p>

    fffffa800157c890  fffffa800157c060  fffffa800157d890  fffffa800157d060<o:p></o:p>

    fffffa800157e890  fffffa800157e060  fffffa800157f890  fffffa80019df040<o:p></o:p>


    DriverEntry:   fffff88000eaa9e0 pci!GsDriverEntry<o:p></o:p>

    DriverStartIo: 00000000                <o:p></o:p>

    DriverUnload:  fffff88000ea6ab4             pci!PciDriverUnload<o:p></o:p>

    AddDevice:     fffff88000e9c1d0                pci!PciAddDevice<o:p></o:p>

    <o:p> </o:p>

    Dispatch routines:<o:p></o:p>

    [00] IRP_MJ_CREATE                      fffff80001193350           nt!IopInvalidDeviceRequest<o:p></o:p>

    [01] IRP_MJ_CREATE_NAMED_PIPE           fffff80001193350        nt!IopInvalidDeviceRequest<o:p></o:p>

    [02] IRP_MJ_CLOSE                       fffff80001193350             nt!IopInvalidDeviceRequest<o:p></o:p>

    [03] IRP_MJ_READ                        fffff80001193350              nt!IopInvalidDeviceRequest<o:p></o:p>

    [04] IRP_MJ_WRITE                       fffff80001193350             nt!IopInvalidDeviceRequest<o:p></o:p>

    [05] IRP_MJ_QUERY_INFORMATION           fffff80001193350      nt!IopInvalidDeviceRequest<o:p></o:p>

    [06] IRP_MJ_SET_INFORMATION             fffff80001193350           nt!IopInvalidDeviceRequest<o:p></o:p>

    [07] IRP_MJ_QUERY_EA                    fffff80001193350       nt!IopInvalidDeviceRequest<o:p></o:p>

    [08] IRP_MJ_SET_EA                      fffff80001193350            nt!IopInvalidDeviceRequest<o:p></o:p>

    [09] IRP_MJ_FLUSH_BUFFERS               fffff80001193350                nt!IopInvalidDeviceRequest<o:p></o:p>

    [0a] IRP_MJ_QUERY_VOLUME_INFORMATION    fffff80001193350        nt!IopInvalidDeviceRequest<o:p></o:p>

    [0b] IRP_MJ_SET_VOLUME_INFORMATION      fffff80001193350            nt!IopInvalidDeviceRequest<o:p></o:p>

    [0c] IRP_MJ_DIRECTORY_CONTROL           fffff80001193350         nt!IopInvalidDeviceRequest<o:p></o:p>

    [0d] IRP_MJ_FILE_SYSTEM_CONTROL         fffff80001193350      nt!IopInvalidDeviceRequest<o:p></o:p>

    [0e] IRP_MJ_DEVICE_CONTROL              fffff88000e7dea0            pci!PciDispatchDeviceControl<o:p></o:p>

    [0f] IRP_MJ_INTERNAL_DEVICE_CONTROL     fffff80001193350                nt!IopInvalidDeviceRequest<o:p></o:p>

    [10] IRP_MJ_SHUTDOWN                    fffff80001193350    nt!IopInvalidDeviceRequest<o:p></o:p>

    [11] IRP_MJ_LOCK_CONTROL                fffff80001193350               nt!IopInvalidDeviceRequest<o:p></o:p>

    [12] IRP_MJ_CLEANUP                     fffff80001193350        nt!IopInvalidDeviceRequest<o:p></o:p>

    [13] IRP_MJ_CREATE_MAILSLOT             fffff80001193350             nt!IopInvalidDeviceRequest<o:p></o:p>

    [14] IRP_MJ_QUERY_SECURITY              fffff80001193350              nt!IopInvalidDeviceRequest<o:p></o:p>

    [15] IRP_MJ_SET_SECURITY                fffff80001193350    nt!IopInvalidDeviceRequest<o:p></o:p>

    [16] IRP_MJ_POWER                       fffff88000e79710          pci!PciDispatchPnpPower<o:p></o:p>

    [17] IRP_MJ_SYSTEM_CONTROL              fffff88000ea4440            pci!PciDispatchSystemControl<o:p></o:p>

    [18] IRP_MJ_DEVICE_CHANGE               fffff80001193350              nt!IopInvalidDeviceRequest<o:p></o:p>

    [19] IRP_MJ_QUERY_QUOTA                 fffff80001193350               nt!IopInvalidDeviceRequest<o:p></o:p>

    [1a] IRP_MJ_SET_QUOTA                   fffff80001193350     nt!IopInvalidDeviceRequest<o:p></o:p>

    [1b] IRP_MJ_PNP                         fffff88000e79710              pci!PciDispatchPnpPower<o:p></o:p>

    <o:p> </o:p>

    kd> !irp fffffa8003d37350<o:p></o:p>

    Irp is active with 4 stacks 2 is current (= 0xfffffa8003d37468)<o:p></o:p>

     No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  <o:p></o:p>

         cmd  flg cl Device   File     Completion-Context<o:p></o:p>

     [  0, 0]   0  0 00000000 00000000 00000000-00000000    <o:p></o:p>

                                                   Args: 00000000 00000000 00000000 00000000<o:p></o:p>

    >[ 16, 2]   0 e0 fffffa8001585060 00000000 fffff88000e045b0-fffff88000e04570 Success Error Cancel <o:p></o:p>

                           \Driver\pci  ACPI!ACPIDeviceIrpDeviceFilterRequest<o:p></o:p>

                                                   Args: 00015400 00000001 00000004 00000003<o:p></o:p>

     [ 16, 2]   0 e1 fffffa8001581c40 00000000 00000000-00000000    pending<o:p></o:p>

                           \Driver\ACPI (IopUnloadSafeCompletion)

    Wednesday, November 9, 2011 1:40 PM
  • In Device Manager I founded PCI bus, 2 PCI Express standard Root Port, PCI standard host CPU bridge, PCI standard ISA bridge, PCI standard PCI-TO-PCI bridge and 11 PCI standard RAM Controller.

    is that?

     Oh, and sometimes I have to power off the computer pulling the plug, because it doesn't turn off.

    Wednesday, November 9, 2011 6:29 PM
  • Hey Lollzd,

     

    PCI devices are devices that connect directly to your motherboard using a PCI slot. Typically PCI devices may include video cards, sound cards, networking cards, etc.

     

    If you haven't already, you may want to try installing the latest available driver for each piece of hardware this is being used by your computer. If your computer was purchased already configured, try visiting your computer manufacturer's website to download the latest drivers. If you built your computer or added additional hardware, you'll need to visit the hardware manufacturer's website of each piece of hardware that is being used by your computer to obtain the latest driver.

     

    If one of the drivers isn't able to install successfully, try using the compatibility troubleshooter to see if it can help the driver to install properly. The compatibility troubleshooter can be opened by:

    • Enter the Start screen
    • Move your mouse to the bottom left of the screen to expand the Charms section
    • Select Search
    • Type Compatibility
    • Click Settings in the right column
    • Click Run programs made for previous versions of Windows

     

    Then follow the prompts and direct the troubleshooter to the installer for the driver. You will likely want to choose the choice for This program worked in earlier versions of Windows but won't install or run now when it is given if the latest driver is only applicable to a different version of Windows.

     

    Hope that helps.


    Steven
    Friday, November 11, 2011 11:02 PM
    Moderator
  • Hey Steven

    I think that no one understand my problem: the problem IS THE DISK CHECKING, and yeah, the MEMORY.DMP gives errors, but the disk checking it's blocking me the access of Windows 7

     

    And about the latest drivers, I have them.

    Monday, November 14, 2011 8:25 PM
  • Hey Lollxd,

     

    Please correct me if this is incorrect or if there are gaps in the information: When you choose to boot Windows 7 the disk checking screen appears and scans your hard drive for errors. After this process has completed you still cannot get into Windows 7.

    Also, what do you see after the disk check completes?

     

    Let's try switching to the Windows 7 for the default operating system to see if that provides a different result. You can do this by:

    • Boot into Windows Developer Preview
    • Enter the Start screen
    • Type Advanced System
    • Click Settings in the right column
    • Click View advanced system settings
    • Under Startup and Recovery, click Settings...
    • Under the Default operating system: drop down, select Windows 7
    • Click OK
    • Click OK
    • Restart your computer

     

    Then choose Windows 7 when given to choice to see if you can successfully boot.


    Steven
    Tuesday, November 15, 2011 12:50 AM
    Moderator
  • So, I am having a simaler issue, Windows 7 64 boot issue. looks like this-

    Windows/system32/winload.exe 0x000428

    after performing a disk image with (Acronis) to SSD then installing a upgrade to Windows 7 64bit the problem started...

    after each reboot error occures.

    I have to use the System disk everytime and run repair windows, each boot....?

    but, when I upgraded my other computer to Windows 7 64bit (First) to the hard disk then imaged to SSD, It worked, on my other computer though.???

    so, Is there a fix for this?:  Or am I back to square one to upgrade the Hard Disk then image to SSD, I really don't what to go through all the updates (3-4 hours worth)

    Please help,

     

    Mark


    • Edited by Mark H Tuesday, November 15, 2011 9:22 PM
    Tuesday, November 15, 2011 9:21 PM
  • Hey Steven, yes you are correct: but there is the Advanced System?

    Enter the start screen, type advanced system. HOW?

    I tried to change W7 to default with msconfig too

     

    Wednesday, November 16, 2011 7:28 AM
  • Hey Lollxd,

     

    If you have a keyboard attached to your system you can just begin typing when in the Start screen to begin a search. Typing Advanced System will give you the option to open "View advanced system settings" in the Settings list of search results.

     

    If you don't have a keyboard attached to your computer and use touch instead, try following these steps:

    • Enter the Start screen
    • Touch your finger to the right edge of your screen and drag your finger toward the center of the screen
    • Touch Search in the Charms menu that appeared on the right side of the screen
    • Touch Settings
    • Touch the search box to open the touch keyboard
    • Type Advanced System
    • Click View advanced system settings
    • Under Startup and Recovery, click Settings...
    • Under the Default operating system: drop down, select Windows 7
    • Click OK
    • Click OK
    • Restart your computer

    Steven
    Wednesday, November 16, 2011 9:42 PM
    Moderator
  • Hey Mark,

     

    This forum is for discussion and questions regarding the Windows Developer Preview, unless you also have Windows Developer Preview installed and this has caused problems with booting Windows 7. For assistance with Windows 7, please reach out to the Microsoft Answers community linked below.
    Microsoft Answers - Windows 7


    Steven
    Wednesday, November 16, 2011 9:49 PM
    Moderator
  • EDIT:

     Is there any way to deactivate the disk check on Windows startup??

     

    Hey Steven,

    thanks for all of your help, but nothing yet. The disk check is running and running every time that i restart, and doesn't let me access Windows 7.

    Maybe I should wait for a new build of W8 and install it..

    but thanks for all your help stev!



    • Edited by Deskt Thursday, November 17, 2011 5:26 PM
    Thursday, November 17, 2011 5:20 PM
  • BiosVersion = P01-A0
    BiosReleaseDate = 09/02/2009
    SystemManufacturer = eMachines
    SystemProductName = EL1830

    Update the BIOS to P01.A2 and try again:

    http://support.gateway.com/us/en/emac/product/default.aspx?modelId=1808


    "A programmer is just a tool which converts caffeine into code"

    Friday, November 18, 2011 10:38 PM
  • Upgraded, but the problem stills. The problem is the disck check, not something in the BIOS.

     

    when I upgraded, my computer starded VUUUUUUUU and I '' OMG, bye computer '' ( ironic moment ) but then it boot :)


    • Edited by Deskt Saturday, November 19, 2011 10:19 AM
    Saturday, November 19, 2011 10:18 AM
  • hello lollxd,

    lets try by repairing your Windows7 installation through the Win7 disk. Put it the drive, choose to boot with it by altering  the boot option at the start up. In the installation window that opens, you will get the option to repair your Windows, go ahead with it. Since you have already set Windows7 as your default OS, even if the installation repairs the start up, it would do no great harm, you may lose your Win 8 graphic boot manager. Later on, you can repair it too, with the same technique. 


    Irfan
    Saturday, November 19, 2011 11:23 AM
  • I have no Win7 disk. It don't came up with the computer.
    Monday, November 21, 2011 6:35 PM
  • I have no Win7 disk. It don't came up with the computer.


    Hi,

    In that case you may try going to the Windows7 Recovery drive option, see if it contains an option to repair the boot menu, try it. If it doesn't, and you get no fresh ideas, do a system recovery after backing up the necessary files.


    Irfan
    Tuesday, November 22, 2011 3:08 AM