locked
Install RRS feed

  • Question

  • User-1222009076 posted

     I am a novice in asp.net

    I cant install classifield kit. Do i have to create data base in my webhotel?

    I have upload all files too my webhotell but it not work.

    Look att www.icaapoteket.se

    I will be glad if someone can help me with step by step to make it work.

    ¨Regards club100

    Thursday, October 30, 2008 5:55 AM

Answers

  • User-1222009076 posted

    I looked at a forum and find this connection string for surftown. So i make like this. And i also created 1 databas fore membership i think. I used the control.

    C://” --> ”Windows” --> ”Microsoft.Net” --> ”Framework” -->  v2.0.50727”


    <connectionStrings>
    <clear />
    <add name="classifiedsConnection" connectionString="Data Source=My IP Number;Initial Catalog=club10450_xxx;User ID=club10670_kkk;Password=club176500"
    providerName="System.Data.SqlClient" />
    <add name="LocalSqlServer" connectionString="Data Source=My IP Number;Initial Catalog=club10450_xxx;User ID=club10670_kkk;Password=club176500"
    providerName="System.Data.SqlClient" />
    </connectionStrings>

    I dont kow if that is ok. But it still dosent work. I think this is fore the membership. I think i have to created one more database. But iam not shure.

    Regards Jorgen

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, November 3, 2008 12:12 PM

All replies

  • User730446648 posted

    I don't really have time to go through it right now, gotta go to work.

    But without really seeing your error, I can tell you that everyone has a problem uploading.

    And it's always the connection strings in your web.config

    I've gone through it before many times, if you do a search for connection strings godaddy,
    you'll find my walk through.

    Let me know if you don't find it.

    Daniel

    Thursday, October 30, 2008 10:00 AM
  • User-1222009076 posted

    I didnt find when i search. So please help if u got time.

    Regards Jorgen

    Friday, October 31, 2008 8:12 AM
  • User730446648 posted

    I'll have more time at the beginning of next week.

    But to get things started,

    First thing, who are you hosting with?

    Next show me you connection strings in your web.config

    Friday, October 31, 2008 10:53 PM
  • User-1222009076 posted

    Thx [:D]

    I am hosting with http://www.surftown.eu/default.aspx

    <connectionStrings> <add name="classifiedsConnection" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\classifiedsdb.mdf;Integrated Security=True;User Instance=True" providerName="System.Data.SqlClient"/>

    </connectionStrings>

     

    I have not created any database yet. Do i have to created one?

    Regards Jorgen

    Saturday, November 1, 2008 2:35 AM
  • User730446648 posted

    As you have your connection strings that works fine for connecting to your local project.
    But you need a different one for connecting to your online databases.
    Keep in mind the changes we are talking about here will make your local version stop working,
    so you need to have a local version, just as you have it now, and a second one for online.

     

    You do need to create two databases, and then connect to them.
    I would recommend creating two MSSQL type databases.

    My host is GoDaddy, so the format might be a little different, but here's mine.
    After you create your databases it should give you an example of how to connect to it.
    Or you'll need to contact your host provider.

    <connectionStrings>
        <add name="classifiedsConnection" connectionString="xxxxxxxxxxxxxxxxxxxxxx;
          Initial Catalog=xxxxxxxxxxx;
          User ID=xxxxxxxxx;
          Password='xxxxxxxxx';" />

        <remove name="LocalSqlServer"/>

        <add name="LocalSqlServer" connectionString="xxxxxxxxxxxxxxxxxxxxxxxxxx;
          Initial Catalog=xxxxxxxxxxxxxxx;
          User ID=xxxxxxxxxx;
          Password='xxxxxxx';" />

      </connectionStrings>

    Try a layout like that, and make sure you leave in the LocalSqlServer

    That name is referenced elsewhere as well in your web.config.

    The first reference points to your members database, and the second is the actual kit.

    Good Luck

     

    Saturday, November 1, 2008 9:43 AM
  • User-1222009076 posted

    I looked at a forum and find this connection string for surftown. So i make like this. And i also created 1 databas fore membership i think. I used the control.

    C://” --> ”Windows” --> ”Microsoft.Net” --> ”Framework” -->  v2.0.50727”


    <connectionStrings>
    <clear />
    <add name="classifiedsConnection" connectionString="Data Source=My IP Number;Initial Catalog=club10450_xxx;User ID=club10670_kkk;Password=club176500"
    providerName="System.Data.SqlClient" />
    <add name="LocalSqlServer" connectionString="Data Source=My IP Number;Initial Catalog=club10450_xxx;User ID=club10670_kkk;Password=club176500"
    providerName="System.Data.SqlClient" />
    </connectionStrings>

    I dont kow if that is ok. But it still dosent work. I think this is fore the membership. I think i have to created one more database. But iam not shure.

    Regards Jorgen

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, November 3, 2008 12:12 PM
  • User730446648 posted

    It's very possible that will work.
    But you are right, you do need another database for the kit itself.

    Good Luck

    Monday, November 3, 2008 1:08 PM
  • User-1222009076 posted

    Do i have to make 1 more connection string ? For the other database.

    Hov should i created the tables in the other database?

    Regards Jorgen

    Monday, November 3, 2008 1:45 PM
  • User730446648 posted

    Do i have to make 1 more connection string ? For the other database.

     

    No you don't.

    This is your connection strings below.
    There is already two, you just entered the same into both.
    The top one is for your members, and the second is for your classifieds.
    And you left out the remove name, I re-added it.

    EDITED FOR SECURITY

    How should i created the tables in the other database?

    That all depends on whether you added any columns to your database?
    If you did not add any new columns, or tables, then you can use the scripts that came with it.
    The default scripts are in App_Data and they are labeled as ".sql"

    I would open them in a notepad and copy it.
    Then go into your ONLINE database, and you should find somewhere to load sql into, maybe a query analizer.

    If your host provider preloaded the member info, as most do, I would recommend deleting all the tables, views, and stored procedures.
    Only do this in your second database before you load your sql for the classifieds.

     

    If you made changes to the database, let me know and I'll walk you through creating fresh sql scripts.


     

    Monday, November 3, 2008 4:11 PM
  • User-1222009076 posted

    Sorry but i dont understand.

    I thougt the second string was for my lokal test.

    Shoul i created 1 moore database with another name?

    Those tables are in the first databas.

     aspnet_Applications dbo 03-11-2008 17:27:10 PRIMARY 0             
     aspnet_Membership dbo 03-11-2008 17:27:12 PRIMARY 0             
     aspnet_Paths dbo 03-11-2008 17:27:18 PRIMARY 0             
     aspnet_PersonalizationAllUsers dbo 03-11-2008 17:27:18 PRIMARY 0             
     aspnet_PersonalizationPerUser dbo 03-11-2008 17:27:18 PRIMARY 0             
     aspnet_Profile dbo 03-11-2008 17:27:14 PRIMARY 0             
     aspnet_Roles dbo 03-11-2008 17:27:16 PRIMARY 0             
     aspnet_SchemaVersions dbo 03-11-2008 17:27:10 PRIMARY 6             
     aspnet_Users dbo 03-11-2008 17:27:10 PRIMARY 0             
     aspnet_UsersInRoles dbo 03-11-2008 17:27:16 PRIMARY 0             
     aspnet_WebEvent_Events

    Now i have created 1 more databas.

    The name of the new database are club100_kkkk and there are no tables

    Regards Jorgen

     

    Tuesday, November 4, 2008 9:34 AM
  • User730446648 posted

    I am assuming that the first one has a lot of tables.
    (This is your members database, and it is the second connection)

    EARLIER I SAID THE MEMBERS DATABASE WAS FIRST, THAT WAS WRONG.
    THE CLASSIFIEDS CONNECTION IS FIRST, AND THE MEMBERS IS SECOND.

    So the last database you created with no tables in it sounds like it's ready for loading your .sql scripts.

    I think you have to load "classifieds_add.sql" and lastly the "categories.sql"
    I think there was only two, but the categories are last.

    I have no idea how to run the sql scripts on your host provider.
    Your going to have to look around, or contact them.

     

     

    Tuesday, November 4, 2008 11:20 AM
  • User-1222009076 posted

    Now i have done that. Now i got those tables in the second database

    Ads Ads club100_buy 04-11-2008 18:54:17 PRIMARY 0  Content Search   Rename Structure Extended properties Generate SQL   Drop 
    Categories Categories club100_buy 04-11-2008 18:54:17 PRIMARY 7  Content Search   Rename Structure Extended properties Generate SQL   Drop 
    Locations Locations club100_buy 04-11-2008 18:54:17 PRIMARY 0  Content Search   Rename Structure Extended properties Generate SQL   Drop 
    Members Members club100_buy 04-11-2008 18:54:17 PRIMARY 0  Content Search   Rename Structure Extended properties Generate SQL   Drop 
    Photos Photos club100_buy 04-11-2008 18:54:17 PRIMARY 0  Content Search   Rename Structure Extended properties Generate SQL   Drop 
    SavedAds SavedAds club100_buy 04-11-2008 18:54:17 PRIMARY 0  Content Search   Rename Structure Extended properties Generate SQL   Drop 

    Rehards Jörgen

    Tuesday, November 4, 2008 12:58 PM
  • User730446648 posted

    Glad to hear you got it.

    Tuesday, November 4, 2008 1:35 PM
  • User-1222009076 posted

    Its not work. I dont now why. But i think there are some prblem with the connectionstring. Do i have to change add name?

    How many connection string can i have? Can i have 2 for the webhosting and 2 to run in my computer local?

    <connectionStrings>
    <add name="classifiedsConnection" connectionString="Data Source=My IP Number;Initial Catalog=club10450_xxx;User ID=club10670_kkk;Password=club176500"
    providerName="System.Data.SqlClient" />

     <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" connectionString="Data Source=My IP Number;Initial Catalog=club10450_xxx;User ID=club10670_kkk;Password=club176500"
    providerName="System.Data.SqlClient" />
    </connectionStrings>

    Tuesday, November 4, 2008 1:47 PM
  • User730446648 posted

    You need to different web.config

    The original string

    <connectionStrings>

    <add name="classifiedsConnection" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\classifiedsdb.mdf;Integrated Security=True;User Instance=True" providerName="System.Data.SqlClient"/>

    </connectionStrings>

    Is for your local computer.

    And if that's your actual pass and username you need to edit your post immediatly.

    I still think you should contact your host provider to get the correct strings for connecting to your databases.

     

    Tuesday, November 4, 2008 3:54 PM
  • User-1222009076 posted

    I got this from my host provider. But i dont understand what they meen.

    Shoúld i use this string and make 2 connectionstring to my hostprovider. One for the membership and one for the classfield?

    Provider=SQLOLEDB;Persist Security Info=True;Server=217.199.199.199; Database=mydatabase; uid=myuserlogin;network=dbmssocn;pwd=mypass;

    Regards Jorghen

    Tuesday, November 4, 2008 4:08 PM
  • User730446648 posted

    That's your connection to one of them, now you need the other one.

    Tuesday, November 4, 2008 6:43 PM