locked
Xamarin.iOS versions are not in sync on the latest PC version versus the latest Mac Book Pro RRS feed

  • Question

  • User19386 posted

    Greetings,

    Does anyone have encounter this problem, I have updated yesterday to the latest stable version of Xamarin iOS on my PC and Mac book pro, but both version does not seems to be in sync.

    I got the following warning but cannot sync them :

    Warning 1 There is a minor mismatch between the installed Xamarin.iOS (version 8.0.0.62) on the Mac Build Host 192.168.28.1 and the local Xamarin.iOS 8.0.52.0. When applying updates, make sure to keep both the Mac and Windows in sync.

    PC Xamarin.iOS 8.0.52.0 (b38baf1c655f9fe816fee25cbd7ac78225def3e9) Visual Studio extension to enable development for Xamarin.iOS.

    Mac book Pro Xamarin.iOS Version: 8.0.0.62 (Business Edition) Hash: 8bd8158 Branch: Build date: 2014-09-18 09:12:55-0400

    Tuesday, September 23, 2014 7:14 PM

All replies

  • User13824 posted

    That warning is ignorable, but there's no way to stop it, and therefore it should be switched off. I've file a bug to request that the warning be removed:
    https://bugzilla.xamarin.com/show_bug.cgi?id=23270

    Also, I'll move this thread over to Visual Studio just to group it more closely with other similar reports.

    Tuesday, September 23, 2014 8:33 PM
  • User19386 posted

    Ok cool, thanks Brendan. I`m having another problem with signing identity, so I was not sure if that was related, but I had the feeling it was ok, since it's not an error but a warning.

    Wednesday, September 24, 2014 12:22 PM
  • User65749 posted

    I get this problem too, but I am unable to Deploy to iOS devices. Under the solution settings the "Deploy" checkbox for iOS project is grayed out.

    So the project builds, I can see the device list, but can't deploy and run.

    See attached screenshot.

    Tuesday, September 30, 2014 5:22 PM
  • User19386 posted

    Is it related to the fact that you have selected the iPhoneSimulator? I don't remember if the box is not grayed out only for real devices. Does it make a difference if you switch to iPhone?

    Tuesday, September 30, 2014 5:24 PM
  • User13824 posted

    @KashifShaikh?, the issue with the greyed out checkboxes would best be discussed in its own forum thread. Note that it's also generally discouraged to post the same question across multiple forum threads (1, 2), but it looks like these are your first posts, so no worries about that!

    That said, the greyed out checkboxes is intentional, and not itself the cause of any problems. I've posted a new thread specifically for that issue:
    http://forums.xamarin.com/discussion/25205/intentional-deploy-checkboxes-for-xamarin-ios-projects-cannot-be-checked

    If you're having trouble building or deploying, you'll need to check through the other logs, and possibly contact support, as mentioned here and here. Thanks for the report!

    Tuesday, September 30, 2014 8:14 PM