locked
SharePoint 2010, HTML Client, Unauthorized - authentication options RRS feed

  • Question

  • I understand that 2013 and LightSwitch have more integration options, but I have a SharePoint 2010 site that I'm trying to use the HTML Client on.

    I'm curious on options I have to authenticate back to SharePoint 2010 (listdata.svc - Windows Integrated Auth).  It looks like I run into the double hop issue when deployed to an IIS Site.  We do not have Kerberos configured (and getting it would be a long shot).

    Here is the setup:

    LightSwitch HTML Client -> SharePoint data source (SharePoint 2010 site w/ Windows Auth) -> Deployed to an IIS Site

    I am really experiencing the double hop problem?  Is there any other options other than Kerberos?  Can I use Forms auth on either/both the LightSwitch or SharePoint side?

    Any help would be great!

    Monday, August 19, 2013 2:43 PM

Answers

  • Hi,

    It is introduced in MSDN blog:

    When configuring Kerberos with SharePoint 2010 you will be using IIS 7.0.

    Integrated windows authentication is now handled in kernel mode and enabled by default.  This technically was primarily for ease of use and performance boosts since auth is no longer happening in user mode.  The problem is that Kernel mode authentication is not supported in SharePoint 2010.  Kernel mode authentication is disabled by default in SharePoint 2010 so will not go into further detail.

    For more detail, you can go to the link below:

    Configuring Kerberos Authentication in SharePoint 2010

    http://blogs.msdn.com/b/russmax/archive/2009/10/20/configuring-kerberos-authentication-in-sharepoint-2010-part-1.aspx 

    There is a similar question for your reference:

    LightSwitch, HTML Client, and SharePoint 2010

    http://social.msdn.microsoft.com/Forums/en-US/ec061c92-7a61-449d-be53-86d6c19f8c13/lightswitch-html-client-and-sharepoint-2010 

    Hope it helps.


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, August 21, 2013 6:35 AM