locked
SQL Agent Account not added to SQLServerAgentUser when account changed in Config manager RRS feed

  • Question

  • Had a dba setting up replication on a dev server, and ran into some file permission issues and he determined that the SQL Agent account that the Agent service runs under was not in the group SQLServerAgentUser  which is set up on install for the instance. He added the domain account used to run agent under to that group and fixed the issue. He indicated to me that the SQL Server Configuration Manager must not have been used to change that service account which is not the case. My question is should the account that runs SQL Agent be in this group? If so, what would cause it not to be added to that group?

    Thanks.

     
    Wednesday, September 12, 2012 7:54 PM

Answers

  • Hi,

    You won't see the actual domain account such as YOURDOMAIN\SQLAgentAccountName in the group but you should see a reference such as NT SERVICE\SQLAgent$InstanceName with a SID which is an SPN for the SQL agent. As you already know any changes to the services should be completed via the SQL Config Manager.

    http://msdn.microsoft.com/en-us/library/ms345578%28v=sql.100%29.aspx


    Sean Massey | Consultant, iUNITE

    Feel free to contact me through My Blog, Twitter or Hire Me.
    Please click the Mark as Answer or Vote As Helpful button if a post solves your problem or is helpful!

    • Marked as answer by Maggie Luo Saturday, September 22, 2012 6:51 PM
    Thursday, September 13, 2012 2:32 AM

All replies

  • Hi,

    You won't see the actual domain account such as YOURDOMAIN\SQLAgentAccountName in the group but you should see a reference such as NT SERVICE\SQLAgent$InstanceName with a SID which is an SPN for the SQL agent. As you already know any changes to the services should be completed via the SQL Config Manager.

    http://msdn.microsoft.com/en-us/library/ms345578%28v=sql.100%29.aspx


    Sean Massey | Consultant, iUNITE

    Feel free to contact me through My Blog, Twitter or Hire Me.
    Please click the Mark as Answer or Vote As Helpful button if a post solves your problem or is helpful!

    • Marked as answer by Maggie Luo Saturday, September 22, 2012 6:51 PM
    Thursday, September 13, 2012 2:32 AM
  • what I found after going through this was consistent with Sean's reply. I did not need to add the specific domain account used for sql server as the dba setting this up reported. I did have to add the account being used for replicaton to have permissions to the repldata folder under the instance directory. After I did that all was well.
    Thursday, September 27, 2012 5:27 PM