none
Custom Add-in is not geting autoloaded to Outlook 2007/2010 RRS feed

  • Question

  • I have created a Custom Add-ins for Outlook Appointment using VSTO. when i am installing the Outlook Addin, Custom Add-in is not geeting autoloaded to Outlook 2007/2010. I am following the Outllook addin Msi pacakaging creation steps. Please help how to fix this issue.

    VSTO Addin Msi Packaging steps

    Monday, November 17, 2014 9:41 AM

All replies

  • Hello Narenda,

    > Custom Add-in is not geeting autoloaded to Outlook 2007/2010

    Where do you expect to see a "greeting" in Outlook? Did you add any UI customizations?

    Did you have a chance the COM Add-ins list in Outlook? Is your add-in listed there as active?

    Did you add the Registry Entries for Application-Level Add-Ins ?

    P.S. See Deploying an Office Solution by Using Windows Installer for more information.

    Monday, November 17, 2014 10:24 AM
  • I have new formRegion which is associated to AppointmentItem. It is not listed in COMAdd-in. I have added the registry entry entries. refer screen shots. Iam using Visualstudio 2010 - Setup and deployment  for package creation.

    Wednesday, November 19, 2014 6:52 AM
  • Narenda,

    Did you have a chance the COM Add-ins list in Outlook? Is your add-in listed there as active?

    Did you add the Registry Entries for Application-Level Add-Ins ?

    Wednesday, November 19, 2014 8:20 AM
  • Eugene,

    Addin appears in the COM Add-ins list and listed as active. but form region UI is not appearing, even after setting registry entries.  

    Wednesday, November 19, 2014 10:35 AM
  • Hello Narenda,

    Could you please be more specific?

    What message class did you specify for the form region? What layout did you choose for the form region?

    See Creating Outlook Form Regions for more information.

    Wednesday, November 19, 2014 10:56 AM
  • Hi Eugene,

    I am able to deploy Custom Outlook Addin by changing the Registry manifest entry.

     file:///[INSTALLDIR]Spaces.SpacesOutlook.vsto|vstolocal to file:///[INSTALLDIR]Spaces.SpacesOutlook.vsto.

    But i am getting the Two installation entries in the Program - UninstallProgram and even in the Outlook COM-Addin List . please refer attached screen shots. Please help me to resolve this issue.

    Thanks,

    Narendra 




    Monday, November 24, 2014 5:16 AM