locked
Issue installing an old WebUI in Windows 10 RRS feed

  • Question

  • User-1062383210 posted

    I'm trying to install an old WebUI to interface with a SQL Server 2008 database.  When I try to install the UI I get the following error:

    "This setup requires Internet Information Server 4.0 or higher and Windows NT 4.0, Windows 2000, or Windows XP.  This setup cannot be installed on Windows 95, Windows 98, or Windows Me.  Please install Internet Information Server and run this setup again."

    I'm running Windows 10 with the default IIS (v10) selections installed.  My research shows it should work on a Windows 7 machine, but to be fair, I dont have one to test it on.  Do you have any suggestions as to how I can get this UI installed?

    This is a stand-alone machine that is not connected to the internet so I have no security concerns, I just want to access data from an external HDD via the WebUI.

    Friday, December 11, 2020 9:26 PM

All replies

  • User690216013 posted

    Everything you described except Windows 10 is end of life and obsolete. It is not just "security concerns" but no one is going to support such on Windows 10. So stick to Windows 7 is probably your only option.

    Saturday, December 12, 2020 6:26 AM
  • User-1062383210 posted

    Thank you for the reply.  Its quite annoying because of course our IT department doesnt have Win7 machines.  My hope was to get this interface working and get the data I needed out of the database.  This is starting to sound like I either need to get a Win7 machine some how, some way, or I need to re-engineer some sort of SQL queries based on notes from 13yrs ago.

    Sunday, December 13, 2020 8:34 PM
  • User1065476709 posted

    Hi AeroApe,

    Thank you for the reply.  Its quite annoying because of course our IT department doesnt have Win7 machines.  My hope was to get this interface working and get the data I needed out of the database.  This is starting to sound like I either need to get a Win7 machine some how, some way, or I need to re-engineer some sort of SQL queries based on notes from 13yrs ago.

    There is a known issue that IIS 10 can't be recognized as an IIS 7 and above version.

    You can try to host the application on IIS 10, but you need ensure you have migrated the website via web deploy. It could be installed in web platform installer.

    Best regards,

    Sam

    Monday, December 14, 2020 8:44 AM