none
Install issues with WebStudio- .NET framework 4.0.3 not installed RRS feed

  • Question

  • I downloaded a trial version of WebExpression and it won't install XSetup.exe - NET Framword Initializaiton Error. To run this application you first must install one of the following versions of the .NET framework: v 4.0.30319.  I have .NET  Framework 4 Extended installed.  What more do I need to do?  Can anyone help?  I am running on  Vista Home Premium 2007 - Service Pace 1
    Sunday, October 3, 2010 10:06 PM

Answers

All replies

  • Hi Catherine10200,

    Thank you for your post in MSDN forums.

    4.0.30319 is the RTM .NET 4 patched up to date.

    Based on your description, I would recommend that you should verify your .NET Framework 4 RTM is installed on your machine correctly firstly.
    You could get it from the following link: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    If it failed, I would recommend that you could uninstall .NET Framework 4 via Add/Remove Program, then download .NET Framework 4 from the following link and install it.
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    Please ensure that disable anti-virus, any security software or firewall during installation. Run the installer to install .NET Framework 4 as ADMINISTRATOR.

    If any problem occurs during the installation, use Collect tool to collect the log files for further troubleshooting.

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET Framework 4
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx
    - Diagnose the cause of failure installation
       Option 1:
       Try the points mentioned here: http://social.msdn.microsoft.com/forums/en-US/vssetup/thread/0376db8f-4761-4ae5-9af2-98c53216318a#How_to_diagnoseVS2008_NETFramework_logs to diagnose the cause of failure installation.
       Option 2:
       Send vslogs.cab file to me (v-xugong@microsoft.com)
       Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Larcolais


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, October 5, 2010 3:27 AM
  • Ok,

    Sorry to keep you waiting... I have good news but not great news :)


    I again formatted my hdd and did a clean install

    1 ) I ran all updates per the MS Update Server

    2) Then I Installed .Net Framework Client 4.x Install

    3) Then I Installed .Net Framework 4.x Full Extended

    4) A system reboot just for good measure

    5) I then ran the MS .Net Framework Validation tool... It Stated .Net Framework 4 V. 4.0.30319.1 was confirmed and OK...

    6) Then took a deep breath and dared Call MS Help Desk Again... :p

    7) I recieved a call about one hour after I called again from a MS Tech Today Who was very paitent, present, and a great listener

    8) I was able to let him know that my system was clean Fresh install, no third party drivers or apps. ( NOT EVEN a Firewall, Spyware or antivirus app running NOTHING) He listened as I explained that this happened every time I tried to install any of the following: Nero 10, MS Live Essentials, Sim-City 4, MS Expression Studio 4 Ult and so on....

    9) He asked if he could attach to my machine and have control of mouse and system I.E. Registry, AppData, System Logs, and of course all .Net Framework configuration files and logs generated at the time of install.  He was able to get the package install I.D's of the actual MS Update stand alone & full extended 4.x installers

    10) He then asked me to download the 60 day trial of the App and try to install that... So that he could rule out a corrupt install / xsetup.exe found on the CD... I did just so and well I got the same error so now we know it is truly a .Net Framework error of some sort.

    11) He explained to me that he felt as though there was a problem (possibly) in the install package for certain Build Numbers of Windows.... He said that he did not feel that it was an issue of .x32 V.S. .x64 O.S.'s ... or even .Net Framework .x32 V.S. .x64 installer; but rather an error of the 4.x installer / packages. He assured me that he was again going to elevate this to an entire group of persons responsible for dealing with .Net Framework install and con-fig issues.... He then PROMISED that I would hear form him within forty eight hours....

    OK sorry for typing you to tears, I felt it best to try and relay to you as much and as clearly as possible... I hope this helps and yes I will post A.S.A.P as I learn more... I have a feeling that this issue may be addressed... and I will add that the tech who did the investigating tried 3-4 four times to run the x-setup after tweaking my PC a bit.... and he saw first hand the 4.0.4 .Net Framework error for himself...

     

    Friday, January 28, 2011 5:24 PM
  • Hi, I was wondering if you solved your issue if not ... I have and I think I can help you out...

     

     

     

    Tuesday, February 1, 2011 6:44 PM