locked
error PRJ0019: A tool returned an error code from "Performing Post-Build Event..." RRS feed

  • Question

  •  

    Hi All,

     

    I compile My project on WindowsMobile Professional 6.0 platform and get an error:

    error PRJ0019: A tool returned an error code from "Performing Post-Build Event..."

     

    Can you please explain me, what's mean current error and may be generic ways to resolve it.

    My project have multiple configurations and in other configurations solution have no compilation errors.

     

    Regards

    Evgeny 

    Sunday, August 31, 2008 4:23 PM

Answers

  • Hi

     

    That was caused by your project had a post-build event which did not return 0 (i.e. success).  You can correct it as follows:

    1.       Open the properties page of your project;

    2.       select the “Build Event” tab;

    3.       Here you can either clear the content in the “Post-build event command line” textbox, or make the command line work properly (return 0), depending on your needs.

    4.       Save and rebuild.

     

    Regards

    Chunsheng Tang

     

    Tuesday, September 2, 2008 1:50 AM

All replies

  • Hi

     

    That was caused by your project had a post-build event which did not return 0 (i.e. success).  You can correct it as follows:

    1.       Open the properties page of your project;

    2.       select the “Build Event” tab;

    3.       Here you can either clear the content in the “Post-build event command line” textbox, or make the command line work properly (return 0), depending on your needs.

    4.       Save and rebuild.

     

    Regards

    Chunsheng Tang

     

    Tuesday, September 2, 2008 1:50 AM
  • solution proven.. thank you for the answer.. i'm facing the same prob. try it.. and its works
    Friday, December 12, 2008 9:30 AM
  • Thanks, it pointed me to a sharing violation problem during post compile
    Friday, December 17, 2010 6:43 PM
  • how can we make the command line work properly (return 0)?

    can you provide a little more detail please? 

    Monday, April 25, 2011 11:35 AM
  • Hi,

    I have checked the above steps, and i have put nothing in the command line. How can i make the command line (return 0)? would it be possible to show me please. your time will be gratley appricated.

    thanks

     

     

     

     

    Monday, August 22, 2011 6:04 PM
  • Hi.

    i have same problem.

    i've used compiler is vs2008.

    copy $(TargetPath) ..\..\

    in this case has problem that "1>Project : error PRJ0019: A tool returned an error code from "Performing Post-Build Event...""

    so, i changed like this

    copy "$(TargetPath)" ..\..\

    then i solved it.

    have a nice day guys~

    Monday, October 7, 2013 3:32 AM
  • Hi thanks it worked
    Thursday, September 24, 2015 7:02 AM