locked
Required fields in edit form not allowing to submit the form RRS feed

  • Question

  • I have a new form and edit form for one of the SP list. 

    In the new form there are only around 5 fields, however, in the edit form there are around 20 fields. 

    Now here is my problem, some of the fields in 'Edit form' are required fields. However, since they are required, when I tried to submit the form using 'New form' which doesn't contain those fields, I get errors stating that I can't submit forms because I don't have any values in those required fields. 

    I tried couple workarounds but couldn't get away with it. Has anyone solved this issue yet? 

    I would really appreciate all the suggestions and comments. 


    7929

    Wednesday, March 28, 2012 1:17 AM

Answers

  • Hello,

    I'm assuming by your 2 "different" forms that these are actually 2 different views of the same form.  The 'problem' is that the views share the same datasource - which contains these required fields.  How I would handle this, is remove the requirement from the required fields (make them not required).

    Then on your "edit" view where you have the fields in the form's layout add a button as the submit button (instead of the submit button in the toolbar at the top - remove that).  Make your new submit button disabled until all of the required fields are not blank by using conditional formatting.

    Let me know if you need more direction / detail.

    Melissa

    • Marked as answer by PremShrestha Wednesday, March 28, 2012 6:03 PM
    Wednesday, March 28, 2012 12:43 PM

All replies

  • Hello,

    I'm assuming by your 2 "different" forms that these are actually 2 different views of the same form.  The 'problem' is that the views share the same datasource - which contains these required fields.  How I would handle this, is remove the requirement from the required fields (make them not required).

    Then on your "edit" view where you have the fields in the form's layout add a button as the submit button (instead of the submit button in the toolbar at the top - remove that).  Make your new submit button disabled until all of the required fields are not blank by using conditional formatting.

    Let me know if you need more direction / detail.

    Melissa

    • Marked as answer by PremShrestha Wednesday, March 28, 2012 6:03 PM
    Wednesday, March 28, 2012 12:43 PM
  • Thank you Melissa! That solves my problem! 

    7929

    Wednesday, March 28, 2012 8:52 PM