none
Sharepoint 0365 and Access queries

    Question

  • Hi,

    I am running into issues when trying to use Access against my SharePoint list. 

    Within my list, I selected "Open with Access" which then created an Access.accdb

    I get Excel worksheets that I am importing into Access then, using an Append Query, appending these items to my SP list. This is working fine, although I am curious as to why I never get a "* of records have been appended" message when complete, It just stops spinning and I have to go into the list view to see if the entries were added. Minor issue but strange.

    My real problem is trying to do update queries.  We will frequently need to update information in the SP list on a mass scale instead of individually.  Again, we will use an imported Excel sheet.

    Anytime I try to run the update query, it will only update around 25-30 records at a time then I get the message "cannot connect to server, try again later". I've tried upping the timeout property but it makes not difference.

    Is this a process that has been proven to work in the past or am I trying to make Access/SharePoint do something it's not designed for?

    Appreciate your thoughts and advice.

    Toni

    Thursday, December 22, 2016 7:13 PM

All replies

  • Hi,

    How did you update queries?

    My understanding: You clicked “Open with Access” button in list and got an Access.accdb. Then you import large excel worksheets into Access db, and got an error message “cannot connect to server, try again later”. Am I right?

    So the issue only occurs when you update large data? Everything works fine if you update few data?

    Since the error message is general, please check for the ULS logs and provide error message of this issue here.

    Thanks,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, December 23, 2016 10:15 AM
    Moderator
  • Hi Dean,

    Thanks for the reply.  I don't seem to have access to the ULS logs - I'm assuming because I'm on the cloud version of SharePoint??

    Yes, you are correct, if I just try to update less than 25 records at a time, it works typically, any more than that and it doesn't complete.

    Thanks again,

    Toni

    Friday, December 23, 2016 2:28 PM