none
visual studio 2015 surface pro 4 win forms

    Question

  • I have a very odd thing happening when I run a winform application on my SP4. It seems to reduce the form, the odd thing is when I've got the SP4 docked and running two other screens the form renders fine. It only happens when I don't have it docked.

    I'm at a loss...

    design view

    Running

    Wednesday, May 11, 2016 12:10 AM

Answers

  • Hi,

    this is because your Windows on the Surface has a high DPI setting.

    DPI Settings

    Mostly the DPI settings on Surface 4 Pro are setted to 200%.

    If you want to set the controls to fixed positions (no docking etc.) in the form you have to take the DPI settings recalculate the positions using the configured DPI.

    How to check the dpi setting of windows?

    Open the settings and search for DPI. There is a slider to adjust the settings.

    It is the page of a german windows but I think you will easily find it :)

    How to do this in win forms?

    Just use google with "DPI winforms" and you will get plenty very good tutorials.

    Regards,

    David

    Wednesday, May 11, 2016 8:32 PM