locked
Simulator Process Crash - Every Time I launch Xamarin Studio RRS feed

  • Question

  • User108517 posted

    This happens every single time I launch Xamarin Studio for the past month or two. All my software is latest and greatest. I've tried the Steady, Beta, even Alpha builds and it still happens. I've updated xCode and every SDK I can think of. It looks like an Apple issue, but I'm mainly curious if anyone else has seen this error.

    Any thoughts? Exception below:

    Process: assetsd [15600] Path: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/System/Library/Frameworks/AssetsLibrary.framework/Support/assetsd Identifier: assetsd Version: 2380.161 Code Type: X86-64 (Native) Parent Process: launchdsim [15587] Responsible: launchdsim [15587] User ID: 501

    Date/Time: 2015-05-14 06:27:40.201 -0400 OS Version: Mac OS X 10.10.3 (14D136) Report Version: 11 Anonymous UUID: 21A4CE42-6165-1DC6-09C8-78F2C6E7FBBD

    Sleep/Wake UUID: 71C35344-7F16-4BD3-9E61-CAD1F7FAD833

    Time Awake Since Boot: 1000000 seconds Time Since Wake: 1800 seconds

    Crashed Thread: 0 Dispatch queue: com.apple.assetsd.sharedPersistentStoreCoordinator

    Exception Type: EXC_CRASH (SIGABRT) Exception Codes: 0x0000000000000000, 0x0000000000000000

    Application Specific Information: * Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[__NSCFString appendString:]: nil argument' terminating with uncaught exception of type NSException abort() called CoreSimulator 117.15 - Device: com.xamarin.MTHosting.40c53b865 - Runtime: iOS 8.3 (12F69) - DeviceType: iPhone 5s

    Thursday, May 14, 2015 10:33 AM

All replies

  • User133219 posted

    I'm getting the same error. Any idea how to fix it ?

    Friday, June 5, 2015 12:51 PM
  • User108517 posted

    Still getting the same error. Updated MacOS a few times since I first got the error too. Same old procedures... new SDK, Studio versions etc.

    I've just been using my Windows machine and the build host... it got old quickly.

    Friday, June 5, 2015 12:55 PM
  • User12878 posted

    It's probable your error is a red herring, I'm assuming you're looking at the ~/Library/Logs/DiagnosticReports folder

    The more likely place the crash log exists is ~/Library/Logs/XamarinStudio-5.0

    Delete all the log files from this folder, and recreate the crash, then inspect the Ide.2015_xxxxxx.log

    Personally I can 100% crash Xamarin just by debugging an android build on simulator, change focus to the simulator, change focus to Xamarin then to anywhere else, maybe yours is similar..

    My log..

    ERROR [2015-07-15 23:55:48Z]: Xamarin Studio failed to start. Some of the assemblies required to run Xamarin Studio (for example gtk-sharp)may not be properly installed in the GAC. System.NullReferenceException: Object reference not set to an instance of an object at MonoDevelop.MacIntegration.MainToolbar.MainToolbar.AttachToolbarEvents (MonoDevelop.MacIntegration.MainToolbar.SearchBar bar) [0x00001] in /Users/builder/data/lanes/1881/8010a90f/source/monodevelop/main/src/addins/MacPlatform/MainToolbar/MainToolbar.cs:144

    Maybe that's a red herring too, perhaps Therzok can take a look. Will raise a bug report in the morning as I'm at a stand still.

    Note MDK is installed correctly (and reinstalled).

    Just downgraded to 5.8.3 and can't recreate the problem (Hurrah!). 5.9 -> 5.9.4 all are very unstable.

    Wednesday, July 15, 2015 11:04 PM
  • User12878 posted

    Been testing some more, the cause is when the Xamarin IDE isn't full width, so that the Search Bar is not present on screen, when changing focus this causes the IDE to bomb.

    The workaround for me is to ensure the IDE is wide enough so that the Search bar is present, or run it fullscreen etc. Hopefully this is the same as your problem, but paste the contents of your ide log if not.

    Thursday, July 16, 2015 7:22 AM
  • User1148 posted

    The issue with assetsd has been fixed and will ship with the next major release. It's a purely cosmetic issue and has no impact on the functionality or stability of xamarin studio. The null reference exception in the toolbar is important though! @MariusUngureanu might know more about it.

    Thanks!

    Thursday, July 16, 2015 9:16 AM
  • User12878 posted

    Cheers, I've bugged it for tracking : Bug 32002

    https://bugzilla.xamarin.com/show_bug.cgi?id=32002

    Sorry I don't have the full callstack till tonight though.

    Thursday, July 16, 2015 9:40 AM
  • User16700 posted

    Hey! Thanks for the bug report. Indeed, that's an issue with the toolbar.

    It's getting fixed for the next release, since the search bar will no longer lack space to be on screen and disappear.

    Saturday, July 18, 2015 1:20 AM