locked
cannot change the properties of empty filegroup RRS feed

  • Question

  • Good Day ,

    I installed sql server 2012 on windows2012R2 when I creat  a new filegroup and try to change like a default give me this message error:cannot change the properties of empty filegroup the filegroup must contain at least one file(Microsoft sql server , error:5050)

    Do you have an idea how I can fix it .

    Thanks in advance .

    Regards


    e

    Thursday, May 21, 2015 11:36 AM

Answers

  • Follow this (GUI Example):

    • Right click on your database, click on Properties
    • Navigate to Files Tab & add a Data File, here select newly created File group in the drop down for "Filegroup"
    • Click OK, then again
    • Right click on your database, click on Properties
    • Now navigate to Filegroups section, select the checkbox for Default
    • Click OK


    Good Luck!
    Please Mark This As Answer if it solved your issue.
    Please Vote This As Helpful if it helps to solve your issue

    • Marked as answer by zikorai Thursday, May 21, 2015 1:43 PM
    Thursday, May 21, 2015 12:00 PM

All replies

  • It is mandatory that you add a data file to the newly created file group failing which the operation you are trying to perform will be denied

    In other words, when you try to associate "default" property to a filegroup it essentially means that all the files in this file group will accommodate new DML operations such as INSERT or DELETE or UPDATE happening on the tables created in this filegroup


    Good Luck!
    Please Mark This As Answer if it solved your issue.
    Please Vote This As Helpful if it helps to solve your issue



    • Edited by Manu Kapoor Thursday, May 21, 2015 11:46 AM
    • Proposed as answer by Stan210 Thursday, May 21, 2015 11:48 AM
    Thursday, May 21, 2015 11:46 AM
  • how I can do it ?

    Thanks


    e

    Thursday, May 21, 2015 11:55 AM
  • Follow this (GUI Example):

    • Right click on your database, click on Properties
    • Navigate to Files Tab & add a Data File, here select newly created File group in the drop down for "Filegroup"
    • Click OK, then again
    • Right click on your database, click on Properties
    • Now navigate to Filegroups section, select the checkbox for Default
    • Click OK


    Good Luck!
    Please Mark This As Answer if it solved your issue.
    Please Vote This As Helpful if it helps to solve your issue

    • Marked as answer by zikorai Thursday, May 21, 2015 1:43 PM
    Thursday, May 21, 2015 12:00 PM