locked
How to Call a Custom Activity build on 4.6.1 .NETFramework RRS feed

  • General discussion

  • Hi

    I've Created a Custom Activity with .NetFramework4.6.1. And when am Calling it From Azure Data Factory it is Failing.

    For Trail and Error  I Created a Sample Project with 4.5.2 Framework and tried to Call it is working fine. But the Same if I Build on 4.6.1 and ran it, am getting. Error.

    How to Solve this Issue. Because I need to use azurekeyvalut library in my customactivity, where this library is available in only 4.6 or next versions, Not on previous Versions.

    Thursday, June 15, 2017 3:28 PM

All replies

  • Custom Activity hasn't yet support 4.6. Please stay with 4.5 for now. The upgrade is working in progress. You may want to come back and check two months later.
    Friday, June 16, 2017 2:56 AM
  • I would assume this is more related to the Azure Batch service then to ADF

    I would further say that I you have a startup-script on your Batch nodes which installes .NetFramework4.6.x this should also work just fine

    But I have not tried this yet personally

    -gerhard


    Gerhard Brueckl
    blogging @ http://blog.gbrueckl.at
    working @ http://www.pmOne.com

    Friday, June 23, 2017 11:35 AM
  • You can use AppDomain as work around. Here's the sample code: https://github.com/Azure/Azure-DataFactory/tree/master/Samples/CrossAppDomainDotNetActivitySample

    Please set .Net framework version in Domain Steup settings.

    Thursday, June 29, 2017 8:30 AM
  • Also please make sure your machine in batch pool installed 4.6 framework.
    Thursday, June 29, 2017 8:40 AM