locked
[W8.1]Unable to renew Windows 8.1 developer license: script error RRS feed

  • Question

  • Since yesterday, when i try to get a new developer license for Windows 8.1 app delelopment, i would always become a script error before the Live-ID Login screen appears. My Environment is Windows 8.1 with visual Studio 2013. I have try it on other Windows 8.1 machines, but the same error occurs.

    https://fud.community.services.support.microsoft.com/Fud/FileDownloadHandler.ashx?fid=c2a1a73e-a11b-4332-8e98-547805f2d34d


    Tuesday, November 8, 2016 10:19 AM

All replies

  • We are also facing the same issue..

    I have no idea if anyone knows what's happening here, but would appreciate some support.

    Tuesday, November 8, 2016 12:54 PM
  • Same Problem here. Since Monday I'm not able to renew my developer license under Windows 8.1 64.
    • Proposed as answer by alman asif Thursday, November 17, 2016 3:22 AM
    • Unproposed as answer by alman asif Thursday, November 17, 2016 3:22 AM
    Tuesday, November 8, 2016 1:31 PM
  • Hello everyone,

    This is a problem that is outside of the devloper community and must be fixed in an update, issued by Microsoft. But, if anyone finds a solution to this problem (highly unlikely) then please post your solution on this thread.

    The only thing I can really advise is to join a live developer chat for support.


    Tuesday, November 8, 2016 2:18 PM
  • Tuesday, November 8, 2016 2:26 PM
  • Since yesterday it's not possible anymore to download or renew developer license for Windows Store Apps. This issue is not only for us with clean machines, but for others as well. Example: Post on Stackoverflow

    Please see screenshots for the error. I really hope some MS guys will read this, as I have to provide a training and we got stuck for 2 days!!! now :(

    What's the matter here? Anyone else facing this issue?

    Detailed debugging error

    Common error window

    • Merged by Mattew Wu Wednesday, November 9, 2016 6:10 AM same issue
    Tuesday, November 8, 2016 2:46 PM
  • Sorry for inconvenience.

    We aware this issue and engineering is investigating.

    When the issue is resolved, I will update this thread.


    山川 直美 (Naomi YAMAKAWA) – Microsoft Support


    Wednesday, November 9, 2016 1:42 AM
  • Sorry for inconvenience.

    We aware this issue and engineering is investigating.

    When the issue is resolved, I will update this thread.


    山川 直美 (Naomi YAMAKAWA) – Microsoft Support


    Yamakawa-San,

    Thank you for contacting us. I am waiting for updates of writing.

    Wednesday, November 9, 2016 2:02 AM
  • Hi,

    On Windows 8.1 with both VS 2013 and VS 2015, I can not obtain a Developer's License so that I can test my Javascript/HTML 5 based Windows Store App.

    When I start the Windows Store App in the IDE, a dialog pops up saying I need a developers license. I agree. The pop up makes out like it is contacting the server. A script error dialog box pops up stating there is an error at the URL https://auth.gfx.ms/16.000.26709.00/DefaultLogon_PCore.js. I click Yes I want to continue and another error comes up saying 0x800706BE Remote Procedure Called Failed. I click Retry and I get another error 0x800706BA The RPC server is unavailable.

    I have seen this error on two different Windows 8.1 machines on two different networks. The VS 2013 version is 12.0.40629.00 Update 5 and the VS 2015 version is 14.0.25123.00 Update 2.

    I just ran the app in the VS 2013 IDE last week with no issues.

    Does anyone have a clue what is going on?

    Thanks

    • Merged by Mattew Wu Wednesday, November 9, 2016 6:06 AM same issue
    Wednesday, November 9, 2016 2:15 AM
  • I need to renew Windows Developer Licence.

    1. When I try to deploy any Windows Phone /Store application on simulator/device I get the window to renew developer licence.

    2. I click on I agree.

    3. Then there comes window stating "contacting licence server"

    4. After that there is error pop up with title "script Error".

    5. It has question - "Do you want to continue running scripts on this page?"

    6. I click "Yes" and nothing happens ahead.

    Please help me with this as I not able to renew developer licence and so it is a blocker for my windows development.

    • Merged by Mattew Wu Wednesday, November 9, 2016 5:56 AM same issue
    Wednesday, November 9, 2016 5:02 AM
  • As a workaround, if you are using domain joined Windows 8.1 PC (Pro and Enterprise edition only)

    You can configure your PCs to have a developer license that does not expire.

    Please refer following document. ("Configure PCs for Developing Windows Store Apps" section)

    Configure PCs for Developing Windows Store Apps
    https://msdn.microsoft.com/en-us/library/hh852635.aspx#BKMK_DeveloperLicense


    山川 直美 (Naomi YAMAKAWA) – Microsoft Support


    Wednesday, November 9, 2016 5:22 AM
  • Yamakawa-San

    thank you for your answer.
    This is not a domain environment, I develop it in a workgroup environment.
    We are waiting for improvement notification.

    Wednesday, November 9, 2016 6:43 AM
  • Since November 7 2016, getting a Developer's License it is not possible, on any machine running Win 8.1, Win 8.1 Enterprise and Win 10, because the Show-WindowsDeveloperLicenseRegistration stopped working.

    Actually gives a script error Line 0, Char 0, Code 0.

    The problem still continues to this minute and development of any application has stopped.

    This obviously has nothing to do with Internet Explorer versions or security settings or Advanced settings or Trusted Sites or Compatibility Views in Intranet, since i already have gone through all this, with no luck.

    Simply the https://auth.gfx.ms/16.000.26709.00/DefaultLogin_PCore.js script stops immediately, which insists error in its code.

    Does anybody know this?

    Does anyone in Microsoft know this ?

    Is there a solution or a fix or an alternative ?

    • Merged by Mattew Wu Wednesday, November 9, 2016 8:22 AM same issue
    Wednesday, November 9, 2016 6:56 AM
  • Hi Yamakawa Naomi,

    We have tried the workaround you provided above. We are still facing the "Script Error" issue.

    Tested machine : Windows 8.1 pro activated with admin access.


    Wednesday, November 9, 2016 10:05 AM
  • Naomi,

    Please keep us updated. We are in a class and need the license to complete labs!

    Thanks,

    Darren

    Wednesday, November 9, 2016 3:01 PM
  • I want to get a windows 8 developer license in order to develop windows apps, the problem is that the developer license page is blank, and a dialog box pops up , stating :Stript error , how to fix this? I would appreciate your input  
    Thursday, November 10, 2016 4:04 AM
  • Yamakawa-San,
    How long will wait?
    We are waiting for improvement response.
    Thanks
    Thursday, November 10, 2016 9:53 AM
  • We are getting the same script error while acquiring developer license in Windows 8.1 Pro tablet.

    I am trying with brand new Windows 8.1 Pro tablet. Installing our Xamarin Windows app running powershell script file, the script attempts to download developer license from Microsoft, it prompts for agree to the terms for license. After agreeing I get the same script error, clicking on Yes it blanks out the dialog it unable to get license and we are unable to install our app on the device.

    We are in tight timeline, the app needs to be tested in QA environment. Anyone have workaround for this issue?

    This can be simply reproduced with devices license already installed.

    -Open Powershell in Administrator mode,  Run the command “Unregister-WindowsDeveloperLicense”, this removes prior license. Now try install any Xamarin app using powershell script and you will be able to reproduce this error.


    Thursday, November 10, 2016 6:01 PM
  • Friday, November 11, 2016 5:12 AM
  • Hi FICKS,

    Thank you for posting here.

    Since your problem is more related to UWP and there is a similar question in that forum, I will merge it to that thread for suitable support.

    The Visual C# forum discuss and ask questions about the C# programming language, IDE, libraries, samples, and tools.

    If you have some grammar or code errors, please feel free to contact us. We will try our best to give you a solution.

    Thanks for your understanding and cooperation.

    Best Regards,

    Wendy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 11, 2016 6:33 AM
  • Hi Naomi Yamakawa,

    We are experiencing the same problem and our app development is stopped because of it, causing a lot of problems. Is it possible for you to estimate when the bug is going to get fixed?

    Thank you!


    • Edited by MV2li Friday, November 11, 2016 8:02 AM
    Friday, November 11, 2016 7:52 AM
  • Hi folks,

    I'm struggling with an issue I can't seem to find enough information to diagnose.

    I run Visual Studio 2015 both at home and at work. The home edition is covered by my MPN agreement and may or may not be the same volume licensing media as work, which is covered by an MSDN subscription. In any case, both environments are bordered by a TMG 2010 instance yet while I was able to acquire a developer licence at home, I cannot at work.

    Some more specifics are:

    Context under which the error arises:

    • Trying to create a Windows 8 universal application (specifically, an 8.1 blank app) at work (home environment is fine).
    • Running the Show-WindowsDeveloperLicenseRegistration from an elevated PowerShell prompt.

    Home environment:

    • Windows 10 Enterprise
    • Visual Studio 2015 Professional Update 3 (build 14.0.25424.00)

    Work environment:

    • Windows 8.1 Enterprise
    • Visual Studio Professional 2015 Update 3 (build 14.0.25431.01)

    I've rebuilt my work machine twice as a means to try different settings to no avail (mostly to get rid of any suspect IEAK group policy legacy garbage). I keep running into the following error:

    Checking various points within Event Viewer only reveals knock-on effect errors, nothing that appears to be related to the root cause.

    I've reset the IE security zone settings for both the Internet and Trusted Zone settings (as I added this URL at one point as a grasping-at-straws check) but, frankly, I'm all out of ideas now.

    Has anyone seen this issue and overcome it?

    As a parting note, I didn't have to do anything with TMG, IE or group policy at home. I don't run as an administrator in either environment though I have access to an administrative account and elevate only as required, yet this has presented no issues at home. Only at work.

    Cheers,
    Lain

    • Merged by 宝宝徐 Monday, November 14, 2016 1:40 AM a bug
    Friday, November 11, 2016 9:10 AM
  • Will be charged for damages…Please help us soon as possible.
    Friday, November 11, 2016 10:10 AM
  • I'm getting the same error. I'm waiting for help
    Saturday, November 12, 2016 12:44 PM
  • I checked few minutes ago, the issue still not fixed, does anyone know when the fix will be released?
    Sunday, November 13, 2016 7:06 AM
  • If you or your company has a Volume license version of Windows 8.1 or 10, you can get a Sideloading key for your testing through VLSC (Volume License Service Center) without additional charge. If you don't manage license, ask your company administrator.
    • Edited by USS-Voyager Monday, November 14, 2016 1:00 AM added without additional charge
    Monday, November 14, 2016 12:45 AM
  • As a quick update to the workaround Naomi presented earlier, the group policy settings mentioned in the workaround are ineffectual.

    I tried these both before and after the Windows rebuilds (as I didn't know about this being a widespread issue until my thread was merged half an hour ago) and they do not work as stated. Visual Studio continues to prompt for a developer licence even with these settings in place (I also had to use the "special locations" policy on account of using a roaming profile).

    This means that unless there's another way of registering for a licence - excluding the sideloading key which isn't going to be appropriate in all cases, we're at an impasse.

    Cheers,
    Lain

    Monday, November 14, 2016 2:18 AM
  • New to the community.... I have exactly the same problem.
    14 November, still the same issue...
    Come on Microsoft, fix this!!

    Monday, November 14, 2016 6:39 AM
  • Hi all, i have feedback to Microsoft last week and they replied that they are solving the problem and said it should be resolved by beginning of this week. But seems like still not resolve. I can't even seems to run my app, hindering my development.

    Any way to solve this problem?

    Monday, November 14, 2016 9:00 AM
  • Same problem here, hope for fast problem resolve...

    // Lars

    Monday, November 14, 2016 10:14 AM
  • Exceptionally frustrating, we are in the midst of massive roll out on 8.1 using the developers license and the bug is delaying deployment - hoping for a timely resolution or an appropriate fix/workaround
    Monday, November 14, 2016 11:28 AM
  • When will there be a solution to this issue? I am delivering some training this week that NEEDS this to be working.
    Tuesday, November 15, 2016 12:02 AM
  • I am in the same situation this week. How did you delivered your class?
    Tuesday, November 15, 2016 12:54 AM
  • Same problem hear.  What worked for me:

    Created new VM (Windows 10) with Visual Studio 2015.

    Copied my project as is.  Opened (upgraded) to VS 2015.

    Working now.

    Tuesday, November 15, 2016 8:55 PM
  • Because the infrastructure environment is can not change.

    Are there the measures as Windows 8.1 environment?

    When can it be fixed?How long to wait?

    Wednesday, November 16, 2016 2:30 AM
  • Windows 10 DeveloperLicense ExpirationTime is 9999/12/31 9:00:00.

    Change to developer mode..Forever 9999/12/31 9:00:00???

    Wednesday, November 16, 2016 8:38 AM
  • Sorry for inconvenience.

    We aware this issue and engineering is investigating.

    When the issue is resolved, I will update this thread.


    山川 直美 (Naomi YAMAKAWA) – Microsoft Support


    Naomi, any updates on this please? Any idea of when a fix will be released?  
    Wednesday, November 16, 2016 1:47 PM
  • Show-WindowsDeveloperLicenseRegistration still not working !!!

    Does anybody know when this will be fixed? Is anybody working on this?

    Wednesday, November 16, 2016 9:21 PM
  • Try it now. I was able to renew my developer license by running Show-WindowsDeveloperLicenseRegistration in an elevated Powershell window.
    • Edited by scookgunngrp Wednesday, November 16, 2016 10:02 PM Added more detail
    Wednesday, November 16, 2016 10:01 PM
  • scookgunngrp,

    What edition of Windows and Visual Studio were you successful with?

    As I posted earlier, I've had no issues with Windows 10 Enterprise running Visual Studio 2015 Professional at all in this period, but the problem persists (even now) under Windows 8.1 Enterprise with Visual Studio 2015.

    Cheers,
    Lain

    Wednesday, November 16, 2016 10:49 PM
  • This looks like it's fixed now.  I had the error for the past few days and now I was able to renew. \o/
    • Proposed as answer by AdamAshton Wednesday, November 16, 2016 11:54 PM
    Wednesday, November 16, 2016 11:54 PM
  • Hey All.

    I can renew developer license use windows 8.1 update version.

    thanks!!!

    Thursday, November 17, 2016 2:08 AM
  • Go for it, it has been fixed, working fine, i just tried
    Thursday, November 17, 2016 3:21 AM
  • Windows 8.1 Pro with Visual Studio 2013.
    Thursday, November 17, 2016 4:23 AM
  • NOT WORKING , ITS AGAIN SHOW SAME PROBLE

    Thursday, November 17, 2016 5:39 AM
  • Hello all,

    Sorry for inconvenience.

    According to engineering, the fix is deployed.

    It is no longer reproducible on my test PC. (Windows 8.1 Pro edition, non domain joined.)


    山川 直美 (Naomi YAMAKAWA) – Microsoft Support


    Thursday, November 17, 2016 6:09 AM
  • Hello all,

    This issue has already been fixed. If you still have any problem please feel free to post back.

    Best regards,

    Barry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Barry Wang Thursday, November 17, 2016 8:15 AM
    Thursday, November 17, 2016 8:15 AM
  • Hello,

    I had the same issue. After this fix, Now i can see the login screen but when i filled the mail address field and press continue button, alerts the new script error. The new error's information:

    Line:22 Char:218687 Error: InvalidStateError , Code:0 URL: same

    OS: Windows 8 Enterprise, Registration Method: Powershell

    Thursday, November 17, 2016 9:06 AM
  • Hello,

    Same with me. I get the feeling that it is solved for Win 8.1 and Win 2012 R2, not for Win 8 and Win 2012 as I have to use in the training setup fot the MS20487B course.

    Indeed the dialog shows up to enter your Microsoft account, but you can enter anything, a valid account for which a license was issued before, a valid account for which never a license was issued or even a fake account. All end with the same error.

    Hjalmar Milo

    Thursday, November 17, 2016 9:19 AM
  • Hi,

    I can confirm it is indeed working on WS 2012 R2 again, using the wizard in Visual Studio, so your assumption is probably correct.

    Hopefully MS can get this sorted for you and everyone else, best of luck!

    Regards

    Matt

    Thursday, November 17, 2016 10:47 AM
  • I'm still experiencing this issue on Windows Embedded 8 Standard.

    EDIT: Problem seems to be fixed now.


    • Edited by Tommi Tuovinen Friday, November 18, 2016 2:01 PM Issue fixed
    Thursday, November 17, 2016 2:14 PM
  • I am able to verify the license fix. It worked fine.

    My environment is Windows 8.1 Pro (non domain).


    • Edited by RaviLink Thursday, November 17, 2016 8:01 PM
    Thursday, November 17, 2016 8:01 PM
  • Hello,

    @ahmetesen,

    Could you retry it?
    Engineering deployed additional hotfix.

    @Hjalar, could you retry on Windows 2012 also?


    山川 直美 (Naomi YAMAKAWA) – Microsoft Support

    Friday, November 18, 2016 1:22 AM
  • Thanks Yamakawa,

    It works on my computer.

    Friday, November 18, 2016 7:11 AM
  • Hello Everyone ,

    I a using Win8.1 and VS2012(Pro). Since 7-Nov I was facing the same prob. but Yesterday(19-Nov) on the same environment I renew my developer licence and didn't get any Script Error.

    I think this error was related to MS Login Page. Which got resolved. So now we don't need to change our Development Environment .

    Thanks to Microsoft Team, for resolving the error.  

    Sunday, November 20, 2016 6:14 AM
  • Naomi,

    Sorry for my late response, I was delivering a Fast Track course. But indeed I can confirm that the course was functioning, we could use the Windows 8 and the Windows Server 2012 environments without any licensing problem!

    Hjalmar

    Tuesday, November 22, 2016 8:58 AM
  • Hi,

    I am getting the script error while trying to get a new developer license.

    I am on window 8.1.

    Tried from with in VS 2013 as well as by running cmdlet in powershell; i could enter my credentials, but after that i get the script error.

    thanks!

    -Saptar

    Wednesday, December 7, 2016 12:32 PM
  • I am getting this error when renew developer licence. I am using Visual Studio Express 2012. Can anyone help me to resolve this?

    Thanks for help


    • Edited by Asha chauhan Friday, March 31, 2017 10:10 AM
    • Merged by 宝宝徐 Monday, April 3, 2017 5:42 AM similar
    Friday, March 31, 2017 10:09 AM