none
Visual Studio 2015 Build Error: 'This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms'

    Question

  • Hey VS gang,

    I just installed VS 2015, and I get this error when building any project, even a simple HelloWorld form. I remember fixing this in VS 2010 by adding in <enforceFIPSPolicy enabled="false"/> in the devenv.exe.config file, however, that didn't work with VS 2015.

    Does anyone have a solution for VS 2015 to work around this problem?

    Thanks!

    SK

    Wednesday, April 20, 2016 8:51 PM

All replies

  • Hi SK,

    Do you have installed Update 2 for your Visual Studio 2015? If yes, please download and install it from below link.

    https://www.visualstudio.com/en-us/news/vs2015-update2-vs.aspx

    Then please try delete the registry key of FipsAlgorithmPolicy which under the path of "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa". After deleting, please restart your machine and then try again.

    Please refer to: http://stackoverflow.com/questions/14509354/this-implementation-is-not-part-of-the-windows-platform-fips-validated-cryptogra

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Friday, April 22, 2016 5:56 AM
    Moderator
  • Hey Weiwei,

    Thanks for the reply, however, we are on a government network and I've asked and we are not allowed to change the configuration of the workstations as they are set a particular way for security reasons. So I cannot remove registry keys, I cannot turn off security policies, etc.

    I need a solution fixes the problem rather than tries to work around it because of this environment that we are in.

    V/R,

    SK

    Friday, April 22, 2016 8:57 AM
  • Hi SK,

    After searching for this issue, I found that there has many communities have this issue and the resolved this issue by adding <enforceFIPSPolicy enabled="false"/> in both msbuild.exe.config and devenv.exe.config.

    Please try add the property in these files and restart your Visual Studio to check whether it can fix this issue.

    Please refer to:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/d1ce3cf7-b12e-4a76-b637-d304b254b898/cant-build-a-wpf-project-on-a-fips-enabled-system?forum=wpf

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Monday, April 25, 2016 1:46 AM
    Moderator
  • I edited the following files and put the <enforceFIPSPolicy enabled="false"/> then rebooted:

    C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\deven.exe.config

    C:\Windows\Microsoft.Net\Framework\v.4.0.30319\msbuild.exe.config

    C:\Windows\Microsoft.Net\Framework64\v.4.0.30319\msbuild.exe.config

    The FIPS errors still occur and I also get new errors as well.

    Did I do the correct files, or did I miss something?

    SK


    Monday, April 25, 2016 9:42 PM
  • Hi SK,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thanks for your understanding!

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Tuesday, April 26, 2016 2:38 AM
    Moderator
  • Hi Weiwei,

    I appreciate your efforts, because I really need a solution that I can implement quickly.

    Since the file modifications didn't work, I'd either assume I did the wrong files, or the files I edited were not the ones to fix the issue.

    SK

    Tuesday, April 26, 2016 6:08 PM
  • Weiwei,

    Is there any update or new information on this issue?

    Thanks!

    SK

    Monday, May 2, 2016 11:28 PM
  • Hi SK, were you able to get this resolved? We were hitting an issue in VS2015 in a FIPS environment that we resolved this week. I wrote up the details here:

    https://blogs.msdn.microsoft.com/samlester/2017/03/10/creating-a-new-project-in-visual-studio-fails-when-fips-is-enabled/

    I'm not sure if this would help you or not, but you can try it out. Also, feel free to send me a direct email if you're stuck on it and I may be able to help find some additional details.

    Thanks,
    Sam Lester (MSFT)


    https://blogs.msdn.microsoft.com/samlester/

    Twitter - @SQLSamLester

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Friday, March 10, 2017 12:15 PM
  • Hey Samuel,

    I took a look at the article, it does look like it will work, thank you for tracking this down!

    I'll forward this off to my colleagues so that they can test, hopefully it does work.

    Thanks again!
    SK

    Friday, March 10, 2017 6:12 PM
  • SK, thanks for letting me know. Can you send me an email (samles@micrsoft.com) so we can discuss the issue you're having in a bit more detail? Do you have a Microsoft Premier team supporting your customer environment?

    Thanks,
    Sam Lester (MSFT)


    https://blogs.msdn.microsoft.com/samlester/

    Twitter - @SQLSamLester

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Friday, March 10, 2017 6:21 PM
  • I removed the “Application Insights for Visual Studio” extension per this blog and the error persists.  Is there something else I need to do to get this thing to go?  I am in the same boat as SK -- gov't facility so we can just turn FIPS off.  This seems to be a persistent problem with VS going way back.  I sure do wish they would get their act together!

    Berg

    Thursday, March 16, 2017 12:33 PM
  • Hi Berg, I'll extend the same offer that I did for SK. Can you send me an email with some additional details and I will try to work with the product group to help isolate the issue you are seeing? I support customers working in FIPS enabled environments and would like to see the issues resolved as well.

    Thanks,

    Sam Lester (MSFT)


    https://blogs.msdn.microsoft.com/samlester/

    Twitter - @SQLSamLester

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Thursday, March 16, 2017 12:51 PM
  • Thank you Sam.  Please check your email.  You have two from me.  What else do you need?  Still DITW (dead in the water).
    Friday, March 17, 2017 2:01 PM
  • Unfortunately I think the mail filter is blocking it because I'm not seeing it in junk or inbox. Can you post a comment on the fips blog entry and leave your contact info there?

    Thanks,

    Sam


    https://blogs.msdn.microsoft.com/samlester/

    Twitter - @SQLSamLester

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Friday, March 17, 2017 5:23 PM
  • rbergmann at colsa dot com
    Friday, March 17, 2017 5:31 PM
  • I am in the same boat as the other individuals who have commented.  Working on government network, Visual Studio 2015, getting the FIPS error every time try to debug, and have been told there is no way to change policy setting.  Do you know of a solution?

    Thanks!

    Tuesday, September 19, 2017 9:56 PM
  • pcola123, can you send me an email to samles@microsoft.com to chat briefly about this? I support FIPS enabled customers and have helped work with the product team for a few different related issues with FIPS and VS. This thread covers two different issues:

    1. Creating a new project fails in VS with FIPS enabled. This has been fixed and a workaround identified in this blog.

    2. Compiling a XAML project fails in VS with FIPS enabled. This bug has been fixed and will be released as part of .NET 4.7.1, which is in early access release now. More notes are written up in this blog.

    Thanks,
    Sam Lester (MSFT)


    https://blogs.msdn.microsoft.com/samlester/

    Twitter - @SQLSamLester

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Wednesday, September 20, 2017 1:37 PM
  • I just spoke with the team that fixed the XAML project bug and they confirmed that it is released as part of the early release builds in .NET 4.7.1.

    I updated my blog entry here with more details:
    https://blogs.msdn.microsoft.com/samlester/2017/09/20/fixed-compiling-a-xaml-based-project-fails-in-visual-studio-with-fips-enabled/

    Thanks,
    Sam Lester (MSFT)


    https://blogs.msdn.microsoft.com/samlester/

    Twitter - @SQLSamLester

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Wednesday, September 20, 2017 5:13 PM
  • Thanks for all the help Sam! I'll update this if I hear anything from that department (I'm in a new department). 

    Friday, September 22, 2017 7:25 PM