locked
VS2015 Community: SP324099: Could not complete the operation RRS feed

  • Question

  • There does not seem to be a way past this screen.

    I have an active account, verified here: https://app.vssps.visualstudio.com/profile/view

    My account is logged in on the login panel under All Accounts.

    Still, it asks that I log in with a "Sign In" grey button.

    I enter the email and password, and get this screen with: SP324099: Could not complete the operation

    I click the link for more detail and the "more detail" is just "Everything is looking good." Server status, not more detail after all.

    After this error appears, IE opens in the background (why? It's not my browser, so I have no idea why this is the forced behavior) attempting to access: https://login.microsoftonline.com/login.srf

    Of course, IE does what it does best and fails to do it's designed job. It is unable to load the url. Reporting: "This program cannot display the webpage" and tries to blame my internet connection.

    When I copy the url (https://login.microsoftonline.com/login.srf) to a browser of my choice, I'm taken to an Office 365 login page (is VS even a part of the Office "family"?), and am told:

    We couldn't find an account with that email address.

    Before I even get to enter my password. Nicely useless url.

    How do I get VS2015 to recognize my login? Is the only way by upgrading IE? (and seriously? MS has made IE a requirement?)

    Friday, November 13, 2015 4:54 AM

Answers

  • Hi WildElf,

    Thank you for posting in MSDN forum.

    For your this issue, I suggest you could upgrade your IE to IE 11.

    Refer to: https://social.msdn.microsoft.com/Forums/en-US/ae64792f-0eaf-4d7f-9fbf-19e9f9d22f06/sp324099-could-not-complete-the-operation-vs-ce-2015?forum=vssetup

    Besides, if the above doesn't help, please check the following tips:

    1. Check the connection of your network. And then open the Internet Explorer, open one website, if it could be opened successfully, indicating your network is well.
    2. Maybe your IE doesn’t trust the Visual Studio web page or the sign in page, try to add the  https://login.microsoftonline.com/  and https://login.live.com/ to your trusted zone. 
    In the IE, go to Tools -> Internet Options -> Security Tab, click the “Sites”, and adds these sites.
    3. If the above doesn’t help, try to enable the JavaScript in Internet Explorer because if the JavaScript is disabled, you will not able to sign in to Visual Studio.

    Go to Tools -> Internet Options -> Security Tab, and then click the Internet zone, depending on whether you have to customize your Internet security settings, select one of the following options:
    •If you do not have to customize your Internet security settings, click Default Level.
    •If you have to customize your Internet security settings, click Custom level, scroll down to the Active scripting section, and then click Enable.

    Best Regards,

    Jiayi


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Proposed as answer by Jiayi Li Friday, November 20, 2015 8:28 AM
    • Marked as answer by Jiayi Li Tuesday, November 24, 2015 2:53 AM
    Monday, November 16, 2015 1:17 AM

All replies

  • Hi WildElf,

    Thank you for posting in MSDN forum.

    For your this issue, I suggest you could upgrade your IE to IE 11.

    Refer to: https://social.msdn.microsoft.com/Forums/en-US/ae64792f-0eaf-4d7f-9fbf-19e9f9d22f06/sp324099-could-not-complete-the-operation-vs-ce-2015?forum=vssetup

    Besides, if the above doesn't help, please check the following tips:

    1. Check the connection of your network. And then open the Internet Explorer, open one website, if it could be opened successfully, indicating your network is well.
    2. Maybe your IE doesn’t trust the Visual Studio web page or the sign in page, try to add the  https://login.microsoftonline.com/  and https://login.live.com/ to your trusted zone. 
    In the IE, go to Tools -> Internet Options -> Security Tab, click the “Sites”, and adds these sites.
    3. If the above doesn’t help, try to enable the JavaScript in Internet Explorer because if the JavaScript is disabled, you will not able to sign in to Visual Studio.

    Go to Tools -> Internet Options -> Security Tab, and then click the Internet zone, depending on whether you have to customize your Internet security settings, select one of the following options:
    •If you do not have to customize your Internet security settings, click Default Level.
    •If you have to customize your Internet security settings, click Custom level, scroll down to the Active scripting section, and then click Enable.

    Best Regards,

    Jiayi


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Proposed as answer by Jiayi Li Friday, November 20, 2015 8:28 AM
    • Marked as answer by Jiayi Li Tuesday, November 24, 2015 2:53 AM
    Monday, November 16, 2015 1:17 AM
  • Not working.

    tried it under Win2016 server. Installed Visual Studio 2015 and was unable to sign in.

    Added already https://login.microsoftonline.com to the trusted zones and this zone has scripts enabled.

    Saturday, August 25, 2018 12:10 PM