locked
tfs build 2017 - skip 'Get sources' task RRS feed

  • Question

  • Is there a way to skip the 'Get sources' task in build execution?

    It looks like 'Get sources' task is a mandatory one and lacks regular 'disable' or 'remove' options.

    When source repository is large repetitive build spends lot of time on get while re-get of sources is not necessarily needed in development.

    The template with 'Empty' name is not really empty.

    Do i miss something?  

    Tuesday, August 1, 2017 8:37 PM

Answers

All replies

  • Hi friend,

    Get source task could not be disabled or removed. You could choose false for Clean, it will only get all the source code at the first time when you queue your build, the next time you queue it, it will only get the changes, not entire source code:

    Best Regards  


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, August 2, 2017 8:59 AM
  • This is unfortunate.

    Thank you for fast reply.

    Wednesday, August 2, 2017 2:31 PM
  • Hi friend,

    The template with 'Empty' is only with not build tasks. "Get sources" is not a build task, it is agent’s built-in behavior.

    I found a user voice related to your requirement, you could vote it and add a comment:

    https://visualstudio.uservoice.com/forums/330519-team-services/suggestions/17023378-disable-get-sources-step-in-vnext-build

    Best Regards


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, August 3, 2017 1:59 AM
  • Under advances, select the "do not sync sources" option:

    


    My blog: blog.jessehouwing.nl

    Monday, August 7, 2017 1:32 AM
  • Unfortunately this is not available with tfs repositories
    Tuesday, September 19, 2017 7:22 PM
  • Hi friend,

    What Jesse said above is available in TFS 2017.2."Do not sync sources" option is for Git repository.

    Which type of repository do you use? TFVC or Git?

    Could you please provide your logs of get source step?

    Best Regards


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Sunday, September 24, 2017 3:33 AM
  • tfvc on-premisses one.

    2017-09-22T21:50:39.1023447Z ##[section]Starting: Get Sources
    2017-09-22T21:50:39.1648214Z Prepending Path environment variable with directory containing 'tf.exe'.
    2017-09-22T21:50:39.1648214Z Querying workspace information.
    2017-09-22T21:50:46.1649275Z ##[command]tf vc get /version:288597 /recursive /overwrite d:\vnext_builds\XXXXXX_agent_01\2\s /loginType:OAuth /login:.,******** /noprompt
    2017-09-22T21:51:10.9465417Z TF401190: The local workspace ws_2_10;Project Build Service (DefaultCollection) has 151908 items in it, which exceeds the recommended limit of 100000 items. To improve performance, either reduce the number of items in the workspace, or convert the workspace to a server workspace.
    2017-09-22T21:51:10.9621621Z All files are up to date.
    2017-09-22T21:51:10.9934180Z ##[section]Finishing: Get Sources


    Wednesday, September 27, 2017 7:02 PM
  • in build definition set

    Build.SyncSources = false

    see Disabling Get Sources step in vNext build


    Please use "Mark as Answer" if my post solved your problem and use "Vote As Helpful" if a post was useful.

    Wednesday, September 27, 2017 7:33 PM