none
Cannot connect to Oracle to recreate entity framework RRS feed

  • Question

  • Hi,
    •We’re migrating several apps done by consultants in 2013 from .Net Framework 4.0/MVC 4 to 4.5.2/MVC5 and Oracle 12c for Preservation on newer Win2012 Servers.
    •All apps were developed in VS 2010 on Win 7 with Oracle 11g
    •We are assuming/hoping after updating one the others will be streamlined. The first is always the most difficult.
    •We assume migrating with the latest Visual Studio (VS2017 Pro and tools/updated packages) would smooth the process.
    •VS2017 prompted us to update several Nuget packages including Entity Frameworks (up to 6.x).
    •We have the current set of Oracle Developer Tools for VS 2017 installed.
    •I've updated the project to MVC5 (I think...) This was the only option in Nuget.

    I've worked through several issues so far but I'm stuck at the EDM wizard and cannot recreate the model from the db (It's unchanged) even though I've followed the steps at https://csharp.today/entity-framework-6-database-first-with-oracle/.  I can read data via VS but not with the app. It's some version discrepancy between my ODAC provider(s) and EF6. I've tried both managed and unmanaged providers from the ODAC and the approved Oracle 12c client.

    Any help would be greatly appreciated.

    Tim

    • Moved by CoolDadTx Tuesday, October 23, 2018 5:58 PM EF related
    Tuesday, October 23, 2018 4:17 PM

All replies