WWW Publishing and SMTP services not starting RRS feed

  • Question

  • User2075549968 posted
    I have Windows XP Pro / IIS5.1 on my system.
    Recently due to virus attack my system files were deleted, i tried to restore the system.
    now I have reinstalled IIS but it doesnt start SMTP and W3SVC services automatically.
    When i start them manually, i get an error saying that "System could not find the path specified", but the Inetinfo.exe is there in the path specified in the properties of the services.
    Is there something that needs to be done with the registry to set/reset the path?
    Please suggest.
    Its really urgent
    Thursday, October 19, 2006 11:14 AM

All replies

  • User-823196590 posted
    Sounds like the IIS metabase was trashed - do you have a file metabase.bin in C:\WINDOWS\system32\inetsrv?
    Thursday, October 19, 2006 3:38 PM
  • User2075549968 posted

    Nopes.... i dont have metabase.bin in that folder...

    I have been searching the registry to find the path specified... hkey_local_machine\system\currentcontrolset\services\W3SVC & SMTPSVC ...

    i have been goin around the internet searching the problem... but dint get any solution...

    http://www.nachos.net/forums/showthread.php?t=39832 , this was one link .. which had the same problem as mine, but the solution suggested doesnt help... i cannot delete inetsrv folder after uninstalling IIS :(


    Friday, October 20, 2006 5:51 AM
  • User-823196590 posted
    If metabase.bin is gone and you don't have a backup you'll need to reinstall IIS, there's no other way. Why can't you delete that folder?
    Friday, October 20, 2006 8:41 AM
  • User2075549968 posted

    after reinstalling IIS, when i delete inetsrv, it says the folder is being used by some program... in the task manager i dont which all process to end so that inetsrv folder can be deleted...

     when u say that i have to reinstall IIS, do u mean that i need Win XP cd for that or from the control panel-->add/remove windows components ??

    Friday, October 20, 2006 10:07 AM
  • User2075549968 posted

    can i just copy the metabase.bin from another system  ???? and use it ????

    is there a way to see wuts inside Metabase.bin ????

    Friday, October 20, 2006 10:10 AM
  • Friday, October 20, 2006 10:27 AM
  • User2075549968 posted

    Meta Edit2.2 is not helping at all.... its giving weird problems..... it opened once .. and as far as i cud make out.. it was to add keys to metabase... i cudnt find a way to view as how are W3SVC and AMTPSVC are registered in that...

     i found the following information in the help file...

    The metabase is stored in a special format file, by default named METABASE.BIN in the INETSRV directory in which you installed IIS. You can move or rename the file and change the Windows NT registry setting that tells IIS where to find the file on startup. To relocate or rename the metabase file, you will need to stop IIS, move or rename the file, and modify the registry key HKLM\SOFTWARE\Microsoft\INetMgr\Parameters. Add a REG_SZ value to this key named MetadataFile that specifies the new complete path of the metabase file including the drive letter and file name.

     Can u pls tell as to if i can change the registry settings or do something?

    i tried that copied Metabase.bin, but its not helping... i thnk there is some information thats stored in that which is not in synch with my system  ! !  :(

    Friday, October 20, 2006 11:06 AM
  • User-823196590 posted

    If you do not have a metabase.bin on the problem computer then metaedit will not work.

    There's nothing in the registry that will help you.

    You can not just copy the metabase.bin file to another computer. Read the first link I sent you, there's a tip on how to create a text file of the good metabase.bin and transfer it to the bad computer.

    Friday, October 20, 2006 12:56 PM
  • User2075549968 posted

    Great ! ... more bad news... I for the back up of Metabase from a good system using MetaEdit, but On my system it doesnt open only.. and i dont know how to use that backup text file... ?????

    Is it possible for me to use any other web server besides IIS for deploying my .NET application ????

    Saturday, October 21, 2006 8:24 AM
  • User-823196590 posted

    Run MetaEdit on the bad server and it can import that text file that was exported on the good server.

    Alternatively try to reinstall IIS again - uninstall it and then do a reboot and delete the inetsrv folder, then install it again.

    Monday, October 23, 2006 8:00 AM
  • User2075549968 posted

    I followed following steps

    1 uninstalled .NET Framework --> Restart

    2 Uninstalled IIS --> Restart

    3 Could not delete Inersrv (gave error saying it is being used) --> deleted all files inside that folder

    4 Re-Installed IIS

    now FTP/SMTP services are running but W#SVC is not running... its giving the same problem....

    I have the Windows XP Pro Installation Cd... can i do something with that ? Or i have to reinstall the OS again ????? oh man... i have searched numerous threads/discussions/forums but havent found a solution to my problem. ...

    In the Event Viewer : it says Event 7023, The system cannot find the specfied path... and i remember that earlier the even viewer also said something like

    >>> Could not start the World Wide Web Publishing service on Local
             Error 3: The system cannot find the path specified

    >>>> The service metabase path "/LM/W3SVC/" could not be opened




    Friday, October 27, 2006 12:12 PM
  • User-823196590 posted

    You need to delete that folder before installing IIS again. Use "handle" to determine what is using that folder.

    If your system was in fact compromised then reinstalling the OS may be the best solution in the long run ...

    Friday, October 27, 2006 1:02 PM
  • User989702501 posted

    And it looks like IIS installation didn't went well. Any error during reinstallation? open %windir%\iis6.log file - look for fail entries and post it here.

     As to delete those inetsrv files, etc. Boot the computer in to safe mode, then delete.

    Saturday, October 28, 2006 11:55 PM
  • User-823196590 posted
     As to delete those inetsrv files, etc. Boot the computer in to safe mode, then delete.
    Great idea!
    Monday, October 30, 2006 9:00 AM
  • User2075549968 posted

    Below is the part from IIS install Log file... i just copied the part which had failed/error messages...i definitely can see many problems during the installation... please suggest...

     [10/31/2006 12:3:16] OC_COMPLETE_INSTALLATION:iis_core:------------------
    [10/31/2006 12:3:16] OC_COMPLETE_INSTALLATION:iis_core:CallProcedureInDll(C:\WINDOWS\system32\inetsrv\iischema.dll): DllRegisterServer
    [10/31/2006 12:3:16] OC_COMPLETE_INSTALLATION:iis_core:iOleInitialize: Succeeded: 0.  MakeSure to call OleUninitialize.
    [10/31/2006 12:3:16] OC_COMPLETE_INSTALLATION:iis_core:CallProcedureInDll: Calling 'DllRegisterServer'.Start
    [10/31/2006 12:3:17] OC_COMPLETE_INSTALLATION:iis_core:MyMessageBox: Title:IIS Setup Error, Msg:Error calling procedure 'DllRegisterServer()' in file 'C:\WINDOWS\system32\inetsrv\iischema.dll'.

    0x8009000f=Object already exists.

    [10/31/2006 12:3:17] OC_COMPLETE_INSTALLATION:iis_core:!FAIL!
    [10/31/2006 12:3:17] OC_COMPLETE_INSTALLATION:iis_core:CallProcedureInDll: Calling 'DllRegisterServer'.End.FAILED.


    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:!FAIL!
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:[WAMERROR -     export.cpp : 00676] FAIL - MDGetIdentity, Getting the IWAM_* account from the Metabase - error=80070003
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:[WAMTRACE -     export.cpp : 00728] CreateIISPackage - Updating metabase defaults.
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:!FAIL!
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:[WAMERROR -     export.cpp : 00743] FAIL - MDUpdateIISDefault, Updating default application - error=80070003
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:!FAIL!
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:[WAMERROR -     export.cpp : 00750] Assertion Failed: (SUCCEEDED(hrReturn))
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:[WAMTRACE -     export.cpp : 00751] RETURN - CreateIISPackage, hr=80070003
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:MyMessageBox: Title:IIS Setup Error, Msg:Error calling procedure 'InstallWam()' in file 'C:\WINDOWS\system32\inetsrv\wamreg.dll'.

    0x80070003=The system cannot find the path specified.

    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:!FAIL!
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:CallProcedureInDll: Calling 'InstallWam'.End.FAILED. Err=80070003.


    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:!FAIL!
    [10/31/2006 12:3:26] OC_COMPLETE_INSTALLATION:iis_www:CallProcedureInDll: Calling 'InstallWam'.End.FAILED. Err=80070003.


    i hope this gives an understanding ! ! ! !


    Tuesday, October 31, 2006 7:25 AM
  • User2075549968 posted

    That great.... I restarted the system in SAFE mode and i cud delete InetSrv folder...

    one more information ....

     While installing IIS I got a popup message saying "Unable to access Microsoft Personal Web Server Configuration"

    I have been getting this on every install...

    Tuesday, October 31, 2006 7:50 AM
  • User2075549968 posted

    I GOT THE SOLUTION ! ! ! !

    WWW and SMTP services are working gr8 now ! ! !

    Thank you very much TOM ... Your info was of gr8 help... i really appreciate ur time :) simply awesome ! :)

    and Bernard... ur inputs also gave me new direction... i dug in the IIS6.log file and spotted the errrors...

     ultimately, I took backup of "C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKey" folder.... and deleted the system files in it..

    how i can relate is that It was something like the keys in the machine keys folder were pointing to i thnk the old installations... so whenever i was reinstalling .. it was matching the registry values and the machine key files.. Since the Registry value and the machine key system file were matching .. it was never getting updated...  so after i deleted them... they were freshly created.. and this time it was correct... i hope that was where the issue was....

    Please let me knowas to how do u feel wut was the issue....

    i restarted the system..  in safe mode.. deleted Inetpub and inersrv folders...

    reinstalled IIS and prayed hard :) so that the installation goes fine ... and luckily it did....

    yeah ... yipppppppy ! ! ! ! Heeeeeee Haaaaaaa ! ! !

    I am really thankful to u guys... i was almost planning to format and reinstall the whole OS... but just wanted to give more effort on it.. and yeah .. hard work did pay off :))

    tk cr

    Tuesday, October 31, 2006 9:36 AM
  • User989702501 posted

    LOL! Cool! glad you fixed it.

    Your error is related to this.
    PRB: Error Message "0x8009000F = Object Already Exists"

    Tuesday, October 31, 2006 10:49 PM
  • User2075549968 posted
    thanks a million ! :)
    Wednesday, November 1, 2006 7:29 AM
  • User-2097060974 posted
    Had the same issue as was stated here, except the web server appeared to start and run, but you'd get an "Access is denied" error on an otherwise blank page.  Trying to re-install permissions would give errors like that it could not find the security templates when you try to use one, even though I had them all in C:\WINDOWS\Security\Templates.  I thought maybe Front Page 2002 Sever Extensions could be to blame, but re-installing that said that it could not find metadata (consequently I did not have the metadata.bin file in C:\WINDOWS\system32\inetsrv, either).  Re-installing IIS would give errors during installation ("Unable to access Microsoft personal web server").  Glad you guys figured this out, as deleting those MachineKeys files worked (though I probably should've just moved them to another folder).  But thank you both very much, as this helped me immensely.
    Wednesday, April 18, 2007 1:41 PM