locked
help please !! username and password problem RRS feed

  • Question

  • User-464786667 posted

    when i fired up sql server management studio for the first time i tried to enter the user name and the password ....this error message showed up (("A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)"))

    how can i solve this problem ?

    Tuesday, December 8, 2015 5:59 PM

Answers

  • User-718146471 posted

    Enable TCP/IP in SQL Server Configuration

    When two or more SQL Servers are connected across network they do all communication using TCP/IP. The default port of SQL Server installation is 1433. This port can be changed through SQL Server Configuration Manager. TCP/IP should be enabled for SQL Server to be connected.

    Go to All Programs >> Microsoft SQL Server 2008 >> Configuration Tools >> SQL Server Configuration Manager >> Select TCP/IP

    1 SQL SERVER FIX : ERROR : (provider: Named Pipes Provider, error: 40 Could not open a connection to SQL Server) (Microsoft SQL Server, Error: )

    Right Click on TCP/IP >> Click on Enable

    2 SQL SERVER FIX : ERROR : (provider: Named Pipes Provider, error: 40 Could not open a connection to SQL Server) (Microsoft SQL Server, Error: )

    You must restart SQL Server Services for all the changes to take effect. Right click and go to menu properties to select location where default port of SQL Server can be changed.

    From; http://blog.sqlauthority.com/2009/05/21/sql-server-fix-error-provider-named-pipes-provider-error-40-could-not-open-a-connection-to-sql-server-microsoft-sql-server-error/

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, December 8, 2015 8:09 PM