locked
Unexpected end of file while parsing Name has occurred. RRS feed

  • Question

  • Hi,

     

    I have created a infopath 2007 form and publish to sharepoint library. Library has a workflow attached with it, infopath form has multiple dataconnections both sharepoint and webservice. When i open the form it get the correct data and no error comes i press submit button and form is saved without any issue/error. All data is saved corretly workflow starts properly and task\emails are sent. But when i open the saved from again it opens correclty but when close button is pressed an error is poped:

     

    Unexpected end of file while parsing Name has occurred. Line 1, position 260.

    System.Xml.XmlException: Unexpected end of file while parsing Name has occurred. Line 1, position 260.
    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
    at System.Xml.XmlTextReaderImpl.Throw(String res, String arg)
    at System.Xml.XmlTextReaderImpl.Throw(Int32 pos, String res, String arg)
    at System.Xml.XmlTextReaderImpl.ParseQName(Boolean isQName, Int32 startOffset, Int32& colonPos)
    at System.Xml.XmlTextReaderImpl.ThrowTagMismatch(NodeData startTag)
    at System.Xml.XmlTextReaderImpl.ParseEndElement()
    at System.Xml.XmlTextReaderImpl.ParseElementContent()
    at System.Xml.XmlTextReaderImpl.Read()
    at System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace)
    at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
    at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
    at System.Xml.XmlDocument.Load(XmlReader reader)
    at Microsoft.Office.InfoPath.Server.Xml.InfoPathXmlDocument.Load(XmlReader reader)
    at Microsoft.Office.InfoPath.Server.DocumentLifetime.DataObject.<>c__DisplayClass3.<.ctor>b__0()
    at Microsoft.Office.Server.Diagnostics.FirstChanceHandler.ExceptionFilter(Boolean fRethrowException, TryBlock tryBlock, FilterBlock filter, CatchBlock catchBlock, FinallyBlock finallyBlock)
    at Microsoft.Office.Server.Diagnostics.ULS.SendWatsonOnExceptionTag(ULSTagID tagID, ULSCat categoryID, String output, Boolean fRethrowException, TryBlock tryBlock, CatchBlock catchBlock, FinallyBlock finallyBlock)
    at Microsoft.Office.InfoPath.Server.DocumentLifetime.DataObject..ctor(EnhancedBinaryReader reader, Solution solution)
    at Microsoft.Office.InfoPath.Server.DocumentLifetime.DataObjects.<>c__DisplayClass2.<.ctor>b__0(EnhancedBinaryReader innerReader, DataObject& newObject)
    at Microsoft.Office.InfoPath.Server.Serialization.EnhancedBinaryReader.ReadObjectMap[KeyT,ValueT](Dictionary`2 map, ItemReaderDelegate`1 readKey, ItemReaderDelegate`1 readValue)
    at Microsoft.Office.InfoPath.Server.Serialization.EnhancedBinaryReader.ReadObjectMap[ValueT](Dictionary`2 map, ItemReaderDelegate`1 readValue)
    at Microsoft.Office.InfoPath.Server.DocumentLifetime.DataObjects..ctor(EnhancedBinaryReader reader, Solution solution)
    at Microsoft.Office.InfoPath.Server.DocumentLifetime.DocumentSessionState.DesterilizeVersion1(EnhancedBinaryReader reader, Solution solution)
    at Microsoft.Office.InfoPath.Server.DocumentLifetime.DocumentSessionState..ctor(EnhancedBinaryReader reader, Solution solution)
    at Microsoft.Office.InfoPath.Server.DocumentLifetime.DocumentSessionState.CreateFromByteArray(Byte[] serializedSessionState, Byte[] serializedVersionState, Solution solution)
    at Microsoft.Office.InfoPath.Server.DocumentLifetime.DocumentSessionStateManager.GetSessionState(HttpContext context, String editingSessionID, Solution solution)
    at Microsoft.Office.InfoPath.Server.DocumentLifetime.Document.LoadFromSession(HttpContext context, SPSite contextSite, EventLogStart eventLogStart, Solution solution)
    at Microsoft.Office.InfoPath.Server.Controls.PostbackPage.<>c__DisplayClass1.<ProcessRequest>b__0()

    I have a approval workflow attached with this form and after first submit it siply dont work and give same error every time.

     

    Can you help me...?? pls

     


    Best Regards, Syed Muhammad Ehsan MCTS SharePoint Server 2007 (Dev & Config)
    Sunday, May 15, 2011 10:22 AM

Answers

  • Thank you Clayton for your reply, actually after alot of hit and tries I eventually identify the reason and solved it. One of the data connections was sent to auto update on form start that was causing the error. Yes even when i turn workflow off error was coming, once I remove auto update check of that data source All worked fine :)

     

    Thanks again for your support.


    Best Regards, Syed Muhammad Ehsan MCTS SharePoint Server 2007 (Dev & Config)
    • Marked as answer by Clayton Cobb Monday, May 16, 2011 6:47 PM
    Monday, May 16, 2011 7:17 AM

All replies

  • Does the same thing happen if you don't run the workflow?
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, May 16, 2011 5:49 AM
  • Thank you Clayton for your reply, actually after alot of hit and tries I eventually identify the reason and solved it. One of the data connections was sent to auto update on form start that was causing the error. Yes even when i turn workflow off error was coming, once I remove auto update check of that data source All worked fine :)

     

    Thanks again for your support.


    Best Regards, Syed Muhammad Ehsan MCTS SharePoint Server 2007 (Dev & Config)
    • Marked as answer by Clayton Cobb Monday, May 16, 2011 6:47 PM
    Monday, May 16, 2011 7:17 AM