none
Dependent project always built

    General discussion

  • Hi, I hope I this is the most appropriate forum for my question.

    I have a VS 2008 solution with a DLL project, and a number of Web Application projects which are dependent on the DLL project.

    Whenever I build one of the Web Application Projects, the shared DLL project always gets built again, even if no changes have been made to it. This significantly increases build time.

    I was of the understanding that a when performing a build (not rebuild), a project build will be skipped if no changes have been made to the project. I'm sure I've seen this occur in our older VS 2005 solutions.

    Am I correct in assuming this? If so, any ideas how I can stop my DLL project from being compiled every time?

    Many thanks,
    Anthony.
    • Changed type jack 321 Thursday, November 27, 2008 2:22 AM OP has posted this question to other forums
    Friday, November 21, 2008 11:10 AM

All replies

  • Perhaps could someone recommend a different forum for me to post this on?

    Many thanks,
    Anthony.
    Monday, November 24, 2008 10:54 PM
  • Hi ants_cx,

    I tried to add two ASP.Net web sites and a Visual C++ win32 DLL project to a solution file, and set the two web sites dependent on the DLL project, when I build the web site, it will ignore to build the DLL project if it is up-to-date, the message is “Build: 1 succeeded, 0 failed, 1 up-to-date, 0 skipped”.

    Also, I replace the Win32 DLL project with a .Net class library project, when I build a web site, it will not to build the other projects if they are up-to-date, the message is following.

    ------ Build started: Project: ClassLibrary1, Configuration: Debug Any CPU ------

    ClassLibrary1 -> E:\ClassLibrary1\bin\Debug\ClassLibrary1.dll

    ------ Build started: Project: D:\WebSite070927\, Configuration: Debug .NET ------

    Validating Web Site

    Building directory '/WebSite070927/'.

     

    Validation Complete

    ========== Build: 2 succeeded or up-to-date, 0 failed, 0 skipped ==========

    If the class library is modified, the message is different which indicated that the project was built.

    Therefore, I cannot repro the issue; have you change the configuration of the project? If it is so, try to reset it as default settings. Or if you still cannot figure the issue out, would you please upload the project to some network drives, such as http://skydrive.live.com/

    You can simplify the project if it is necessary; just make sure we can repro the problem.

    Also, if you want to give some feedback to the VS product team, you can do it via the following CONNECT portal.

    http://connect.microsoft.com/visualstudio/

    Regards,

    Xun


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/csharpide/thread/8e9ed0d7-11ff-402a-8489-9b5f05eeb706
    Tuesday, November 25, 2008 6:59 AM
  • Hi Xun,

    Thanks for your response. I believe I've found the cause of the problem.

    The issue only seems to occur when the DLL project contains a .edmx file (ADO .NET Entity Data Model). When I remove these files from my project, the project only builds when changes have been made.

    I have created a sample solution which replicates the problem on my PC:

    http://cid-059a79e7ba59118d.skydrive.live.com/self.aspx/Public/EXMXTest.zip

    If I build the Web project, the DLL project is always rebuilt. If I remove the .edmx file, then only the Web project is built.

    Cheers,
    Anthony.
    Tuesday, November 25, 2008 2:00 PM
  • Hi ants_cx,

    Thanks for sharing your project and info, I can repro the problem by building your project. since the problem was caused by "ADO .NET Entity Data Model", perhaps you can try the following forum.


    in ADO.NET Entity Framework and LINQ to Entities (Pre-release)

    http://forums.microsoft.com/msdn/ShowForum.aspx?ForumID=533&SiteID=1

    Or you can just report a bug via the CONNECT portal.

    Regards,
    Xun


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/csharpide/thread/8e9ed0d7-11ff-402a-8489-9b5f05eeb706
    • Edited by jack 321 Wednesday, November 26, 2008 3:20 AM edit link
    Wednesday, November 26, 2008 2:10 AM
  • I've created a new thread on the LINQ to Entities Forum:

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=4172878&SiteID=1

    Thanks for your help,
    Anthony.

    Wednesday, November 26, 2008 3:14 AM