locked
the form has been closed RRS feed

  • Question

  • i got this err msg "the form has been closed" /"This form cannot be opened. It is not workflow enabled." when i try to associate a custom workflow(dev in Infopath 2007 and VS 2005) in share point 2007. can anybody help me.
    Saturday, June 2, 2007 10:15 AM

Answers

  • This is a common thing when beginning to develop InfoPath forms for SharePoint.  What you can do is go to forms management in central administration under applications administration.  From here you will see a list of forms that have been deployed.  Most of the time when you get the error you will see that the form you are talking about still says installing.  This will not change.  What you need to do is verify the forms that you are deploying with your workflow.  You can check this by going to upload and then it will give you a verify button.  This should tell you what you need to fix. 

    The problems that I ran into the most are:

    1. appropriate security.

    2. browser enabled.

    3. the form has been published to a network location.

    4. when publishing the form do not set an alternative location, leave it blank. (This one was a pain to figure out)

    • Marked as answer by tharakans Monday, April 16, 2012 10:56 AM
    Saturday, June 2, 2007 5:22 PM

All replies

  • This is a common thing when beginning to develop InfoPath forms for SharePoint.  What you can do is go to forms management in central administration under applications administration.  From here you will see a list of forms that have been deployed.  Most of the time when you get the error you will see that the form you are talking about still says installing.  This will not change.  What you need to do is verify the forms that you are deploying with your workflow.  You can check this by going to upload and then it will give you a verify button.  This should tell you what you need to fix. 

    The problems that I ran into the most are:

    1. appropriate security.

    2. browser enabled.

    3. the form has been published to a network location.

    4. when publishing the form do not set an alternative location, leave it blank. (This one was a pain to figure out)

    • Marked as answer by tharakans Monday, April 16, 2012 10:56 AM
    Saturday, June 2, 2007 5:22 PM
  • Thanks very much George Olson. it solced the problem
    Monday, June 4, 2007 7:13 AM
  • Any ideas on what the alternative location is for, and why it doesn't work?
    Tuesday, June 5, 2007 7:30 PM