none
cannot install framework 4 client profile because of Windows Presentation Foundation Font Cache 4.0.0.0 RRS feed

  • Question

  • Hi,

    I am trying to install the framework 4 client profile but the install fails with the following message :

    [1/25/2013, 17:7:56]Log File C:\DOCUME~1\Marcel\LOCALS~1\Temp\Microsoft .NET Framework 4 Client Profile Setup_20130125_170750576-MSI_netfx_Core_x86.msi.txt does not yet exist but may do at Watson upload time
    [1/25/2013, 17:7:56]Calling MsiInstallProduct(C:\96521e2192f62ad841f76a9e061ff1\netfx_Core_x86.msi, EXTUI=1
    [1/25/2013, 17:8:58] Returning IDOK. INSTALLMESSAGE_ERROR [Impossible d’installer le service Windows Presentation Foundation Font Cache 4.0.0.0 (WPFFontCache_v0400). Vérifiez que vous disposez de privilèges suffisants pour installer des services système.]
    [1/25/2013, 17:9:28]MSI (C:\96521e2192f62ad841f76a9e061ff1\netfx_Core_x86.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Client Profile Setup_20130125_170750576-MSI_netfx_Core_x86.msi.txt
    [1/25/2013, 17:9:28]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)

    [1/25/2013, 17:9:28] Action complete

    It's french, sorry. I am running the install as a local administrator.

    Can you help me please ?

    Thank you!

    Matteo

    Matteo, .NET Developer and System Engineer

    Friday, January 25, 2013 4:47 PM

Answers

  • Hi Armando, Thank you for tour response. Actually, I have been able to install the update by scanning the computer with SpyBot and remove all the stuff it found. I guess I may be infected by a malware.... Anyway, don't know what was wrong but now it's ok. Best regards. Matteo

    Matteo, .NET Developer and System Engineer

    • Marked as answer by joujoukinder Friday, January 25, 2013 7:36 PM
    Friday, January 25, 2013 7:36 PM

All replies

  • Matteo,

    The error message really says you don't have privileges to install it. Sometimes this happens when there is a pending update from Windows Update.

    You may also try to download the redistrib packaged and install it locally.

    Hope this helps,


    Armando Lacerda

    Friday, January 25, 2013 5:58 PM
  • Hi Armando, Thank you for tour response. Actually, I have been able to install the update by scanning the computer with SpyBot and remove all the stuff it found. I guess I may be infected by a malware.... Anyway, don't know what was wrong but now it's ok. Best regards. Matteo

    Matteo, .NET Developer and System Engineer

    • Marked as answer by joujoukinder Friday, January 25, 2013 7:36 PM
    Friday, January 25, 2013 7:36 PM
  • That is great!

    Infections ... good know. Just learned one more. :)

    Regards,


    Armando Lacerda

    Friday, January 25, 2013 7:45 PM