none
Download link not working for MSDN downloads (BizSpark) RRS feed

  • Question

  • Hello,

    We just received our BizSpark acceptance email yesterday. I followed the instructions in the email to access software via MSDN. I have tried several downloads including Windows 8 and Visual Studio 2012 but when I click the "download" button, the page just refreshes. No Javascript errors ... nothing.Not sure if it has anything to do with the fact that I am using a Mac (we develop within VMWare Fusion). I have tried Firefox, Safari, and Chrome all to the same effect. Am I missing a step? Thanks.

    Friday, December 21, 2012 1:46 PM

Answers

  • strange report northernndev.  We've never had that issue reported before, so I'd be interested to know if others are having similar reports today. 

    We work just fine with Macs and PCs and Linux machines.  If you're not on IE you should be getting a prompt for a direct file download using the browser's download manager.    You can also try the 'details' link next to the name of the product, and this will show a "direct download" link that you can use as well.  Please try this as well adn let us know if the problem continues.

    Thanks,
    Mike


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Friday, December 21, 2012 6:31 PM
    Moderator

All replies

  • strange report northernndev.  We've never had that issue reported before, so I'd be interested to know if others are having similar reports today. 

    We work just fine with Macs and PCs and Linux machines.  If you're not on IE you should be getting a prompt for a direct file download using the browser's download manager.    You can also try the 'details' link next to the name of the product, and this will show a "direct download" link that you can use as well.  Please try this as well adn let us know if the problem continues.

    Thanks,
    Mike


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Friday, December 21, 2012 6:31 PM
    Moderator
  • I am also getting the same symptoms, suddenly some links I can not download from.  At least in one instance it reported a DNS error attributed to AKAMAI.  I did try using chrome but still no luck.  Also any download for windows 8, the SHA1 verification always fails.

    Sunday, January 20, 2013 2:17 PM
  • same issue here on Google Chrome. no download warning whatsoever, cleared cache and things like that.
    also, the  'direct' download  link does not make it work either.

    Works just fine in IE though.


    • Edited by Shadowin Thursday, March 7, 2013 12:06 AM
    Wednesday, March 6, 2013 11:56 PM