none
Depth Camera framerate struggling RRS feed

  • Question

  • I am having a problem and couldn't find any solid answers through google. I have worked with the kinect for windows SDK plenty since we use it at the children's museum I work at pretty regularly and haven't had any problems till now. I had been working on a desktop both at my house and at work and they both managed framerates of about 30fps with both color and depth cameras. I recently bought a Lenovo Y510P i7 quad-core geforce 755M SLI which should blow my work computer out of the water i3 dual core intel HD 4000 and is stronger than my desktop at home, Phenom II x6 Geforce 550ti. The machines run Windows 8.1, Windows 7 Pro, and 8.1 Pro respectively. I thought my laptop would be able to handle the kinect no problem, however the depth camera framerate is all over the place and is usually sub 10 fps sometimes hanging at 1FPS or even 0. Does any one have any insight as to why this could be happening. I tried uninstalling the SDK and reinstalling. My laptops processor is a bit slower but I have it overclocked up to 3 gHz from the default 2.4. 

    I try using the kinect explorer and literally everything works except the depth image framerate is bad, though when I try the depth basics example it runs at 30 fps. When I try to run a program that I wrote that only uses the depth stream however, I encounter the same problem. The program works fine on all other machines so its clearly a problem specific to my laptop, could it be a driver issue or what? 

    Monday, July 21, 2014 11:34 PM

All replies

  • Does DepthBasics-D2D or D3D samples exhibit the same issues? What about skeletal tracking?

    The original Kinect depth/color data come directly off the camera/USB2 bus. Depth data is then processed by the runtime to generate skeletons. If you are able to track users without issues, then the issue is going to be environmental to that particular install. Do you have any third party security or monitor type applications that could be trying to hook into the apis? 


    Carmine Sirignano - MSFT

    Thursday, July 31, 2014 5:21 PM
  • Sorry for the slow reply I recently moved and just got settled in.

    The depth basics did not have the same stuttering problem. I don't think I tried the skeletal tracking because I didn't need it for what I was working with. There might be something about Lenovo's software that came installed on the machine but I uninstalled the bloatware as far as I can tell. I did notice that the framerate goes to a solid 30 fps when the CPU is under load and was a replicatable issue. I have a feeling it could be related to the ESIT that is a part of the i7 4700MQ processor and unfortunately I have no way of turning it off in the BIOS. Lenovo's energy management isn't exactly deep in features and when I change the energy management in the control panel it still seems to make no difference. The way I was able to test the framerate under heavy load was I was using intels XTU to set the overclocking and when I ran a bench test the framerate is solid and once the bench test ends it drops back down.

    Thursday, August 14, 2014 7:22 PM
  • Based on what you describe the data and sensor/drivers seem to be working fine. The app itself may be having some perf issues based on the system configuration. Do you see any differences between D2D Kinect Explorer and the WPF versions? Is your system running overclocked?


    Carmine Sirignano - MSFT

    Friday, August 15, 2014 4:57 PM