none
Mounting file share from Windows 10 stopped working with anniversary update

    Question

  • Since upgrading to Windows 10 build 14393, I can no longer mount an Azure file storage drive with net use. I get "System error 53 has occurred. The network path was not found." I used the following command:

    net use z: \\henriko.file.core.windows.net\backup /u:henriko <access key>

    I have tried both from a private and a domain network. I have also verified connectivity on port 445:

    Test-NetConnection -ComputerName henriko.file.core.windows.net -Port 445
    
    ComputerName     : henriko.file.core.windows.net
    RemoteAddress    : 191.235.193.44
    RemotePort       : 445
    InterfaceAlias   : vEthernet (Wireless Virtual Switch)
    SourceAddress    : 192.168.1.24
    TcpTestSucceeded : True
    

    Mounting works fine from another (virtual) machine with build 10586.
    Tuesday, August 23, 2016 12:42 PM

Answers

  • I actually got help from Microsoft on this. NTLMv1 communication was enabled on the client. Having NTLMv1 enabled creates a less secure client and therefore communication will be blocked for Azure Files. This is controlled by registry HKLM\SYSTEM\CurrentControlSet\Control\Lsa > LmCompatibilityLevel. I had 0, and after setting it to 3 the problem was solved. See https://technet.microsoft.com/en-us/library/jj852207(v=ws.11).aspx.
    • Edited by HOlsson Friday, August 26, 2016 9:19 AM
    • Marked as answer by HOlsson Friday, August 26, 2016 9:19 AM
    Friday, August 26, 2016 9:18 AM

All replies