none
Issues installing .Net Framework 3.5 SP1 and 4.0 RRS feed

  • Question

  • Hi Everyone,

    Hoping someone can help me.

    I'm trying to install .net framework 3.5 SP1 and 4.0 on XP machine, running SP3.

    I need specifically ver 2 and 4 running for particular apps.

    I have used the .net framework removal tool and tried web and standalone installers to install, all to no avail.

    I get the following error when installing 4.0: Error 25015. Failed to install assembly ‘C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.EnterpriseServices.dll’ because of system error: Access is denied.

    With 3.5 SP1, i get the following error: WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed

    I have also tried resetting the ACL's as described in http://blogs.msdn.com/b/astebner/archive/2006/09/04/solving-setup-errors-by-using-the-subinacl-tool-to-repair-file-and-registry-permissions.aspx, all to no avail.

    I tried renaming the assembly directory (as some have appeared to have some success with this.. I have not)

    Hoping someone can point me in the right direction.

    Regards,

    Dennis.

    Thursday, February 26, 2015 1:13 AM

Answers

  • Hello, doreski.

    Have you made any progress with your issue?

    If not, I'd like to suggest a couple of things:

    First, please use this tool to share the state of .NET frameworks on your system:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with the highest available .NET version selected, then post the first 15 lines AND the last 15 lines of the tool log here.

    Also, so past install attempts can be reviewed, please collect and share your install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like OneDrive, and post the link here.

    Monday, March 2, 2015 3:34 PM

All replies

  • Hi Dennis,

    Have you tried to use the solution listed on the following blog?

    http://blogs.msdn.com/b/astebner/archive/2006/11/15/how-to-fix-error-code-25015-with-access-denied-message-during-net-framework-2-0-setup.aspx

    By the way, have you manually checked the permission for that folder in the logs?

    Best regards,



    Barry
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, February 26, 2015 4:20 AM
    Moderator
  • Hi Barry,

    Yes I have tried the above link.
    Regarding the manual checking, I created the reset.cmd file from the stock code that was on his blog.
    I assume that was correct. 
    Do you have any idea what the permissions should be?

    Regards,

    Dennis.

    Thursday, February 26, 2015 6:16 AM
  • Hello, doreski.

    Have you made any progress with your issue?

    If not, I'd like to suggest a couple of things:

    First, please use this tool to share the state of .NET frameworks on your system:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with the highest available .NET version selected, then post the first 15 lines AND the last 15 lines of the tool log here.

    Also, so past install attempts can be reviewed, please collect and share your install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like OneDrive, and post the link here.

    Monday, March 2, 2015 3:34 PM