locked
Azure Stack Deployment failed at Step 60 RRS feed

  • Question

  • VERBOSE: Action: Action plan 'Deployment' failed. - 6/7/2018 5:00:29 AM
    Invoke-EceAction : Action: Invocation of step 60 failed. Stopping invocation of action plan.
    At C:\CloudDeployment\Setup\DeploySingleNode.ps1:797 char:5
    +     Invoke-EceAction -RolePath $masterRole -ActionType $actionPlan @d ...
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Invoke-EceAction], ActionExecutionException
        + FullyQualifiedErrorId : Unspecified error,CloudEngine.Cmdlets.InvokeCmdlet
    Thursday, June 7, 2018 5:27 AM

Answers

  • Ensure that you are running the latest ASDK version, refer the document Azure Stack Development Kit release notes.


    To check if ASDK time is in sync with UTC run following commands and make sure the difference is + or – a second.

    Example output:

    18:37:02, -00.0104484s

    18:37:04, +00.0019010s

     

    ### Compare AzS-DC01 to UTC

    Invoke-command -Computername AzS-DC01 -ScriptBlock {w32tm /stripchart /Computer:time.windows.com /dataonly}

    ### Compare Host to UTC -

    w32tm /stripchart /Computer:time.windows.com /dataonly

     

    To check if the ASDK-Host & AzS VMs time are in sync with each other.

    ### Compare time on Host & AzS VMs

    $VM = Get-VM

    Invoke-command -Computername $VM.name -ScriptBlock {get-date}

    get-date

     

    To set the ASDK-Host & AzS VMs to UTC.

    ### Set time source on AzS-DC01 & Force sync to UTC

    Invoke-command -Computername AzS-DC01 -ScriptBlock {w32tm /config /manualpeerlist:"time.windows.com" /syncfromflags:manual reliable:yes /update}

    # Sync Host and VMs to AzS-DC01

    $VM = Get-VM

    Invoke-command -Computername $VM.name -ScriptBlock {w32tm /config /update /syncfromflags:DOMHIER}

    w32tm /config /update /syncfromflags:DOMHIER

     

    After setting ASDK to UTC redeploy using -rerun

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

     

    If the issue persist, kindly provide the following information to details:

     

    Build/Version:  

    Get-Content "C:\CloudDeployment\Configuration\Version\version.xml"

     

    Directory type: 

    Azure AD or ADFS

     

    Hardware: 

    How many CPU Cores, RAM, Get-Disk output

     

    Network: 

    Static or DHCP.

     

    The method used to access the Internet:

    NAT, Web Proxy, Transparent Proxy, DMZ or Closed

     

    BareMetal or Nested Hyper-V:

     

    Deployment parameters used:

     

    In the interim, if you haven't already done so, try redeploying using the -rerun parameter.

    NOTE: Make sure you are running the deployment as under the AzureStack\AzureStackAdmin account.

    Friday, June 22, 2018 5:43 AM