Async CTP (SP1 Refresh) Install Successful But Not Working RRS feed

  • Question

  • Hi All,
    The Async CTP (SP1 Refresh) refresh installation is not working.  It completes successfully but nothing appears in the "\Microsoft Visual Studio Async CTP\Documentation" directory doe not appear in My Documents (although "My Documents" does open during install).  Furthermore, when I attempt to open an async project (from another box), Visual Studio reports this project type is not supported.  I have run an uninstall from the command line and then re-installed but still nothing.
    Any suggestions on how to diagnose and resolve?  Here's a log of my most recent install.
    Saturday, July 2, 2011 5:56 PM


All replies

  • Summary Resolution:

    • Uninstall Visual Studio SP1
    • Uninstall Visual Studio 2010 
    • Uninstall Visual Studio PreReqs
    • Verified all "*Visual Studio*" related installs are removed (and removed them if they weren't).  
      (Visual Studio 2010 Tools for Office Runtime never did get removed from Programs and Features)
    • Renamed "C:\Program Files (x86)\Microsoft Visual Studio 10.0" as the directory still existed.
    • Reinstalled Visual Studio 2010
    • Reinstalled Visual Studio 2010 SP1
    • Reinstalled Async CTP (SP1 Refresh)

    The difference this time was that the Web Page with "Visual Studio Async CTP" displayed - whereas it didn't before.

    Other attempts that failed:

    • Running a repair on Visual Studio SP1
    • Uninstalling Visual Studio SP1
      Installing SP1
      Installing Async CTP 
    • Uninstalling Visual Studio 2010
      (Visual Studio SP1 stays installed and won't uninstall at this point)
      Installing SP1
      Installing Async CTP



    Monday, July 4, 2011 5:33 PM
  • Is there a cause/resolution for this issue?   This problem is occuring for me as well.  I have successfully installed the Async CTP on several workstations, but one of them fails with the same symptoms mentioned above.

    The install takes a hell of a long time to complete, almost 10 minutes.   After it does complete there is no folder created under My Documents with the samples and required assemblies.


    I realize this is a CTP, but surely there should be some recourse other than having to uninstall/reinstall all of Visual Studio.


    Monday, January 16, 2012 12:57 AM
  • I have similar Issue and It appears that Windows Phone SDK have to be installed before Async CTP :)


    Hope this help.

    • Edited by dominikj Monday, January 16, 2012 3:28 PM
    Monday, January 16, 2012 3:27 PM
  • No, the Windows phone SDK is not required to install Async CTP, the only requirement is that you have any SKU of Visual Studio 2010 with SP1 installed.

    tditty - can you provide more details on this machine? In general we know about two reasons for installation failures, the first is when the "My document" folder is on a network share, the second is when there is a VS patch that was shipped post Async CTP. 

    If you can provide us with more information such as what patches for VS are installed on this machine, the location of "my documents" folder and the version of msvbide.dll, we can look into this.




    Avner Aharoni
    Monday, January 16, 2012 6:13 PM
  • I don’t want to argue with source :)  but I have two precedence’s when while installing Async CTP there was no errors but there were no files in ‘Documents\Microsoft Visual Studio Async CTP’ (one on windows 7 and one on Windows server 2008). Without Windows Phone SDK after installing CTP Explorer displays my documents but there are no files in Documents. For me installing Phone SDK helped… I don’t know why but it helped.

    • Edited by dominikj Monday, January 16, 2012 7:39 PM
    Monday, January 16, 2012 6:54 PM
  • We will look at it. Thanks for the report.


    Avner Aharoni
    Monday, January 16, 2012 7:24 PM
  • We found an issue with Silverlight 5 tools RTM, if you have it installed, async cTP will not install correctly. See more here: http://social.msdn.microsoft.com/Forums/en-US/async/thread/8faf9f46-8ecd-4750-9b9e-9579d784d383


    Avner Aharoni
    Tuesday, January 24, 2012 10:26 PM
  • I went ahead and updated the blog post on this issue: http://intellitechture.com/async-ctp-sp1-refresh-fails-to-fully-install/



    Wednesday, January 25, 2012 9:52 PM
  • FWIW this issue appears to still happen w/ the v3 of the Async CTP that is presently available. I have only tried installing it thus far, I haven't tried the steps outlined as the "fix" in this thread (yet).

    I'm trying to install one more time, if it fails I will be following the steps here and reporting back.


    I followed the link in this thread to the thread related to Silverlight 5

    1) I didn't have SL5 installed

    2) the post in that thread alluding to the removal of a couple of installed KBs didn't solve my problem (though those KBs were present on my system, removing them didn't help)

    I'm now trying the full uninstall/reinstall indicated in this thread

    Twitter: @bc3tech

    • Edited by Brandon H_ Monday, July 2, 2012 4:36 PM update per SL thread
    Monday, July 2, 2012 2:37 PM