locked
Slow Build Issue RRS feed

  • Question

  • User114957 posted

    I've started having problems with our Android and iOS projects building extremely slowly in Xamarin studio.

    This first started happening with 5.10 (which has been working on my machine well for a long time).

    I have tried updating to 6.1.1 (both builds 15 and 17) with the latest versions of both SDKs, but unfortunately the issue still persists.

    I have also tried a complete reinstall of Xamarin by following the instructions here

    https://forums.xamarin.com/discussion/13755/complete-uninstall-on-mac-help https://developer.xamarin.com/guides/cross-platform/gettingstarted/installation/uninstallingxamarin>

    Interestingly the builds are only slow when connected to the internet. I have attached the build logs for our iOS and Android projects when both connected and disconnected.

    In summary timings are approximately as follows for clean builds:

    iOS Build (simulator SE 10.1) Connected - 23 mins Not connected - 19 secs Android Build Connected - 19 mins Not connected - 37 secs

    Looking under the 'Tasks performance summary' for the Droid/iOS builds, the slow build time can be attributed to a small number of targets.

    The worst offenders seem to be:

    iOS MTouch ResolveAssemblyReference Droid StripEmbeddedLibraries LinkAssemblies GenerateJavaStubs

    Friday, November 11, 2016 7:52 AM

All replies

  • User14247 posted

    I can duplicate this problem as well. I disconnected from the internet and the build completes normally in regular time.

    Friday, February 24, 2017 9:31 PM
  • User31867 posted

    I am also facing this issue. It works for first day, not build process taking infinite time.

    Sunday, April 9, 2017 1:34 PM