none
BizTalk 2009 support for EDIFACT messages ORDERS S93A and INSDES D96A RRS feed

  • Question

  • Is there any way to get support for these EDIFACT message types in BizTalk?
    I know there is support for this if I by the "Covast EDI Accelerator". But that seems to be overkill in my case.

    Thanks,

    /ola

    Saturday, October 31, 2009 8:52 AM

Answers

  • Hi,

    It seems that the message types that I want to use (INSDES D96A and ORDERS S93A) aren´t any standard EDIFACT messages.
    I will solve this by trying to make the partner user any of the standard EIDFACT messages or by modifying a existing schema so that it matches these messages.

    Thanks a lot anyway!

    Regards,

    /ola
    • Marked as answer by Hiselius Wednesday, November 11, 2009 8:54 PM
    Wednesday, November 11, 2009 8:54 PM

All replies

  • Hi,
       BTS 2009 do support EDIFACT message types.

    You can find an example here for EDIFACT processing in Biztalk:
    http://msdn.microsoft.com/en-us/library/bb743647(BTS.20).aspx


    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    Sunday, November 1, 2009 8:52 AM
  • Hi Gyan,

    Thank you for a fast answer.

    Yes, I know that BizTalk has support from EDIFACT. I have used it a lot. But I can not find any support for the message types ORDERS S:93A and INSDES D:96A. At least there are no schemas supplied for these messeges out of the box.

    Thanks,
    /ola
    Sunday, November 1, 2009 2:15 PM
  • BizTalk 2006 R2 and 2009 has a very wide variety of D96A schemas out of the box.

    In your BizTalk installation path is a folder "XSD_Schema". In there is a self extracting archive with about 8000 different schemas:
    MicrosoftEdiXSDTemplates.exe

    If you extract these (just doubleclick) you will have a number of different folders, the D96A schemas are in the EDIFACT\D96A.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, November 6, 2009 9:46 AM
    Moderator
  • Hi,

    I know that these schemas exist. But among all these 8000 schemas there aren´t any schema for ORDERS S:93A and INSDES D:96A.


    /ola

    Friday, November 6, 2009 1:14 PM
  • Hi,

    You could see D:96A at this location.
    C:\Program Files\Microsoft BizTalk Server 2006\XSD_Schema\EDI\XSDTemplate\EDIFACT\D96A

    But I could not see S: 93 A. This I browsed in BizTalk Server 2006 R2. Not sure about 2009.

    Regards
    Vishnu
    Vishnu
    Monday, November 9, 2009 11:50 AM
  • Hi,

    I have checked for BizTalk 2009. These schemas do not exist there iether. In the D96A folder there are no INSDES schemas. And a S93A does not exist at all. That’s wy I am looking for a solution somewhere else. Do you know if there are any third party that sells schemas for EDIFACT (except Covast)?

    Regards,

    /ola

    Monday, November 9, 2009 11:56 AM
  • Hi, 

    Unfortunately I don't know of any of the S93A schemas.
    But perhaps it's a good idea to compare the schemas. Maybe there is not much difference between the two?

    Best regards,
    Pieter
    Monday, November 9, 2009 1:03 PM
  • OK, thanks anyway.

    /ola
    Tuesday, November 10, 2009 8:36 AM
  • Hi,

    You should get some help at http://www.stylusstudio.com/edi/EDIFACT_translate.html and http://www.stylusstudio.com/edifact/D04B/ORDERS.htm .
    Looks they have some tools [Free Downloads as well], which could help you out to get the xsd out of your EDIFACT messages.
    Please let me know if it helps.

    Regards
    Vishnu


    Vishnu
    Tuesday, November 10, 2009 11:03 AM
  • Hi,

    It seems that the message types that I want to use (INSDES D96A and ORDERS S93A) aren´t any standard EDIFACT messages.
    I will solve this by trying to make the partner user any of the standard EIDFACT messages or by modifying a existing schema so that it matches these messages.

    Thanks a lot anyway!

    Regards,

    /ola
    • Marked as answer by Hiselius Wednesday, November 11, 2009 8:54 PM
    Wednesday, November 11, 2009 8:54 PM
  • Hi, Hiselius!

    How'd you solve this issue?

    I'm looking at the same problem here? Did you create a schema? Would that be something you could share? :-D

    Regards //Niklas

    Friday, March 4, 2011 11:10 AM
  • I guess use of S 93A and other "S" versions is not very relevant in US, but in Scandinavia it is quite common, and almost impossible to avoid if you are implementing Edifact. The absence of these scemas has quite certainly prevented several implementations of BizTalk as Edifact handler here in Scandinavia.

    I am currently working on upgrading a customers BizTalk 2006 solution to BizTalk 2010, and in the process they are replacing Covast EDI accellerator with stock BizTalk. Both IFTMIN S 93A and IFTMCS S 93A are schemas they need to process, but which is not included in MS vast range of Edifact schemas.

    I solved this quite easily: I took the D 9A schema, and renamed its root name from D to S, and that was about i. It worked on first try, and is a very easy solution to a problem I expected to be much worse.

     

    I must admit that I have not looked into what the difference between S 93A and D 93A actually is, I assume that there is some, but I can verify that the differences must be very very small. So far I have not found any when comparing between Covast representation of S 93A and my use of D 93A as S 93A. If you do actually find a discrepancy it is quite easy so customize edifact schemas and add/change the required fields. But my guess would be that you can solve this just as easy as I did. Good luck, and feel free to ask if you have any more questions about this.


    Sunday, March 13, 2011 6:39 PM