locked
Unable to Launch Desktop Designer RRS feed

  • Question

  • When I try and start Desktop designer I get an pop-up that says Application cannot be started. Contact the vendor. When I click on details I get this:

    PLATFORM VERSION INFO
     Windows    : 6.1.7601.65536 (Win32NT)
     Common Language Runtime  : 4.0.30319.18063
     System.Deployment.dll   : 4.0.30319.17929 built by: FX45RTMREL
     clr.dll    : 4.0.30319.18063 built by: FX45RTMGDR
     dfdll.dll    : 4.0.30319.17929 built by: FX45RTMREL
     dfshim.dll    : 4.0.41209.0 (Main.041209-0000)

    SOURCES
     Deployment url   : http://admin/_layouts/15/ppsma/1033/designer.application?Operation=OpenWebsite&SiteCollection=http://admin/sites/survey&SiteLocation=
          Server  : Microsoft-IIS/8.0
          X-Powered-By : ASP.NET
     Application url   : http://admin/_layouts/15/ppsma/1033/DesignerInstall/Designer.exe.manifest
          Server  : Microsoft-IIS/8.0
          X-Powered-By : ASP.NET

    IDENTITIES
     Deployment Identity  : DashboardDesigner.exe(en-us), Version=15.0.4549.1000, Culture=neutral, PublicKeyToken=f7b232fd7284a56a, processorArchitecture=msil

    APPLICATION SUMMARY
     * Online only application.
     * Trust url parameter is set.
    ERROR SUMMARY
     Below is a summary of the errors, details of these errors are listed later in the log.
     * Activation of http://admin/_layouts/15/ppsma/1033/designer.application?Operation=OpenWebsite&SiteCollection=http://admin/sites/survey&SiteLocation= resulted in exception. Following failure messages were detected:
      + Reference in the deployment does not match the identity defined in the application manifest.

    COMPONENT STORE TRANSACTION FAILURE SUMMARY
     No transaction error was detected.

    WARNINGS
     There were no warnings during this operation.

    OPERATION PROGRESS STATUS
     * [4/15/2014 10:26:33 AM] : Activation of http://admin/_layouts/15/ppsma/1033/designer.application?Operation=OpenWebsite&SiteCollection=http://admin/sites/survey&SiteLocation= has started.
     * [4/15/2014 10:26:38 AM] : Processing of deployment manifest has successfully completed.
     * [4/15/2014 10:26:38 AM] : Installation of the application has started.

    ERROR DETAILS
     Following errors were detected during this operation.
     * [4/15/2014 10:26:38 AM] System.Deployment.Application.InvalidDeploymentException (SubscriptionSemanticValidation)
      - Reference in the deployment does not match the identity defined in the application manifest.
      - Source: System.Deployment
      - Stack trace:
       at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, IDownloadNotification notification, DownloadOptions options, Uri& appSourceUri, String& appManifestPath)
       at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, Uri& appSourceUri, String& appManifestPath)
       at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
       at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
       at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
       at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

    COMPONENT STORE TRANSACTION DETAILS
     No transaction information is available.

    Any suggests?

    Tuesday, April 15, 2014 2:36 PM

Answers

All replies

  • According to your post, my understanding is that you failed to launch Desktop Designer.

    Did you mean the Dashboard Designer?

    If so, the issue occurs because of an inconsistency in the Dashboard Designer version numbers in the latest SharePoint Server 2013 public update and cumulative update.

    To resolve this issue, use one of the following methods.

    Method 1

    Revert your SharePoint Server 2013 installation to the last version before you installed the October 2013 update.

    Method 2

    If you cannot revert your SharePoint Server 2013 installation systematically, try to do it manually by replacing the following SharePoint Server 2013 files.

    Note The replacement files are available on the following Microsoft TechNet Blogs website:

    PerformancePoint 2013 Dashboard Designer fails to start after October 2013 CU

    Method 3

    Install SharePoint 2013 Service Pack 1

    More information:

    You cannot start Dashboard Designer in SharePoint Server 2013 after you install the October 2013 update

    PerformancePoint 2013 Dashboard Designer fails to start after October 2013 CU

    Best Regards,

    Linda Li


    Linda Li
    TechNet Community Support

    • Marked as answer by JasonGuo Sunday, April 27, 2014 6:15 AM
    Wednesday, April 16, 2014 6:09 AM
  • UP

    Hey everybody.

    Seems that re-released service pack 1 does not change the files - the problem still remains - any workaround (for languages other than 1033)?


    Sergey Head of Business Intelligence Line www.incoma.ru sergey.a.vdovin@gmail.com

    Monday, May 26, 2014 6:33 PM
  • As a current workaround i installed  slistream language pack service pack 1 ans use designer in english version

    Sergey Vdovin

    Thursday, May 29, 2014 8:04 AM
  • I've tried everthing in your suggestion and nothing worked. Am still unable to launch Dashboard Designer at all...

    A. M. Robinson

    Sunday, June 1, 2014 11:43 AM
  • Hi All,

    Same here as well. i have installed the newly re released Sp1 and April 2014 cu on our sharepoint 2013 environment, but it did not fix the issue. any one has other work around.


    YOGESHA H P(MCTS)

    Wednesday, August 27, 2014 7:12 AM
  • Tried this?:

    As a current workaround i installed  slistream language pack service pack 1 ans use designer in english version


    Sergey Vdovin

    Wednesday, August 27, 2014 8:04 AM
  • These procedures does not work!

    SP2013 with SP1 does not fix anything nor the 3 methods presented above.

    Any other fix available since almost one year?

    Is Microsoft waiting for the problem to vanish from the forums?

    Anybody home?

    Thursday, March 12, 2015 2:20 PM