locked
Deploy RIA services: choose your favorite error (404.3 or System.ServiceModel.Activation.HttpModule) RRS feed

  • Question

  • Now, if this is not funny i don't know what it is.

    I deploy my SL application to Windows server 2008, IIS 7.

    I was getting error:
    Could not load type 'System.ServiceModel.Activation.HttpModule' from assembly 'System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

    This was fix here.

    Then i get this error when accesing svc file:

    Server Error in Application "mydomain"

    Internet Information Services 7.0
    Error Summary
    HTTP Error 404.3 - Not Found
    The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.
    Detailed Error Information
    Module    StaticFileModule
    Notification    ExecuteRequestHandler
    Handler    StaticFile
    Error Code    0x80070032
    Requested URL    http://mydomain:80/Service1.svc
    Physical Path    ....\mydomain\Service1.svc
    Logon Method    Anonymous
    Logon User    Anonymous
    Most likely causes:

    ......


    I fix this with ServiceModelReg.

    Any gues what i am back to:
    ould not load type 'System.ServiceModel.Activation.HttpModule' from assembly 'System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

    So isn't this lovely. I spent 3 days trying to deploy SL application, because of that.

     

    Tuesday, May 18, 2010 1:00 PM

Answers

  • Sorry, yes, I meant application pools.

    You should run ServiceModelReg from \Windows\Microsoft.NET\Framework\v4.0... (forgot the exact number). ServiceModelReg is no longer inside the WCF sub-dir - it's now directly inside the framework version directory.

    Tuesday, May 18, 2010 6:45 PM
  • Can you try running ServiceModelReg -ia (install all components)?

    Tuesday, May 18, 2010 7:00 PM
  • fora, you may be having trouble getting answers because your questions fall outside the expertise of many of the people on this forum. You might get better results re-asking your question on either the WCF forum or the IIS forum. Tell them you're having trouble deploying a WCF RIA Services application using .NET 4 and ASP.NET on IIS7 (?). Hopefully they will be more familiar with the errors and be able to provide you with better solutions.

    Kyle

    Wednesday, May 19, 2010 12:31 PM

All replies

  • It looks like the AppDomain of your website isn't using .NET 4, because it's trying to load version 3.0.0.0 of ServiceModel instead of 4.0.0.0. Can you open the IIS admin console, go to AppDomains and find the AppDomain that's being used for your app, and make sure it's running against .NET 4?

    Tuesday, May 18, 2010 5:47 PM
  • If you mean application pools, i am using application pool with net framework v4.0 (pipeline: Integrated) for my website.

     I don't have any net 3.0.0.0 installed. I never did.

    But i am running servicemodelreg -r -y from Windows\microsft.net\framework\v3.0\windows communication foundation, because v4.0 doesn't have any windows communication folder.
    Is this ok? To run it from this v3.0 directory?

    And when i run servicemodelreg in IIS manager 2 handler mappings is added:
    Managed handler: *.svc and
    type:System.ServiceModel.Activation.HttpHandler, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

    I can change it to 4.0.0.0, but the error stay the same.

    The second is Script map: *.svc
    Executable:
    C:\Windows\Microsoft.NET\Framework\vv2.0.50727\aspnet_isapi.dll
    but i also manualy changed this to 4.0.*, but the same error:

    Could not load type 'System.ServiceModel.Activation.HttpModule' from assembly 'System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.


    Tuesday, May 18, 2010 6:40 PM
  • Sorry, yes, I meant application pools.

    You should run ServiceModelReg from \Windows\Microsoft.NET\Framework\v4.0... (forgot the exact number). ServiceModelReg is no longer inside the WCF sub-dir - it's now directly inside the framework version directory.

    Tuesday, May 18, 2010 6:45 PM
  • Where can i get any help for this?

    I try servicemodelreg -i but i am getting error:
    [Error] Switch '-c' requires a component to be specified for installation or uninstallation. Please specify which component to install or uninstall.

    By the way. All post all google searches everything is for net 3.0. I was searching for Windows Communication Foundation map in v4.0 dir but didn't find it. So much time spent for nothing.

    Thanks for that.

    Tuesday, May 18, 2010 6:58 PM
  • Can you try running ServiceModelReg -ia (install all components)?

    Tuesday, May 18, 2010 7:00 PM
  • Well -ia  is solution for that.

    Now i am getting error:

     

    Server Error

    Internet Information Services 7.0

    Error Summary

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Detailed Error Information
    Module IIS Web Core
    Notification Unknown
    Handler Not yet determined
    Error Code 0x80070032
    Config Error The configuration section 'system.serviceModel' cannot be read because it is missing a section declaration
    Config File \\?\d:\inetpub\vhosts\mydomain\subdomains\test2\httpdocs\web.config
    Requested URL http://mydomain:80/Service1.svc
    Physical Path
    Logon Method Not yet determined
    Logon User Not yet determined
    Config Source
       32: 
    33: <system.serviceModel>
    34: <behaviors>
    Links and More Information This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.

    View more information »

     

    Tuesday, May 18, 2010 7:01 PM
  • Yikes. Looks like we're running in some nasty dependency ordering issue.

    Can you try re-installing IIS by going to "Turn on/off Windows features", unchecking IIS, OK'ing the dialog, then go back and check it again? You shouldn't have to run ServiceModelReg or anything after that, because if you install IIS now, it already knows about WCF.

    Tuesday, May 18, 2010 7:27 PM
  •  Thanks.
    I did start a new thread for this problem.

    Edit:

    To answer your question. No this is not an option. That would collapse a lot of web pages. This is production server.

    Tuesday, May 18, 2010 7:27 PM
  • fora, you may be having trouble getting answers because your questions fall outside the expertise of many of the people on this forum. You might get better results re-asking your question on either the WCF forum or the IIS forum. Tell them you're having trouble deploying a WCF RIA Services application using .NET 4 and ASP.NET on IIS7 (?). Hopefully they will be more familiar with the errors and be able to provide you with better solutions.

    Kyle

    Wednesday, May 19, 2010 12:31 PM