locked
VS2012 bug and Xamarin studio can't debug (breakpoint are ignored) RRS feed

  • Question

  • User2119 posted

    Hello everybody,

    My VS2012 have a bug with Xamarin plugin. https://us.v-cdn.net/5019960/uploads/FileUpload/b7/b4feb06b93d051d8009c0064625698.jpg (in English : Impossible to load the file or the assembly Microsoft.VisualStudio.ExtensibilityHosting ... or one of its dependences. File not found.

    I remove Xamarin + VS 2012, and reinstall it : same problem.

    Anyway, I try to use Xamarin Studio, and it able to open my VS2012 project, BUT when I try to debug my app, the breakpoint don't work at all ! The app is not "paused".... I checked that my app is launched in Debug mode, so I don't understand what happening since I am on Windows 8.

    Thursday, March 14, 2013 8:47 AM

All replies

  • User943 posted

    I have got the same error when I try to deploy...

    New installed vs2012 on windows 8 x64, then installed xamarin. Now I can't deploy any android app. I got allways the following error:

    Fehler: Die Datei oder Assembly "Microsoft.VisualStudio.ExtensibilityHosting, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040)

    The Android Settings in VS2012 Options also showing only an error message...

    Hope for any help!

    Best Regards Renzo

    Monday, March 18, 2013 7:20 AM
  • User2119 posted

    This bug is very ... My windows's username is with a dot inside, so I thought that the problem was with that. I created a new user called tester. I reinstall for this user xamarin and the verification process is infinite (proof: http://www.youtube.com/watch?v=LoJqMBcfdzY)

    If the internet access is not present, the verification make a force close.... Need to fix that asap !

    Monday, March 18, 2013 9:02 AM
  • User7988 posted

    Impossible to load the file or the assembly Microsoft.VisualStudio.ExtensibilityHosting

    I also had this problem, and i found the solution: this issue can be fixed by installing English Language Pack in Visual Studio. http://www.microsoft.com/en-us/download/details.aspx?id=30681

    Monday, April 8, 2013 10:30 AM
  • User7988 posted

    You also should select english language in settings: Tools -> Options -> International Settings

    Monday, April 8, 2013 10:41 AM
  • User2119 posted

    I fix it by selecting beta version. But thanks for your help Scalar ! It's so boring that Xamarin team doesn't test enough their released program....

    Monday, April 8, 2013 2:07 PM
  • User37843 posted

    I have the same problem but I am using windows 7 (VS 2013 and Xamarin 3). I tried switching to the beta version but it says it is "Up to date".

    Also tried re installing VS and Xamarin but neither solved this problem.

    Would appreciate any help from Xamarin or anyone else. Thank you!

    Friday, June 6, 2014 12:29 AM