none
SSMS as a remoteapp keeps disappearing on query execute or database change RRS feed

  • Question

  • Our RDS is hosted on a Win2012 R2 (current with updates) VM in a data center, and we publish apps for remote workers - Dynamics AX, SSMS, third party apps, etc.  VM has 48 GB RAM, SSDs, Xeon procs, etc , and I believe is configured properly for RDS best practice.

    When using SSMS (17.5) as a remoteapp, the app itself disappears when I either change databases in the database listbox, or execute a query.  The app disappears, but you can still see a box outline of the app itself, and I have to click on the screen for the app to reappear. This happens for users that are remote or on the corporate network. For remote users, there is no VPN in play.

    I am not sure if this is SSMS or RDS issue, as this is my first time dealing with remoteapps/RDS, so I thought i'd start with SQL side.

    Any ideas if this is known issue/expected for SSMS as a remoteapp?

    Monday, February 19, 2018 7:25 PM

All replies

  • Hi Greg Y,

    We also use SSMS 17.5 as a remote app, we used Remote Desktop Connection Manager (RDCMan) to connect to the remote virtual machine. It works well on this machine.

    I tested it with Remote Desk Service (RDS) and did not meet a similar problem. I suggest you using RDCMan to connect to it for test, if it works normally, this can be a problem of the incompatibility between SSMS and RDS or some other application.

    Besides, what about using SSMS of other versions? Does it work normally in your scenario?

    Best Regards,

    Teige


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 20, 2018 9:31 AM
    Moderator
  • Did you ever crack this? We have exactly the same problem.

    Have tried a few 17.x including 17.6. Have just rebuilt RDS server (2012 R2) and it still does it.

    Rather annoying.

    Andy

    Wednesday, April 25, 2018 10:36 AM
  • Did you ever crack this? We have exactly the same problem.

    Have tried a few 17.x including 17.6. Have just rebuilt RDS server (2012 R2) and it still does it.

    Rather annoying.

    Andy

    Our users have been reporting the same issues for the last few months.
    RDS Farm has been migrated to from 2012 r2 to 2016 and SMSS 2016 (13.0.16106.4)

    The farm was upgraded in September 2017, users only reported issues since march 2018.

    Wednesday, May 23, 2018 4:10 AM
  • Hi.

    Was wondering if you had any update on this? Did you manage to fix or do you have a workaround in place?

    Thanks

    D

    Tuesday, August 21, 2018 11:16 AM
  • I have not found an update or workaround, we simply avoid using SSMS on RemoteApp at the moment, and use our VPN instead.
    Wednesday, August 29, 2018 12:31 PM
  • Same issue here.  For me and a co-worker, it started when we got new laptops.  May it is related to a video card setting or a Windows 10 setting because the RDS session hosts didn't change.  I tried making a few changes to the .RDP file but have had no luck improving the situation.
    Tuesday, November 5, 2019 6:31 PM