locked
"Unable to install or run the application. The application requires that assembly Microsoft.ReportViewer.ProcessingObjectModel Version x.x.x.x be installed in the Global Cache (GAC) first. RRS feed

  • Question

  • Hello Community

        I have a Windows Application written in c#. I use ClickOnce deployment.

        When I publish the application in ClickOnce there is a button for "Prerequisites"
    there is a selection for "Microsoft Visual Studio 2008 Report Viewer".

        I can install the application on my box but when I go to the user and try to install the application on their computer I get an error message stating:

    "Unable to install or run the application. The application requires that assembly Microsoft.ReportViewer.ProcessingObjectModel Version x.x.x.x be installed in the Global Cache (GAC) first.

        How do I get the application to install on the users computers?

        Thanks
        Shabeaut

       


    Thursday, September 8, 2016 10:19 PM

Answers

  • Hi Shabeaut,

    >> "Unable to install or run the application. The application requires that assembly Microsoft.ReportViewer.ProcessingObjectModel Version x.x.x.x be installed in the Global Cache (GAC) first.

    For this issue, I suggest you check Project property-> Publish-> Application Files-> Include the Microsoft.ReportViewer.ProcessingObjectModel assembly. With this way, when your ClickOnce is deployed, the dll is deployed locally along with it and will not look for it in GAC.

    You could refer the similar threads below:

    # ClickOnce Application throws error “..requires assembly MySql.Data Version 6.5.4.0 be installed in the Global Assembly Cache (GAC) first.”

    http://stackoverflow.com/questions/12270919/clickonce-application-throws-error-requires-assembly-mysql-data-version-6-5-4

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Monday, September 12, 2016 5:36 AM

All replies

  • Hi Shabeaut,

    Welcome to the MSDN forum.

    According to your description, your issue is more related to the ClickOnce. Since our forum is to discuss the Visual Studio Setup and Installation, I will help you move it to the appropriate forum: https://social.msdn.microsoft.com/Forums/windows/en-US/home?forum=winformssetup for dedicated information, thank you for your understanding.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 9, 2016 3:34 AM
  • Hi Shabeaut,

    >> "Unable to install or run the application. The application requires that assembly Microsoft.ReportViewer.ProcessingObjectModel Version x.x.x.x be installed in the Global Cache (GAC) first.

    For this issue, I suggest you check Project property-> Publish-> Application Files-> Include the Microsoft.ReportViewer.ProcessingObjectModel assembly. With this way, when your ClickOnce is deployed, the dll is deployed locally along with it and will not look for it in GAC.

    You could refer the similar threads below:

    # ClickOnce Application throws error “..requires assembly MySql.Data Version 6.5.4.0 be installed in the Global Assembly Cache (GAC) first.”

    http://stackoverflow.com/questions/12270919/clickonce-application-throws-error-requires-assembly-mysql-data-version-6-5-4

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Monday, September 12, 2016 5:36 AM