locked
Integration Runtime Create Linked Service - Authentication Issue RRS feed

  • Question

  • Hello,

    This is in regards to Data Factory v2.

    I am unable to create a linked service pointing to onpremise SQL Server. I have the Integration Runtime properties all green, even did the diagnostics successfully.

    When I try to create linked service pointing to the onpremise integration runtime, I get the following error:

    Connection failed: InternalError: please contact Microsoft support, activityId: bb1a4ac9-a067-46f8-a877-7ec26c119fdf

    I tried several different settings, without any success, even re-installing the IR.

    Your input is much appreciated.

    Regards,

    R

    Tuesday, February 13, 2018 1:41 PM

All replies

  • We also have this issue. On all existing connections using a self-hosted integration runtime, we are facing this probleem too. All these connections were working succesfully, but now they are not working giving the same error: InternalError.

    It looks like there is a coincidence. Maybe something didn't went go well at the side of Microsoft?
    Tuesday, February 13, 2018 4:23 PM
  • Thank you for sharing your input. I can confirm that I was able to connect before as well.

    Tuesday, February 13, 2018 5:41 PM
  • I'm having the same issue, same error, but with different on-prem connection type.  I can confirm they were working, and the connection type still works in v1. 
    Tuesday, February 13, 2018 7:35 PM
  • Hi all,

    It seems the issue was fixed by MS. I am able to connect now.

    Regards,

    R

    Wednesday, February 14, 2018 5:52 AM
  • Hi all,

    It seems the issue was fixed by MS. I am able to connect now.

    Regards,

    R

    Yes indeed, MS confirmed the issue caused by a recent deployment and they got it fixed.

    Wednesday, February 14, 2018 8:28 AM
  • Confirmed my issue was fixed also.
    Wednesday, February 14, 2018 2:52 PM