locked
'Group cannot be found' error during running content deployment job. RRS feed

  • Question

  •  

    Hi,

    I have created content deployment job for deploying contents from staging server to production server.

    Job run fine for few days,

    but now it gives error 'Content deployment job 'Remote import job for job with sourceID = b391ada2-9d57-4af8-89a7-b171938eae14' failed.The exception thrown was 'Microsoft.SharePoint.SPException' : 'Group cannot be found.'

    Group cannot be found. at Microsoft.SharePoint.SPGroup.InitMember() at Microsoft.SharePoint.SPGroup..ctor(SPWeb web, ISecurableObject scope, SPUser user, String GroupName, Object[,] arrGroupsData, UInt32 index, Int32 iByParamId, SPGroupCollectionType groupCollectionType) at Microsoft.SharePoint.SPGroupCollection.get_Item(String name) at Microsoft.SharePoint.Deployment.RoleAssignmentXImport.UpdateAssignment(ImportStreamingContext context, SPWeb web, ISecurableObject obj, Boolean bAdd, String strUser, String strGroup, String strRole) at Microsoft.SharePoint.Deployment.RoleAssignmentXImport.ProcessElement(ImportStreamingContext context, XmlReader xr, SqlSession session) at Microsoft.SharePoint.Deployment.SqlImport.Run() at Microsoft.SharePoint.Deployment.SecurityObjectSerializer.SetObjectData(Object obj, SerializationInfo info, StreamingContext context, ISurrogateSelector selector) at Microsoft.SharePoint.Deployment.XmlFormatter.ParseObjectDirect(Object objParent, Type objectType) at Microsoft.SharePoint.Deployment.XmlFormatter.DeserializeObject(Type objectType, Boolean isChildObject, DeploymentObject envelope) at Microsoft.SharePoint.Deployment.XmlFormatter.Deserialize(Stream serializationStream) at Microsoft.SharePoint.Deployment.ObjectSerializer.Deserialize(Stream serializationStream) at Microsoft.SharePoint.Deployment.ImportObjectManager.ProcessObject(XmlReader xmlReader) at Microsoft.SharePoint.Deployment.SPImport.DeserializeObjects() at Microsoft.SharePoint.Deployment.SPImport.Run() No any group setting or user setting has been changed.

    Can anybody help on this?

    Wednesday, January 21, 2009 9:22 AM

Answers

All replies

  • Hello Heena,

     

    Generally, this error implies that the required object reference doesn’t exist. If so, this issue is very possibly a known one and fixed by updates.

     

    ·         Please confirm that your SharePoint farm has Service Pack 1 applied.

    ·         Please apply August cumulative update package:

    (KB960010) Description of the Windows SharePoint Services 3.0 cumulative update package (WSS server-package): December 16, 2008
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;960010

    To deploy the hotfix in your farm, please refer to:

     

    Deploy software updates for Office SharePoint Server 2007

    http://technet.microsoft.com/en-us/library/cc263467.aspx

     

    Deploy software updates for Windows SharePoint Services 3.0

    http://technet.microsoft.com/en-us/library/cc288269.aspx

     

    Please give it a try and let us know the result. Thanks.

     

    Best Regards,

    Lionel

    Friday, January 23, 2009 9:33 AM
  •  

    Hello

    What was happening is the following as of lot of errors in sharepoint they are not very descriptive “Group cannot be found” mean that group had no permission within site, to be accessible the group should have at least read permission within the site.

     So if you create new group or your using group with no access, you will have the error

    Resolution :

    Give permission to your group on the site J

    Cheers


    Momo
    Tuesday, January 25, 2011 5:15 PM