2013 Workflows goes cancelled state in SharePoint Server 2016 RRS feed

  • Question

  • Hey Guys,

    I have two band new SharePoint 2016 Deployments (With latest CU installed) With Workflow Manager 1.0 Configured (In a Different Server)

    Both these deployments are prompting an strange behavior on 2013 Workflows. 2013 workflow can be created and published without a issue at all but when starting manually (Automatic start doesn't work at all) the status goes cancelled. 2010 workflows are working well and this behavior only appears on 2013 WFs.

    1. Installation of WF Manager setup went well without any issues

    2. I have tried to remove the WF farm and install again and then join the SP Farm to it with no shed of any lights

    3. HNSC and generic both ways are tried

    3. WFM Server, AD, DB, APP all servers are in the same network

    4. WFM and SP Servers are communicating well

    5. No firewalls at all

    6. Latest updates for WFM and SP16 are installed and tried with no luck

    7. Verified the WFM service URL by accessing from SP16 server and SP site from the WFM server. both are loaded properly on both sides and communication has no issues.

    8. SharePoint Logs shows are same error as below and nothing beyond

    9. Workflow are allowed to be able to use APP Permissions

    10. Full Control Permissions also granted to Workflows through "http://{hostname}/{the Site Collection}/_layouts/15/appinv.aspx" page

    all above are tried with no shed of a light.

    Below is the error contained in exclamation mark icon in theInternal Status of each WF instances:

    RequestorId: 0f2921e8-c2c8-c48c-3240-de0626a44ccc. Details: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary. at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

    Snapshot of the same is below:

    has anyone faced this and came across a solution or is it a weird bug ? any relevant response is greatly appreciated

    Thank You

    Sunday, October 23, 2016 1:32 PM


  • Ultimately, I had to Unregister the WFM from the SharePoint Farm and Re-Built the WFM Farm from the scratch in a dedicated server. ensuring the following set of services running in green state in the new server with all latest updates are installed, WF started working well in SP2016 Sites.

    1. Workflow management backend Service

    2. Both Service Bus Services

    This step guidance essentially takes through the right steps -

    Tuesday, October 25, 2016 11:11 AM