locked
Website not working ASP error Event 1310 RRS feed

  • Question

  • User-1067128194 posted

    Hi All

    I need assistance with getting this Website to work.

    The website was working fine on a Web Server (32-bit Windows Server 2003) - IIS6.0

    I migrated the entire website across to a new Server (64-Bit Windows Server 2008 R2) - IIS7

    Now when I access the website, I get an Application Error. The following are many warnings being logged in the Event Viewer.

    Please assist as I need to get this Website up and running.

    Event 1310, ASP.NET 2.0.50727.0

    Event code: 3008
    Event message: A configuration error has occurred.
    Event time: 12/04/2013 10:35:06 AM
    Event time (UTC): 12/04/2013 12:35:06 AM
    Event ID: b82380f005d74ac0b20e8a7c568befeb
    Event sequence: 1
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/11/ROOT-11-130102005060342963
        Trust level: Full
        Application Virtual Path: /
        Application Path: C:\Inetpub\vhosts\xyzwebsite.com\httpdocs\
        Machine name: WebServer
     
    Process information:
        Process ID: 4672
        Process name: w3wp.exe
        Account name: WebServer\IWPD_51(xyzweb)
     
    Exception information:
        Exception type: HttpException
        Exception message: Invalid access to memory location. (Exception from HRESULT: 0x800703E6)
     
    Request information:
        Request URL: http://www.xyzwebsite.com/Default.aspx
        Request path: /Default.aspx
        User host address: <IP>
        User:  
        Is authenticated: False
        Authentication Type:  
        Thread account name: WebServer\IWPD_51(xyzweb)
     
    Thread information:
        Thread ID: 10
        Thread account name: WebServer\IWPD_51(xyzweb)
        Is impersonating: False
        Stack trace:    at System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
       at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
       at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
     
     

    Thursday, April 11, 2013 11:29 PM

All replies

  • User2125765622 posted

    See enable32BitAppOnWin64 property for Application Pools. 

    http://www.iis.net/configreference/system.applicationhost/applicationpools/add#005

    Friday, April 12, 2013 6:01 PM
  • User-1067128194 posted

    Hi Mike

    Thanks for the Link.

    I did set the property and now started getting below 2 errors in the Event Viewer:

    Event ID:   2268

    Source:   IIS-W3SVC-WP

    Error:      Could not load all ISAPI filters for site 'xyz.com'.  Therefore site startup aborted.

    Event ID:   2274

    Source:   IIS-W3SVC-WP

    Error:       ISAPI Filter 'C:\Program Files (x86)\Parallels\Plesk\isapi\urlprotect.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a AMD64 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.

    In order to fix these, I removed the above mentioned filter from the ISAPI Filter settings for this Site.

    Once removed, I am now getting a different Warning:

    Event code: 3008
    Event message: A configuration error has occurred.
    Event time: 13/04/2013 12:18:14 PM
    Event time (UTC): 13/04/2013 2:18:14 AM
    Event ID: ff003ebe467b42638387ec2231412691
    Event sequence: 1
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/11/ROOT-1-130102930940806757
        Trust level: Full
        Application Virtual Path: /
        Application Path: C:\Inetpub\vhosts\xyz.com\httpdocs\
        Machine name: WebServer
     
    Process information:
        Process ID: 2536
        Process name: w3wp.exe
        Account name: WebServer\IWPD_51(abc)
     
    Exception information:
        Exception type: HttpException
        Exception message: Could not load file or assembly 'Markit.Modules.SlideShow' or one of its dependencies. An attempt was made to load a program with an incorrect format.
     
    Request information:
        Request URL: http://xyz.com/Default.aspx?randomHash=38442a76bec06968df6ab007fb47a885
        Request path: /Default.aspx
        User host address: IPAddress
        User:  
        Is authenticated: False
        Authentication Type:  
        Thread account name: WebServer\IWPD_51(abc)
     
    Thread information:
        Thread ID: 5
        Thread account name: WebServer\IWPD_51(abc)
        Is impersonating: False
        Stack trace:    at System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
       at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
       at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
     
     

    Please assist.

    Thanks

    Friday, April 12, 2013 10:09 PM
  • User2125765622 posted

    hmm... that setting should be all you need unless those DLL's do not run on a 64bit OS. i did some researching on the Plesk dll and found an interesting and informative posting http://social.msdn.microsoft.com/Forums/en-US/tfssetup/thread/fdf9cf0c-7102-4d73-bb77-aafa7d3b4a0b/ Maybe it will lead you in the right direction. 

    As for the Markit module, I did not find anything specific or helpful on that one. 

    By chance is your site a DotNetNuke site?

    Hope the link helps. 

    Saturday, April 13, 2013 8:49 AM
  • User-1067128194 posted

    Hi Mike

    I checked the above mentioned Post.

    I will not be able to make any changes since there are 15 other websites running fine on the same Server.

    Also, I have removed that dll file that I was getting an error with and now I am still getting that Markit module error.

    Yes it a DotNetNuke website

    I cant even find that module in the Web.config file.

    Thanks

    Sunday, April 14, 2013 8:37 PM
  • User311508580 posted

    Hi vishistgupta,

    You may need to check the connection string again. For DNN, we believe it is not complicated issue. We have many clients use DNN too. When migrate our client site to new server, we just need to migrate the files first to new server, restore their db, and then check the connection string. Hope it helps

    Sunday, April 14, 2013 11:29 PM
  • User-1067128194 posted

    Hi

    I have already migrated the databases across and also checked the connection string.

    Still not working.

    Thanks

    Monday, April 15, 2013 1:17 AM
  • User2125765622 posted

    Could you post your web.config contents?

    Monday, April 15, 2013 10:34 AM
  • User-1067128194 posted

    Hi Mike

    Below is the Config...

    <configuration>
      <!-- register local configuration handlers -->
      <configSections>
        <sectionGroup name="dotnetnuke">
          <!-- the requirePermission attribute will cause a syntax warning - please ignore - it is required for Medium Trust support-->
          <section name="data" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="logging" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="scheduling" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="htmlEditor" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="navigationControl" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="searchIndex" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="searchDataStore" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="friendlyUrl" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="caching" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="authentication" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="members" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="roles" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
          <section name="profiles" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
        </sectionGroup>
      </configSections>
      <connectionStrings>
        <add name="SiteSqlServer" connectionString="Data Source=(local)\SQLEXPRESS;Initial Catalog=X_YZ;User ID=user1;Password=pass1" />
      </connectionStrings>
      <appSettings>
        <!-- Connection String for SQL Server 2005 Express - kept for backwards compatability - legacy modules   -->
        <add key="SiteSqlServer" value="Data Source=(local)\SQLEXPRESS;Initial Catalog=XYZ;User ID=user1;Password=pass1" />
        <!-- Connection String for SQL Server 2000/2005 - kept for backwards compatability - legacy modules
        <add key="SiteSqlServer" value="Server=(local);Database=DotNetNuke;uid=;pwd=;"/>
        -->
        <add key="InstallTemplate" value="DotNetNuke.install.config" />
        <add key="AutoUpgrade" value="true" />
        <add key="UseInstallWizard" value="true" />
        <add key="InstallMemberRole" value="true" />
        <add key="ShowMissingKeys" value="false" />
        <add key="EnableWebFarmSupport" value="false" />
        <add key="EnableCachePersistence" value="false" />
        <add key="HostHeader" value="" />
        <!-- Host Header to remove from URL so "www.mydomain.com/johndoe/Default.aspx" is treated as "www.mydomain.com/Default.aspx" -->
        <add key="RemoveAngleBrackets" value="false" />
        <!--optionally strip angle brackets on public login and registration screens-->
        <add key="PersistentCookieTimeout" value="0" />
        <!--use as persistent cookie expiration. Value is in minutes, and only active if a non-zero figure-->
        <!-- set UsePortNumber to true to preserve the port number if you're using a port number other than 80 (the standard)
        <add key="UsePortNumber" value="true" /> -->
        <add key="InstallationDate" value="12/3/2008" />
            <add key="enable32BitAppOnWin64" value="true" />
      </appSettings>
      <system.codedom>
        <compilers>
          <compiler language="vb" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" extension=".VB" />
        </compilers>
      </system.codedom>
      <!-- The system.webServer section is required for IIS7 compatability It is ignored by IIS6-->
      <system.web>
        <!-- Ensure validationkey is not set to AutoGenerate,IsolateApps so it correctly supports webfarms -->
        <machineKey decryption="Auto" decryptionKey="AutoGenerate,IsolateApps" validation="SHA1" validationKey="AutoGenerate,IsolateApps" />
        <!-- HttpModules for Common Functionality -->
        <httpModules>
          <!-- add name="Authentication" type="DotNetNuke.HttpModules.AuthenticationModule, DotNetNuke.HttpModules.Authentication" / -->
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add name="Compression" type="DotNetNuke.HttpModules.Compression.CompressionModule, DotNetNuke.HttpModules" />
          <add name="RequestFilter" type="DotNetNuke.HttpModules.RequestFilter.RequestFilterModule, DotNetNuke.HttpModules" />
          <add name="UrlRewrite" type="DotNetNuke.HttpModules.UrlRewriteModule, DotNetNuke.HttpModules" />
          <add name="Exception" type="DotNetNuke.HttpModules.Exceptions.ExceptionModule, DotNetNuke.HttpModules" />
          <add name="UsersOnline" type="DotNetNuke.HttpModules.UsersOnline.UsersOnlineModule, DotNetNuke.HttpModules" />
          <add name="DNNMembership" type="DotNetNuke.HttpModules.Membership.MembershipModule, DotNetNuke.HttpModules" />
          <add name="Personalization" type="DotNetNuke.HttpModules.Personalization.PersonalizationModule, DotNetNuke.HttpModules" />
        </httpModules>
        <httpHandlers>
          <!-- This is for CAPTCHA support -->
          <add verb="*" path="*.captcha.aspx" type="DotNetNuke.UI.WebControls.CaptchaHandler, DotNetNuke" />
          <!-- This is for Serving files, secure, insecure, from database -->
          <add verb="*" path="LinkClick.aspx" type="DotNetNuke.Services.FileSystem.FileServerHandler, DotNetNuke" />
          <!-- This adds syndication support -->
          <add verb="*" path="RSS.aspx" type="DotNetNuke.Services.Syndication.RssHandler, DotNetNuke" />
          <!-- This adds legacy support for the Logoff page -->
          <add verb="*" path="Logoff.aspx" type="DotNetNuke.Services.Authentication.LogOffHandler, DotNetNuke" />
          <!-- ASP.NET AJAX support -->
          <remove verb="*" path="*.asmx" />
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />
        </httpHandlers>
        <!-- set code access security trust level - this is generally set in the machine.config
        <trust level="Medium" originUrl=".*" />
         -->
        <!-- set debugmode to false for running application -->
        <compilation strict="false">
          <buildProviders>
            <remove extension=".resx" />
            <remove extension=".resources" />
          </buildProviders>
          <assemblies>
            <add assembly="Microsoft.VisualBasic, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.DirectoryServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          </assemblies>
          <!-- register your app_code subfolders to generate granular assemblies during compilation
          <codeSubDirectories>
             <add directoryName="sub-directory name"/>
          </codeSubDirectories>
          -->
          <codeSubDirectories>
            <add directoryName="HTML" />
          </codeSubDirectories>
        </compilation>
        <!-- permits errors to be displayed for remote clients -->
        <customErrors mode="On" />
        <!-- Forms or Windows authentication -->
        <authentication mode="Forms">
          <forms name=".DOTNETNUKE" protection="All" timeout="60" cookieless="UseCookies" />
        </authentication>
        <!--
                <identity impersonate="true"/>
                <authentication mode="Windows">
                </authentication>
            -->
        <!-- allow large file uploads -->
        <httpRuntime useFullyQualifiedRedirectUrl="true" maxRequestLength="8192" requestLengthDiskThreshold="8192" />
        <httpCookies httpOnlyCookies="true" requireSSL="false" domain="" />
        <!--  GLOBALIZATION
            This section sets the globalization settings of the application.
            Utf-8 is not supported on Netscape 4.x
            If you need netscape compatiblity leave iso-8859-1.
            UTF-8 is recommended for complex languages
            -->
        <globalization culture="en-US" uiCulture="en-AU" requestEncoding="UTF-8" responseEncoding="UTF-8" fileEncoding="UTF-8" />
        <!--<globalization culture="en-US" uiCulture="en"  fileEncoding="iso-8859-1" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1"/>-->
        <!-- page level options -->
        <pages validateRequest="false" enableViewStateMac="true" enableEventValidation="false">
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          </controls>
          <namespaces>
            <add namespace="System.ComponentModel" />
            <add namespace="System.Data" />
            <add namespace="System.Data.SqlClient" />
            <add namespace="System.Drawing" />
            <add namespace="Microsoft.VisualBasic" />
            <add namespace="System.Globalization" />
            <add namespace="DotNetNuke.Services.Localization" />
            <add namespace="DotNetNuke.Entities.Users" />
            <add namespace="DotNetNuke" />
            <add namespace="DotNetNuke.Common" />
            <add namespace="DotNetNuke.Data" />
            <add namespace="DotNetNuke.Framework" />
            <add namespace="DotNetNuke.Modules" />
            <add namespace="DotNetNuke.Security" />
            <add namespace="DotNetNuke.Services" />
            <add namespace="DotNetNuke.UI" />
            <add namespace="DotNetNuke.Entities.Portals" />
            <add namespace="DotNetNuke.Common.Utilities" />
            <add namespace="DotNetNuke.Services.Exceptions" />
            <add namespace="DotNetNuke.Entities.Tabs" />
          </namespaces>
        </pages>
        <!-- ASP.NET 2 Membership/Profile/Role and AnonymousAuthentication Providers -->
        <!-- anonymousIdentification configuration:
              enabled="[true|false]"                              Feature is enabled?
              cookieName=".ASPXANONYMOUS"                         Cookie Name
              cookieTimeout="100000"                              Cookie Timeout in minutes
              cookiePath="/"                                      Cookie Path
              cookieRequireSSL="[true|false]"                     Set Secure bit in Cookie
              cookieSlidingExpiration="[true|false]"              Reissue expiring cookies?
              cookieProtection="[None|Validation|Encryption|All]" How to protect cookies from being read/tampered
              domain="[domain]"                                   Enables output of the "domain" cookie attribute set to the specified value
            -->
        <anonymousIdentification enabled="true" cookieName=".ASPXANONYMOUS" cookieTimeout="100000" cookiePath="/" cookieRequireSSL="false" cookieSlidingExpiration="true" cookieProtection="None" domain="" />
        <membership defaultProvider="AspNetSqlMembershipProvider" userIsOnlineTimeWindow="15">
          <providers>
            <clear />
            <!-- Configuration for DNNSQLMembershipProvider:
                  connectionStringName="string"               Name corresponding to the entry in <connectionStrings> section where the connection string for the provider is specified
                  passwordAttemptThreshold="int"              The number of failed password attempts, or failed password answer attempts that are allowed before locking out a user?s account
                  passwordAttemptWindow="int"                 The time window, in minutes, during which failed password attempts and failed password answer attempts are tracked
                  enablePasswordRetrieval="[true|false]"      Should the provider support password retrievals
                  enablePasswordReset="[true|false]"          Should the provider support password resets
                  requiresQuestionAndAnswer="[true|false]"    Should the provider require Q & A
                        minRequiredPasswordLength="int"                  The minimum password length
                        minRequiredNonalphanumericCharacters="int"  The minimum number of non-alphanumeric characters
                  applicationName="string"                    Optional string to identity the application: defaults to Application Metabase path
                  requiresUniqueEmail="[true|false]"          Should the provider require a unique email to be specified
                  passwordFormat="[Clear|Hashed|Encrypted]"   Storage format for the password: Hashed (SHA1), Clear or Encrypted (Triple-DES)
                  description="string"                        Description of what the provider does
            -->
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="SiteSqlServer" enablePasswordRetrieval="true" enablePasswordReset="true" requiresQuestionAndAnswer="false" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="0" requiresUniqueEmail="false" passwordFormat="Encrypted" applicationName="DotNetNuke" description="Stores and retrieves membership data from the local Microsoft SQL Server database" />
          </providers>
        </membership>
      </system.web>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <probing privatePath="bin;bin\HttpModules;bin\Providers;bin\Modules;bin\Support;" />
        </assemblyBinding>
      </runtime>
      <dotnetnuke>
        <htmlEditor defaultProvider="FckHtmlEditorProvider">
          <providers>
            <clear />
            <add name="FckHtmlEditorProvider" type="DotNetNuke.HtmlEditor.FckHtmlEditorProvider.FckHtmlEditorProvider, DotNetNuke.FckHtmlEditorProvider" providerPath="~/Providers/HtmlEditorProviders/Fck/" CustomConfigurationPath="~/Providers/HtmlEditorProviders/Fck/custom/FCKConfig.js" EnhancedSecurityDefault="false" SecureConfigurationPath="~/Providers/HtmlEditorProviders/Fck/custom/FCKConfigSecure.js" ImageGalleryPath="~/Providers/HtmlEditorProviders/Fck/fckimagegallery.aspx" ImageUploadPath="~/Providers/HtmlEditorProviders/Fck/fckimagegallery.aspx" ImageAllowedFileTypes="gif,png,bmp,jpg" FlashGalleryPath="~/Providers/HtmlEditorProviders/Fck/fckimagegallery.aspx" FlashUploadPath="~/Providers/HtmlEditorProviders/Fck/fckimagegallery.aspx" FlashAllowedFileTypes="fla,swf" LinksGalleryPath="~/Providers/HtmlEditorProviders/Fck/fcklinkgallery.aspx" DynamicStylesGeneratorPath="~/Providers/HtmlEditorProviders/Fck/FCKStyles.aspx" DynamicStylesCaseSensitive="true" DynamicStylesGeneratorFilter="controlpanel|filemanager|mainmenu|wizard" StaticStylesFile="~/Providers/HtmlEditorProviders/Fck/FCKeditor/fckstyles.xml" StylesDefaultMode="dynamic" DynamicCSSGeneratorPath="~/Providers/HtmlEditorProviders/Fck/FCKCSS.aspx" StaticCSSFile="~/Providers/HtmlEditorProviders/Fck/FCKeditor/editor/css/fck_editorarea.css" CSSDefaultMode="dynamic" spellCheck="ieSpell" AvailableToolbarSkins="Office2003,Silver" DefaultToolbarSkin="Office2003" AvailableToolBarSets="DNNDefault,Default,NoGallery,Basic" DefaultToolbarSet="DNNDefault" DefaultImageGallerySkin="Default" DefaultFlashGallerySkin="Default" DefaultLinksGallerySkin="Default" FCKDebugMode="false" UseFCKSource="false" OptionsOpenMode="ShowModalDialog" ShowModuleType="true" FixOldDNNPostback="false" CustomOptionsDialog="Admin" />
          </providers>
        </htmlEditor>
        <navigationControl defaultProvider="SolpartMenuNavigationProvider">
          <providers>
            <clear />
            <add name="SolpartMenuNavigationProvider" type="DotNetNuke.NavigationControl.SolpartMenuNavigationProvider, DotNetNuke.SolpartMenuNavigationProvider" providerPath="~\Providers\NavigationProviders\SolpartMenuNavigationProvider\" />
            <add name="DNNMenuNavigationProvider" type="DotNetNuke.NavigationControl.DNNMenuNavigationProvider, DotNetNuke.DNNMenuNavigationProvider" providerPath="~\Providers\NavigationProviders\DNNMenuNavigationProvider\" />
            <add name="DNNTreeNavigationProvider" type="DotNetNuke.NavigationControl.DNNTreeNavigationProvider, DotNetNuke.DNNTreeNavigationProvider" providerPath="~\Providers\NavigationProviders\DNNTreeNavigationProvider\" />
            <add name="DNNDropDownNavigationProvider" type="DotNetNuke.NavigationControl.DNNDropDownNavigationProvider, DotNetNuke.DNNDropDownNavigationProvider" providerPath="~\Providers\NavigationProviders\DNNDropDownNavigationProvider\" />
            <add name="ASP2MenuNavigationProvider" type="DotNetNuke.NavigationControl.ASP2MenuNavigationProvider, DotNetNuke.ASP2MenuNavigationProvider" providerPath="~\Providers\NavigationProviders\ASP2MenuNavigationProvider\" />
          </providers>
        </navigationControl>
        <searchIndex defaultProvider="ModuleIndexProvider">
          <providers>
            <clear />
            <add name="ModuleIndexProvider" type="DotNetNuke.Services.Search.ModuleIndexer, DotNetNuke.Search.Index" providerPath="~\Providers\SearchProviders\ModuleIndexer\" />
          </providers>
        </searchIndex>
        <searchDataStore defaultProvider="SearchDataStoreProvider">
          <providers>
            <clear />
            <add name="SearchDataStoreProvider" type="DotNetNuke.Services.Search.SearchDataStore, DotNetNuke.Search.DataStore" providerPath="~\Providers\SearchProviders\SearchDataStore\" />
          </providers>
        </searchDataStore>
        <data defaultProvider="SqlDataProvider">
          <providers>
            <clear />
            <add name="SqlDataProvider" type="DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider" connectionStringName="SiteSqlServer" upgradeConnectionString="" providerPath="~\Providers\DataProviders\SqlDataProvider\" objectQualifier="" databaseOwner="dbo" />
          </providers>
        </data>
        <logging defaultProvider="DBLoggingProvider">
          <providers>
            <clear />
            <add name="XMLLoggingProvider" type="DotNetNuke.Services.Log.EventLog.XMLLoggingProvider, DotNetNuke.XMLLoggingProvider" configfilename="LogConfig.xml.resources" providerPath="~\Providers\LoggingProviders\XMLLoggingProvider\" />
            <add name="DBLoggingProvider" type="DotNetNuke.Services.Log.EventLog.DBLoggingProvider.DBLoggingProvider, DotNetNuke.Provider.DBLoggingProvider" providerPath="~\Providers\LoggingProviders\Provider.DBLoggingProvider\" />
          </providers>
        </logging>
        <scheduling defaultProvider="DNNScheduler">
          <providers>
            <clear />
            <add name="DNNScheduler" type="DotNetNuke.Services.Scheduling.DNNScheduling.DNNScheduler, DotNetNuke.DNNScheduler" providerPath="~\Providers\SchedulingProviders\DNNScheduler\" debug="false" maxThreads="1" />
          </providers>
        </scheduling>
        <friendlyUrl defaultProvider="DNNFriendlyUrl">
          <providers>
            <clear />
            <add name="DNNFriendlyUrl" type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" />
          </providers>
        </friendlyUrl>
        <caching defaultProvider="FileBasedCachingProvider">
          <providers>
            <clear />
            <add name="FileBasedCachingProvider" type="DotNetNuke.Services.Cache.FileBasedCachingProvider.FBCachingProvider, DotNetNuke.Caching.FileBasedCachingProvider" providerPath="~\Providers\CachingProviders\FileBasedCachingProvider\" />
            <add name="BroadcastPollingCachingProvider" type="DotNetNuke.Services.Cache.BroadcastPollingCachingProvider.BPCachingProvider, DotNetNuke.Caching.BroadcastPollingCachingProvider" providerPath="~\Providers\CachingProviders\BroadcastPollingCachingProvider\" />
          </providers>
        </caching>
        <authentication defaultProvider="ADSIAuthenticationProvider">
          <providers>
            <clear />
            <add name="ADSIAuthenticationProvider" type="DotNetNuke.Authentication.ActiveDirectory.ADSI.ADSIProvider, DotNetNuke.Authentication.ActiveDirectory" providerPath="~\Providers\AuthenticationProviders\ADSIProvider\" />
          </providers>
        </authentication>
        <members defaultProvider="AspNetMembershipProvider">
          <providers>
            <clear />
            <add name="AspNetMembershipProvider" type="DotNetNuke.Security.Membership.AspNetMembershipProvider, DotNetNuke.Provider.AspNetProvider" providerPath="~\Providers\MembershipProviders\AspNetMembershipProvider\" />
          </providers>
        </members>
        <roles defaultProvider="DNNRoleProvider">
          <providers>
            <clear />
            <add name="DNNRoleProvider" type="DotNetNuke.Security.Membership.DNNRoleProvider, DotNetNuke.Provider.DNNProvider" providerPath="~\Providers\MembershipProviders\DNNMembershipProvider\" />
          </providers>
        </roles>
        <profiles defaultProvider="DNNProfileProvider">
          <providers>
            <clear />
            <add name="DNNProfileProvider" type="DotNetNuke.Security.Profile.DNNProfileProvider, DotNetNuke.Provider.DNNProvider" providerPath="~\Providers\MembershipProviders\DNNMembershipProvider\" />
          </providers>
        </profiles>
      </dotnetnuke>
      <system.webServer>
        <!-- The system.webServer section is required for IIS7 compatability It is ignored by IIS6-->
        <modules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="managedHandler" />
          <add name="Compression" type="DotNetNuke.HttpModules.Compression.CompressionModule, DotNetNuke.HttpModules" preCondition="managedHandler" />
          <add name="RequestFilter" type="DotNetNuke.HttpModules.RequestFilter.RequestFilterModule, DotNetNuke.HttpModules" preCondition="managedHandler" />
          <add name="UrlRewrite" type="DotNetNuke.HttpModules.UrlRewriteModule, DotNetNuke.HttpModules" preCondition="managedHandler" />
          <add name="Exception" type="DotNetNuke.HttpModules.Exceptions.ExceptionModule, DotNetNuke.HttpModules" preCondition="managedHandler" />
          <add name="UsersOnline" type="DotNetNuke.HttpModules.UsersOnline.UsersOnlineModule, DotNetNuke.HttpModules" preCondition="managedHandler" />
          <add name="DNNMembership" type="DotNetNuke.HttpModules.Membership.MembershipModule, DotNetNuke.HttpModules" preCondition="managedHandler" />
          <add name="Personalization" type="DotNetNuke.HttpModules.Personalization.PersonalizationModule, DotNetNuke.HttpModules" preCondition="managedHandler" />
        </modules>
        <handlers>
          <add name="AJAX_ScriptResourceHandler" path="ScriptResource.axd" verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv2.0" />
          <add name="AJAX_AppServiceHandler" path="*_AppService.axd" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv2.0" />
          <add name="AJAX_WebServiceHandler" path="*.asmx" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv2.0" />
          <add name="LogoffHandler*" path="Logoff.aspx" verb="*" type="DotNetNuke.Services.Authentication.LogOffHandler, DotNetNuke" preCondition="integratedMode,runtimeVersionv2.0" />
          <add name="RSSJandler" path="RSS.aspx" verb="*" type="DotNetNuke.Services.Syndication.RssHandler, DotNetNuke" preCondition="integratedMode,runtimeVersionv2.0" />
          <add name="LinkClickHandler" path="LinkClick.aspx" verb="*" type="DotNetNuke.Services.FileSystem.FileServerHandler, DotNetNuke" preCondition="integratedMode,runtimeVersionv2.0" />
          <add name="CaptchaHandler" path="*.captcha.aspx" verb="*" type="DotNetNuke.UI.WebControls.CaptchaHandler, DotNetNuke" preCondition="integratedMode,runtimeVersionv2.0" />
        </handlers>
        <validation validateIntegratedModeConfiguration="false" />
        <defaultDocument>
          <files>
            <clear />
            <add value="Default.aspx" />
            <add value="Index.html" />
            <add value="Index.htm" />
            <add value="Index.cfm" />
            <add value="Index.shtml" />
            <add value="Index.shtm" />
            <add value="Index.stm" />
            <add value="Index.php" />
            <add value="Index.php3" />
            <add value="Index.asp" />
            <add value="Index.aspx" />
            <add value="Default.htm" />
            <add value="Default.asp" />
          </files>
        </defaultDocument>
            <httpErrors errorMode="Detailed" />
      </system.webServer>
    </configuration>

    Thanks.

    Monday, April 15, 2013 8:01 PM
  • User2125765622 posted

    I don't see anything out of sorts in your web.config... Can you check your references in the project and make sure that those dll's are referenced correctly? I would suggest setting them to copylocal = true in the reference instead of having them in the GAC (if they are). Was your original site on this same server before or did you migrate to this one from somewhere else?

    Tuesday, April 16, 2013 11:13 AM
  • User-1067128194 posted

    Hi Mike

    The website is still not working. Tried everything.

    I installed VS 2008 and tried running the webiste in there.

    The error that is giving is

    Error 103 It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS. C:\inetpub\vhosts\abc.com\httpdocs\web.config Line 57

    The above error on Line 57. Line 57 reads:

    <machineKey decryption="Auto" decryptionKey="AutoGenerate" validation="SHA1" validationKey="AutoGenerate" />

    Tried to do a bit of googleing but still unable to resolve this.

    Please help.

    Thanks

     

    Monday, May 6, 2013 2:43 AM
  • User2125765622 posted

    So that error is usually one of two things. Either the deployed site is not set up as a virtual directory in IIS or there is a web.config file in a subdirectory of your site that has properties that are only allowed in the root web.config. 

    Can you verify that your site is set up as an application in IIS?

    Can you verify that you do not have any subdirectory web.configs with invalid properties?

    Regards, 

    Mike

    Monday, May 6, 2013 4:00 PM
  • User-1067128194 posted

    Hi Mike

    Can you verify that your site is set up as an application in IIS?

    ----I am not sure about this. It has an application Pool. I am running IIS 7.5 and its a bit different. None of the directories have been converted to application in there.

    Can you verify that you do not have any subdirectory web.configs with invalid properties?

    ---Yes. We do not have any other web.config files in any subdirectory.

     

    Thanks

    Wednesday, May 8, 2013 1:35 AM