locked
Cannot run test. An item with the same key has already been added. RRS feed

  • Question

  • Hello,

    I am using VSTS 2012 Ultimate but it doesn't have a Forum.

    I have created a load test from a number of different webtests and when I run the load test I am getting the error message;

    "Could not run loadtest 'NSWH Primary' on agent 'PQA-SS': An item with the same key has already been added"

    NSWH Primary is the load test

    PQA-SS is my desk top thaqt I have been using as an agent.

    Can anyone tell me why this is happening and the load test will not run, or how I can get the loadtest to run?

    Thanks


    • Edited by SteveBrk Wednesday, June 5, 2013 3:29 PM
    Wednesday, June 5, 2013 3:27 PM

Answers

  • Hello,

    Thank you for your post.

    I did a search about this error message and find this thread:

    http://social.msdn.microsoft.com/Forums/en-US/vsmantest/thread/f5df952b-2f11-48d2-9fa1-a35a8d09ab37

    Based on Hnoell2’s posts, it seems that this issue may occur in a TFS level or Team Collection level.

    I would like to know whether you run the load test in a lab environment in MTM? If so, you can try Hnoell2’s solution to troubleshoot this issue.

    If you are not working with TFS and MTM, I suggest that you try to restart test controller and test agent service, restart VS as Admin and create a simple web test and load test. After that you run the load test locally and remotely to check the result.

    If you still get this issue, I suggest that you try to repair your VS.

    If you have other environment, I suggest that you install a test agent on another machine and then try the same scenario to check the result.

    Best regards,


    Amanda Zhu [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Amanda Zhu Tuesday, June 11, 2013 6:13 AM
    Thursday, June 6, 2013 5:52 AM